USB-C Multiport Connectivity on L14

Update: Has anyone successfully purchased an SD to USB converter that works on the L14? I’ve tried 3 with no success. The first 2 were more complex, multiport hubs with all kinds of ports. I thought “maybe this is too complex and confounding the L14”. So the third was a bare bones single SD to USB drive - no success. I don’t know what kind of technical specification to look for prior to making a purchase. I only know that I plug them in and they don’t work. All 3 have worked on my wife’s windows laptop so I don’t know what feature there is enabling the connectivity with these drives.


I have a point and shoot camera that utilizes a full size SD card for storage. The L14 does not have a full size SD port so I got a Satechi USB-C multiport adapter that has (among other ports) an SD slot. My problem has been getting drives to connect to the L14 through this device. For example it seems to read standard USB drives all right, but it will not read my SD card nor does it read the USB-C port. When I connect the multiport device to my wife’s Windows machine all the I can connect any drive and it reads them right away. On the Windows I can even connect my external DVD player to the USB port on the multiport device and it will play. When I try this on my L14 the drive just winds up and dies, winds up and dies, etc.

Do I need to install some kind of firmware or something to enable proper connectivity through my multiport thing on the L14?

That device looks like overkill for the task at hand. You really just want a simple USB dongle for reading uSD or SD cards, which can be bought for bugger all (particularly if you don’t care about performance), and in that case you would just use a USB-A port on the laptop.

That said, a lot could be going wrong with the more complex device.

The DVD player “winds up and dies” suggests maybe insufficient power. The power negotiation between the L14 and the dock may be failing.

For exhaustive testing, you need to try the dock in each of the two USB-C ports on the L14. One is a full-functionality Power Delivery / DisplayPort altmode (video) USB-C port and one is a vanilla (data only) USB-C port. The former sounds like a better bet.

You also need to try the USB-C cable in both orientations (in each USB-C port).

Regardless, you should use lsusb (and lsusb -v -s... on the specific USB device if anything shows up) to see what is being detected each time you plug in to test.

If you want to persevere with this then it is always helpful to provide a link to the product specifications (not just a photo) since you can’t assume that randoms on the internet (like me) have access to every single possible device or can work out the model number.

Unlikely - but a product link might shed light on compatibility.