USB-C port has stopped working

I am no longer able to charge my phone through USB-C, and the USB no longer work for other things either. Connecting the HOYOKI USB hub no longer works with external display (HDMI). I can no longer connect a USB keyboard into the phone either.

This has gradually been getting worse over the last week. First, I had trouble getting a steady charging light, and I had to use the charging troubleshooting from after the phone was draining battery instead of charging. Now there is no charging light at all, even when holding volume up and inserting the battery slowly.

I have tried to charge with different chargers and many different cables, both usb-c to usb-c and usb-a to usb-c. I have tried the usb-c cables in both orientations.

I have already sent an email to support, and they have been very helpful and quick to reply before. I post the question here as well to see if anyone has suggestions for troubleshooting or know of a fix I can try, as this is my daily driver.

It sounds like USB-C connector on your phone has physically lost connection. It might be due to cold solder, or mechanical stress. If that’s the case, it can be replaced or soldered back to the motherboard.

You should anyway wait for the support to help you troubleshoot the issue before trying anything else.