USB Ethernet Settings On PureOS boot?

I’m trying to get an Ethernet connection to work in PureOS boot.

The Ethernet shows connected, but I can’t get any data thru.

It is set to “automatic”. Do I need to set it up manually?

If so, what are the settings that generally work?

I’m using a USB tether from a Android phone.

I’m trying to pipe the USB through the Ethernet adaptor. It worked perfectly fine in the Qubes boot. Its not working in PureOS.

Any ideas?

“not working” equates to? An error message? No observable result?

So this is just a vanilla PureOS boot? Not using VM etc.? Or?

With a vanilla PureOS boot, I would start by doing lsusb before plugging in and then repeat afterwards to see whether any USB device is recognised at all.

If your WiFi is working (on laptop and on Android phone), it may be less demanding to tether via WiFi. Less software has to be working. Less potential user mucking around.

“not working” = The ethernet shows as connected, but I cannot access the internet.

I tried a USB boot using Etcher + PureOS ISO to create a bootable USB. That boot shows the same ethernet symptoms. Wifi connects. Not the Ethernet.

I had similar issues with Qubes VMs. But Qubes root could connect through the USB just fine. The fix on the VMs was to manually setup the connection. The Qubes VM gave you all those settings to do so. I have no idea how to get those settings for a PureOS boot?

Where would I get the DNS info to test a manual setup?

hi ! could you please check if you have network-manager-gnome installed ? most modern distro releases just assume everybody is connecting through wifi so they don’t have the following preinstalled which kinda’ sucks because in order to get it you would have to have it as a .deb somewhere before booting from the .iso …

sudo apt install network-manager-gnome

then if the CLI tells you that you have it just



ip a < to see your ip if your ping is good

if PureOS doesn’t have it preinstalled as part of the distribution you need Debian stable

i checked bullseye and it’s not there. i’d be curious if the new ubuntu LTS coming sometime later in april will have the same issue … FYI 18.04 was good on that note …