Using the context menu in Files/Nautilus

On my newly arrived Purism 5 with all updates, I cannot figure out how to delete a file using the Files/Nautilus app. When hold down my finger on a file to emulate “right click” to get the context menu to come up, the menu disappears as soon as I remove my finger.

How in the world is this supposed to work? Is the context menu supposed to stay open so I can select an option? Just FYI I cannot just slide my finger to the option I want on the menu, it disappears.


So I found one way to do this… go into Usage and check Storage. That gave me a check box to delete the file. Now I would like to adjust the file preferences using the menu. How do I keep the context menu on the screen long enough to click something on it?

1 Like

It’s a current painpoint. I had the same problem.

The (vomit) solution that I came up with is … touch the file (dismiss ImageMagick or whatever might get launched) then bring up the keyboard (selecting the Terminal keyboard if not already selected, and selecting the special keys (>_) if not already selected) then touch Del. Job done.

Then touch x to dismiss the Undo option (although it will disappear automatically after X seconds).

The Context menu did actually work just once when I was fumbling around but I was never able to reproduce that.


I strongly recommend setting up flatpak and installing portfolio. It’s considerable better than nautilous.

(moving and deleting files is easy)


I use Nemo instead. (Confusingly, also called Files.) It has all the menu options you expect, and they operate as normal.


@steve Thank you for the response. So Portfolio works on the Purism 5 device without needing access to menus normally accessed by a right click? Is it also an adaptive application?

@amarok Thank you for the recommendation. I will take a look at Nemo. Odd that it would work fine, but Nautilus would not when it is one specifically being worked on for a mobile device.

1 Like

I know portfolio works in the mobile form factor, not sure what it looks like on the desktop.

It does requires you to press and hold on a file to select the file and go into ‘select’ mode where you can select more my tapping them, or exit select mode by tapping the file again ‘unselecting’ it. When in select mode you can rename, move, copy, etc from buttons on the bottom.

That’s a GTK bug:

I’ll be looking into resolving it in some near future.


Just wanted to say that I’m glad everytime I’m scrolling through the latest topics on the forums overview and seeing your avatar @dos as the latest response on topics I’m interested in. Thanks!


I like seeing any of the staff providing technical expertise here in the forums. They always have the most thorough, timely, and well-explained solutions.

1 Like

Thank you for the response! I am looking forward to seeing how the phone’s software stack improves over time.

In the browser (Epiphany?) some days, I can somewhat reliably get the context menu to work by timing the release of my finger just right: a fraction of a second before the menu appears. This causes the menu to stay on screen, but takes some practice. However, I have as yet been unable to pull off the same trick in Nautilus.

1 Like

@amarok Thanks for the referral to Nemo, that works great! Thank you!

1 Like

I installed Portfolio and overall really like the look and function, but I can’t seem to access my Nextcloud cloud drive in Portfolio, possibly due to Portfolio not being able to access my keychain? Any ideas?

No idea, I know that it shows my usb drive when I plug that in so it does support other stuff that’s mounted.

Might be worth opening up an issue in

1 Like

My own situation in “Files” and Nautilus. I have a Librem 5 with PureOS 10.0.

Bumb. This still exists. Even on Nemo (no keychain and no menu from touch at all - is it just me?), which luckily has standard menus on the top.

1 Like

Still today, nautilus is unusable for me. Still no way to invoke context menu actions.

Even opening a directory doesn’t reliable work. If I set “Single Click” in the corresponding preference, tap only selects, but doesn’t open. When I select “Double Click” I couldn’t even recognize the scheme of how the app reacts to various tapping gestures.

Back then I was willing to invest time into helping, but with everybody just pointing fingers at another component, I have no idea when/who/how this will ever be resolved.

Interestingly, just the other day I noticed that context menus work properly in firefox and even epiphany: menu pops up on release of a long press. Just that epiphany has no affordance for marking text, so still no copy & paste etc.

1 Like

Back then I was willing to invest time into helping, but with everybody just pointing fingers at another component, I have no idea when/who/how this will ever be resolved.

I’m not aware of any finger pointing in different direction than GTK closing the popup when receiving motion events on a touch point that was active before the popup has been opened. This doesn’t happen on Mutter only because Mutter cancels the old touch point, which isn’t mandated by the spec. Did someone say something else?