Vibration on-off

Not that I’m aware of. That’s a question for Purism.

There’s vibration settings in the mobile configs app but I haven’t really explored it.

Are you talking about the app Mobile Settings? This allows for the app Calls to select between full / quiet / silent, but not to switch off vibration.

Ah yeah that’s right. Well… nevermind.

Or for the sources? I mean surely it must be possible to do it?

1 Like

No, it’s for filing an issue in the bug tracker.

Here we go:

1 Like

Yes it is possible but not from the interface. You have to sacrifice the vibration from the quiet settings. It seems that the full profile is built in a down to top logic. So full includes the quite profile. And the quiet profile has vibration on. If you remove the vibration from the quiet profile, then vibration is not present in the full profile and you are done.

cd /usr/share/feedbackd/themes/
cp default.json default-orig.json (for backup purposes)

open the default.json file for editing as root (say sudo vi default.json)
scroll down to the quiet profile and locate and delete the section:

      "event-name" : "phone-incoming-call",
      "type"       : "VibraPeriodic",
      "duration"   : 10000

being careful to preserve the format of the file. Save and reboot.

Now you will be receiving calls without vibration, only sound.

This will be overwritten with any update of this file and you will have to re-do it. It is supposed that if copied in the .local directory of the purism user then the setting will persist but I did not manage to do that. It seems that this is ignored if set for the user and not systemwide as above.

In any case this is a solution.


Thanks, I’ve changed the 10000 (ms?) to 0. Works fine. Thanks again.


Great discussion. I have the opposite request. For keyboard usage, I really like the vibration. But, it is so light. I don’t know if I’ve pressed a key or not. @antonis, can I use that same file to adjust the intensity of the vibration for keyboard presses? I notice the intensity of the vibration can vary depending upon what keyboard or situation I’m in. entering the keyring password vs. the luks password for instance.

It would be nice to be able to config these different scenarious.

By definition, when entering the LUKS password, the above file hasn’t been decrypted yet (i.e. the file system that it is on hasn’t been made available unencrypted yet), so it must be using either hard-coded behaviour or a different config file - or so I suppose.

I have not tested anything relating to keyboard. Does this file have relative entries? I do not remember, I have to check. But maybe @dcz knows better about this.

Note that you don’t need to modify the file shipped by the package, you can override the config in your hoome directory:


Thanks @guido.gunther!

Thanks. I rolled back by changes and described the config below $HOME in my internal readme as:

   The vibration can be switched off by modifying the file a local
   copy of the defaul.json file:

   mkdir -p ~/.config/feedbackd/themes
   cp -p /usr/share/feedbackd/themes/default.json ~/.config/feedbackd/themes

   modify in the local default.json file the 10000 to 0
   in this section (line 134):

      "event-name" : "phone-incoming-call",
      "type"       : "VibraPeriodic",
      "duration"   : 10000

   SIGHUP the feedbackd:

   ps ax | grep feed
   1458 ?        Sl     0:48 /usr/libexec/feedbackd
   sudo kill -HUP 1458

Works fine!

1 Like

Yes this is how it is supposed to work. But it did not work on my L5, this is why I modified the distributed file. But maybe I did some mistake. I will retry.

But the logic with which this is built is not very convenient I think. For example you can not have only sound in the full profile and vibration on the quiet profile because the full loads the quiet. They should have been independent in order for such a configuration to work.

And do not think to copy the incoming call section to the full profile with VibraPeriodic set to 0, thinking that this might overwrite the quiet setting of the 10000. I just tried that and resulted in a phone that refused to reach the login screen!

Luckily enough ssh was still working and I reverted the file.

I followed the instructions at the link @guido.gunther provided and my keyboard vibrations are better for me. This worked nice for me. Adjusting the file is a bit confusing, but I was able to make it work.

1 Like

I think that a good additon to feedbackd is to allow for using the led. The led flashing for inciming calls will be very useful in noisy environments.