Virtual Private Network

Was anybody able to run vpn from PIA (
I was able to download and install their program for linux (
But the program does not run (i.e. no window pops out asking for username and password). PIA said they don’t support any derivation of Linux (including PureOS).
If not PIA, were you able to install and run any other vpn provider?

Not sure how to run the clients. I have used a couple of VPN services including PIA, but now always just use openvpn and not the providers client. In my opinion PIA’s client software communicates a lot more with their vpn servers that what is needed (it talks with them even when you are not asking it to connect). It is a bit more work setting up the open-vpn, but i have it working well on my librem with pureos.
As far as i remember you can find a guide on PIA’s webpage on how to add their servers once you have openvpn installed and working.

1 Like

I personally haven’t used ProtonVPN on PureOS or any other OS but some friends of mine like it so I thought I’d give you the link so you can maybe do a research on it.

Thanks for the detailed info.

Thanks for the information. I will test out protonvpn.

FWIW, I ran into the same problem with the PIA desktop client, and have still not been able to run it successfully. And when visiting PIA’s main website the toolbar showed that my connection was unprotected.

I ended up using the the following instructions from PIA’s support to automate installation of VPN connections (regions) via OpenVPN:

The instructions were very straight-forward and the setup script provided complete configuration for all the connections/regions in OpenVPN normally provided in PIA’s desktop app.

Some of the PIA Desktop’s user-friendly features like green/red toolbar indicator and WiFi killswitch aren’t included, requiring additional setup/helper apps. But otherwise the connections are working without a hitch.

Alternatively you may follow the instructions in the following forum post to import the settings into OpenVPN manually per connection/region [note: unlike above these instructions setup one connection at a time]: