Virtualbox Failed upon start/loading of PureOS ISO

I installed the latest Virtual Box version on the host Mac OS 10.15.7 Catalina. That worked smoothly.

I then tried to have VirtualBox run the latest PureOS ISO and during the ISO booting phase, VirtualBox keeps crashing and I get a crash report. The previous times I have used VirtualBox, it didn’t have these problems. Then again the last time I used virtual box was on the previous Mac OS 10.14 with no issues.

How can I help you solve this problem of mine?

I think it might be an issue with Virtual box. Try another ISO. If it is failing during boot then try windows, they don’t use Grub.

Try changing the settings on your virtual machine before starting it.

I appreciate your input @dean although I do not have a spare Windows OS License to test with. Costs way too much. I will try downloading a new ISO of PureOS and fidget with the VirtualBox settings.

You don’t need a Windows license when running in a virtual machine. Just go to their website and download a copy. That’s the only way I have used Windows in the last 10 years.


@dean A very valuable comment, thank you.

If you post your crash report, maybe it has some info to indicate what is the problem.

If you can run Linux Mint 4 Debbie in VirtualBox on your Mac, then the problem is probably because you lack some proprietary firmware in PureOS for your hardware.

I am not a lawyer, but my reading of the Windows license said that it was free on a VDI – if the VDI ran on a licensed copy of Windows. My system at work has a mix of RedHat and Windows servers running on a cluster. The users run Windows 10 in VDI on a thin client via Citrix. The Windows clients had to be licensed.

At home, the only Windows running is 7 Professional running in VMWare (no internet access), but it is a licensed copy that I had laying around.

Windows licenses come with 99.9% of computers sold these days. If you’ve bought a laptop that came with Windows, you have a Windows license, and therefore can legally obtain and install Windows 10.

Interesting discussion for people running Windows in a VM in a Linux host, but @Jonathanta doesn’t need a Windows license. He is running PureOS in a VirtualBox on MacOS.

1 Like

Thank you for noticing correctly! @amosbatto I do not intend to use Windows at all, period.

I opened this thread to help figure out how to get PureOS to run properly using the latest VirtualBox software, in light of the errors I mentioned at the beginning.

Really hard to troubleshoot what is the problem if you don’t post the errors you are seeing or try installing the Mint version and see if it works. If it works, then you know that it is a proprietary driver issue. Then, install and run vrms to find out what proprietary stuff you have in Mint that is allowing it to work.

I found out what the problem is. I decided to check if the error was related to the VirtualBox software version, and it was. VBox version 5.2.44 works correctly without issues, with the settings being “.VDI”, “Linux”, “Debian 64-bit”, hard drive size: 200GB.

The most recent version of VBox is “6.1.14”, which has either one severe bug, or multiple bugs, that make running a virtual PureOS impossible and causes loading errors.


Edit: Since I was able to load virtual box and install PureOS into the Virtual Drive, this also tells me there aren’t any hostOS problems either.