VoLTE support progress

This makes me very sad. I was wanting to do this very thing.

You never know… The carrier might think the L5 is a car or a laptop. Try it!

1 Like

Well I was wanting to do so with my pixel in the meantime. Alas…

A (hopefully cheap-rate) international travel SIM will probably work with the Pixel. Surfroam’s data SIM works with my Android, with no complaints from the underlying roam network.

Bonus: The roam network may not get much PII on you from the overseas company. Plus, court orders might be harder to serve in a foreign country.

Keepgo.com is alternative to surfroam for a international data-only sim. Disclaimer: I haven’t tried this yet. I am considering it for the future as it appears that having VoLTE work on the librem 5 seems to be mainly up to the mobile network providers, not Purism. For the networks with a whitelist, if the librem 5 isn’t on it, there is nothing Purism can do. It is not really a technical issue at that point.

Per a response from @Kyle_Rankin on another thread (seen here New Post: I (Finally) Fired Google ), VoLTE can work with the BM818 (although Kyle was only saying it worked with his Librem 5 with AweSIM service). I don’t really want to spend $100/month for a phone that I mostly only need cellular service for phone calls (as I’m within trusted wifi range 95% of my life), so I’m attempting to get VoLTE working with service from T-Mobile. 4G data works just fine, but calls are only working via 3G (which I believe T-Mobile is planning to shut down in July). My IMEI shows up as fully compatible and not blocked on T-Mobile’s IMEI checker. Does anybody have experience with getting VoLTE to work with T-Mobile or a MVNO running on T-Mobile’s backbone?

The modem defaults to VoLTE being disabled, because being enabled on networks that don’t support VoLTE could result in the phone not working at all from my understanding. Here are the steps to enable/disable that mode but please be very careful with this and double check everything you are typing.

To Enable VoLTE:
sudo screen /dev/ttyUSB3

power cycle modem with kill switch

To Disable VoLTE:
sudo screen /dev/ttyUSB3

power cycle modem with kill switch

I was able to get this working on Google Fi (which uses TMobile’s backbone in this case).


Am I wrong to assume that all the major US carriers support VoLTE nationwide? Do you know of any that do not?

In addition, do the terminal commands you’ve given above for enabling VoLTE persist following powering up the L5 or do these need to be redone every time the phone is powered up or rebooted? Thanks.

1 Like

I had already run those commands with “socat” instead of “screen,” with this command to get to the shell to interact with the modem:
sudo socat - /dev/ttyUSB3,crnl

When I tried to run the commands you provided, @Kyle_Rankin, the “screen” shell didn’t seem to take keyboard input consistently.

EDIT: I think I finally was able to enter all of the commands into the “screen” shell to control the modem. I power-cycled the modem with the hardware switch (waiting 10 seconds between turning it off and on). I switched to 4G only mode, and now it appears that phone calls are being attempted via 4G, but it’s not going through. Before, if I was on 4G only and tried to make a call, the phone call would start and immediately end (I had this issue when I attempted to do the same thing on AT&T’s network with an AT&T SIM). Now the call appears to start, but just hangs at the calling screen. When I attempt to call my Librem 5 from another cell phone when I have the Librem in 4G only mode, it just immediately goes to voicemail. Does T-Mobile have to do anything to enable VoLTE calling for this modem?

All U.S. networks support VoLTE, but not all OEMs have tested and obtained network VoLTE certification for every one of their devices on every U.S. network. Some devices may be certified for this network, but not for that network.

The MVNOs operate over the major networks, so the device certification with the majors still applies.


See if you can receive incoming calls and if so, whether it stays on 4G. When attempting outgoing calls, first type *67 and then the number and see if that allows the call through.

You’re on a Tmobile MVNO, IIRC. So are you gonna take the plunge? :wink:

I am on a T-mobile MVNO, but I’ll wait for an official modem update. :slight_smile:

I’m not using the L5 as a phone at the moment, anyway.

1 Like

From what I recall from testing it myself was that it may work but doesn’t ever ring on your end for outbound calls. I think I also needed to reboot the phone completely to get it working as well.

If I have my mobile settings on “2G, 3G, 4G (Preferred),” incoming calls come in but the network switches to 3G. If I have my mobile settings on “4G Only,” incoming calls go straight to voicemail.

I believe I have seen the following happen twice:
Right after I run the modem commands via the “screen” shell and then power cycle the modem with the hardware switch, calls seem to attempt to work but just hang at this screen:

After waiting a good long time and clicking the red button to end the call and then waiting a good long time more, I tried a call again with the same behavior. After ending the second call, I got this following screen telling me I didn’t have a voice capable modem:

After power-cycling the modem with the hardware switch, while on “4G Only” calls just immediately end after attempting to initiate them. If I switch back to “2G, 3G, 4G (Preferred),” outgoing calls work but the phone switches to 3G.

Good question.

Any takers?

I think the emphasis is on L5 in that question.

No you should nit need to reperform the instructions after a reboot.

Is there a firmware update I need to install for the modem in order for it to do VoLTE?

Do you have data enabled in your Mobile network settings? That is a hard requirement for this to work as well.

No firmware update should be needed and once it’s set, the setting persists reboots.