Can't make or receive calls

USA and it’s Mint (T-Mobile). I don’t know if they use VoLTE.


Yes, they require VoLTE, as do all U.S. carriers now. Any phone model (or modem) that hasn’t been tested and certified for VoLTE with any of the three major carriers (and that means the particular VoLTE implementation that that carrier uses), will not even be approved for activation. In fact, if they detect a non-VoLTE capable phone on their network, some carriers (AT&T, and possibly Verizon) will disable your SIM for calls until you put it in a different VoLTE-capable phone. All the rest of the “carriers” are just MVNOs that run on one of the three major carriers’ networks, so they observe the majors’ requirements. (Except U.S. Cellular, which is regional, and I believe, a separate network.)

Fortunately, the BM818-A1 modem is known and approved for activation by T-mobile (and related MVNOs), because it is already certified for T-mobile’s particular VoLTE implementation. T-mobile is unaware, I’m sure, that your BM818-A1 does not currently have VoLTE enabled.

So, to make calls work, you’ll need to enable the (currently beta) VoLTE capability, according to Purism’s instructions, while we’re all waiting for it to be officially packaged and made available.


It would be great to know where these instructions are.

I think they might be in that recent VoLTE-themed thread. If not, you can email Support for them.

I think this is the relevant post (for anyone else looking):

[edit] This got it working for me.


I use Mint. Make sure register your phone with them. Update mobile and the Chatty settings to Mint “Wholesale” settings as recommended on their website.

Send me a DM and I will look up all my settings and send them to you.

Do you have MMS working.

Yes, but it took awhile. Setting had to be the same in mobile and Chatty.

Make sure register your phone with them.

Could you please elaborate? I’ve activated my sim card (best I can tell), are there further steps necessary to register my phone with mint?

Can anyone comment on the accuracy of these APN settings for mint?

I can’t seem to find a combination of settings that results in a “network status” (as seen in “modem details”) other than “Not Registered”.

Mine (on android) is:

MMS: 310
MNC: 240
APN Type: default,supl,ia,mms,xcap
APN Protocol: IPv6
APN Roaming Protocol: IPv4

1 Like

@g4stly, here are some search results: MMS support Telia Sweden?, Works on AirVoice and How will APN settings work?.

As above, within serviceproviders.xml all related APN data are written under: <name>T-Mobile</name>. Yet there, within this .xml file, popups this difference: vs:

                        <apn value="">
                                <plan type="postpaid"/>
                                <usage type="internet"/>
                                <name>T-Mobile LTE</name>

Autocorrect got me, fixed my typo.

1 Like

That can’t be true. My L5 is set to fall back to 2G, which it does for voice all the time – because I have not bothered to enable VoLTE. Audio quality and coverage, at least within 80 miles of Mojave California, are fine. As I drive around, I even get indications in the notifications bar of 2.5G, I rarely get another variation of 2G, but I forget what it said.

Except for the recent issue with MMS and Mint on the L5, I think Mint Mobile is pretty damned good.

1 Like

@Quarnero Thanks for your help. I’ve been informed I have a separate issue I need to fix before I can configure my APN. I noticed those two different suggestions in the forums too; the and but like I said a separate issue could be blocking one or both of them from working for me, because neither does at the moment.

This was an unwanted autocorrect, just FYI.

Ah, sorry. I didn’t notice you had mentioned that already.

As I mentioned earlier in the thread, I got calls working but I had two problems: battery drain and my sim card stopped working. So, I shelved it for now.

It looks like you are doing what I did. I live in the United States. I registered the Librem 5 with Mint, I use their suggested APN settings. I was having trouble with MMS on Chatty but everything seems to be working now. Sorry, I am not sure what else to say.

Suggested APN Settings Main BestMVNO Verified|APN Name|MINT|
| — | — |
|MMS Proxy||
|MMS Port||
|Authentication Type|PAP|
|APN Type|default,mms|
|APN Protocol|IPv4|
|APN Roaming Protocol|IPv4|
|MVNO Type|None|
|MVNO Type|

VoLTE is required for activation on the network, even if T-mobile still has some 2G to fall back on. Mint is aware that the BM818-A1 is VoLTE-certified on T-mobile’s network, even if you don’t have it turned on. That’s why they’re not making a fuss, probably. Eventually you start to have issues with calling if, and as, 2G starts disappearing.