VoLTE support progress

As far as I can tell, all my settings on the providers side are in order (I double checked), and all the firmware on my L5 is pretty recent (dated 2020 and with high version numbers - higher than most mentioned above).
I used the tool, I entered the required modem strings…

Still no VoLTE.

3G sunset on the T-mobile network over here in the Netherlands is still not upon us, but it would really, really be nice to not have to worry about basics like this.

So, is there any indication of when this problem will be solved? Purism is keeping pretty schtum on this subject, and I find that anything but reassuring.

Just tell to @joao.azevedo that you need to test firmwareS 2019 or 2021or 2022, 2023 in order to get the VoLTE working in your mobile workstation L5, i confident that if you test 2019 firmware version you got volte work. Also make sure that the other half also is supporting v.o.l.t.e.

OK. Lets try. Dear @joao.azevedo can we get some help with this somehow? Are there anywhere some written instructions to follow? Is there a firmware known to work? And how to get to that firmware version? Thank you.

And @joao.azevedo what is the actual firmware to look for? Is it what shows up in the bm818-tool, the reply to mmcli --modem=X, or what comes back after AT+BMSWVER?

I think I answered part of that question myself: I entered the line which allows you to send the modem strings (the line with ttyUSB3 in it), and then I ran the bm818-tool in order to compare the firmware versions.
This results in the modem commands send by the tool becoming visible in the terminal window. One of them is simply +BMSWVER.
Others are: +BMRAT, +CNMI, and $QCPDPIMSCFGE.

If I recall correctly we spoke some months ago about this. I will DM you.


By the way does anybody have the BM818 pdf that has all the AT codes listed that are supported? The documents i have reviewed do not show AT commands specific for the modem.

Never mind found it:


Running something like:


should find EPS network registration status.


@joao.azevedo contacted me about VoLTE and he gave me very clear instructions. I thank him.

All the commands for the flashing of the modem went through without any problem. No error reported. However, my phone still drops to 2G.

Is there any commands to debug this?

So, which firmware version did you flash?

The instructions I got from @joao.azevedo was saying

sudo apt install ./firmware-bm818-nonfree_0.6pureos1+librem5ci78950.0a39dc2_arm64.deb

It is true that the repository had also a 0.4 version but I will not do that unless I am explicitly told it should be done. Because I use the phone and I need it to be working.

By the way what is this CBS Enable?

1 Like

do you remember the link to the repository? Since i cant receive mms or send id like to try.

MMS and VoLTE are not related.

1 Like

Did the call went trough?

Is the username on your phone purism the bm818-tools package will need to be tweaked if the username is different.

ok gotcha my bad

The answer to both questions is YES. Calls go through but it drops to 2G. I have not changed anything relating to user purism (no other user, just the default).

One thing that might be different is that I have not updated the calls app. i do not know if this might be the reason. I did not update because the current is alpha and had some issues. Maybe they have been resolved now though. Should I upgrade that?

In the past (a year ago) I had tried to execute some AT commands for VoLTE. I do not know if this has saved something to the modem configuration. Is there a way to do a full reset of the modem?

But something looks different than before:


+BMSWVER: M100E_YCSN0_1.0.0_220926,YCSN0_M100E_1BAD_3117_V1.0.0.2_20220930,M100E_1.0.4_200715



Previously instead of GPRS it was saying EDGE. Does this mean something?

All in all, it seems to me that this VoLTE thing is becoming a bit of an uphill struggle.
A few people claim the solutions offered above work for them, most however report negative results (including myself).

@joao.azevedo: Can anyone, please, curb my pessimism?

Yes: both 2G, GPRS being even worse than EDGE.

Is that the name that can be changed under Settings --> Users, or is it the first bit of the command line in the terminal?
(I take it, it is not the device name; the bit that can be changed under Settings --> About (and which shows up as the second part of the command line prompt, after the @).

So I upgraded to get to something worse? :unamused: