VoLTE support progress

Great work Purism!


where is that setting?


fiacco: It need install: https://source.puri.sm/Librem5/bm818-tools/-/jobs/390480/artifacts/download
after install execute: sudo usermod -a -G dialout purism then reboot, then will see an app on Home, in order to work it need the modem enabled with sim card.


Seems you stumbled onto a tool that one of our devs recently made like 3 days ago :wink:

Since this is still quite recent there are still some things to sort out and some merge requests have been done to address it.

This is something that will be addressed in a next version so that people do not have to do this step manually.
Another is to improve the LTE call test.

So while the basics are already there it is still a work in progress.


Yes i stumbled with the newer Purism-tools for the modem, i shared the version 0.1 but now already exist the version v0.5 with more fruits. With this tools i finally tested the VoLTE on my Librem 5 and it work really good on my case, the only bad things it that the modem crash very often, i hope that Purism programmers fix this bug.

Would this likely be any use with my issue regarding not being able to connect to T-mobile?

i wonder if using this could create new or unforseen issues when VOLTE is already enabled through Awesim AT&T for example?

It will not add an issue if you install the VoLTE app when v.o.l.t.e. it already enabled manually. It safe to go.

1 Like

how do you get that screen option? i cant find it in gnome settings after install and unning of command.

It’s not there. It will set itself up as a little icon among the other apps. Remember, it’s still in development and may change.

weird there is none for me, maybe the install did not work when selecting .deb and letting the package software install do its thing.

When using the terminal to install it worked and shows up as an icon in the apps.

sudo apt install ./bm818*.deb

With modem-bm818 firmware v2021.09 the VoLTE do not work like calls fallback to 3G when VoLTE it enabled, just work with Firmware 2019.xx.
The firmware v2021.09 worked on suspended mode on 3G.


This conflicts with my experience. I am able to make a call with “Mobile Data” switched off and “Network Mode” set to “4G Only”.


Different country though? Different MNO?


I also have data turned off and I can call out when I am in “4G only” mode. I am using Purism’s SIMple service that runs on AT&T’s backbone.

1 Like

4G calls work with VoLTE or without v.o.l.t.e and all depend if the other phone has the VoLTE enabled.
If you make a call under VoLTE with DATA enabled and the other phone has VoLTE disabled then the calls fallback to 4G call without VoLTE.

citation needed

1 Like

That’s doesn’t make sense, as plenty of people (including myself) are not able to make cellular calls from the Librem 5 unless VoLTE is enabled. From all of the reading I’ve done on it, 4G calls are ONLY VoLTE; there is no non-VoLTE 4G voice call.

1 Like

As far i know to get VoLTE work it need be enabled by: Firmware(modem) + Software(telephony manager) + Red(4G & carrier) so it weird that 4G only do HD CALLS.
@johnk to me all this issues it is because Meego OS died then Telephony Manager(ofono) get obsolete to 4G. I know L5 it using MM.
I will do more testing on this this afternoon, then i will respond to you tomorrow more extended.