VoLTE support progress

No, it didn’t work. It did show some output, but it never echoed what I typed. I went and typed everything and cycled the modem, but it still won’t let me place calls.

What was that output?

Until you can get it working, you should probably not type the above AT commands and instead stick with ATI (identification). Here is the output from the ATI command on my phone.

Manufacturer: BroadMobi
Model: BM818-T1
Revision: M1.0.2_E1.0.0.0_A1.0.2
IMEI: censored


Maybe post output from the shell command: mmcli -m any | grep tty

Output from mmcli -m any | grep tty:

18: | ports: cdc-wdm0 (qmi), ttyUSB0 (qcdm), tty USB1 (at), ttyUSB2 (at),
19: | ttyUSB3 (at), wwan0 (net)

When I do the screen command and type ATI, I get similar output to yours, but the Model and Revision are different:

Model: BM818-A1
Revision: M1.0.0_E1.0.0.0_A1.0.0

Does it echo the ATI?

The ATE command should also be relatively safe.

If you use the screen command to talk to the modem and type
and press Enter, do you get an OK response? If so, if you repeat the command, does it echo the command (and again give an OK response)?

FYI, if ATE1 is successful then you should finish by doing ATE0

That’s because the model depends on where you are in the world (North America, Europe, Asia - in rough terms).

Sharing my experience of getting VoLte to work:

For reference, I would consider myself a general user of linux. Not an expert. But I do like to tinker with stuff.

I signed up for PureTalk (AT&T backbone) and got a SIM from them. They said I was good to go when I looked up my IMEI on their page.

I was admittedly under-educated in the phasing out of the g’s when I received my L5; not to mention VoLte vs. dropping to 3g for connection. Were I aware before, I wouldn’t have been too surprised that voice didn’t work on receipt. But now, after reading about the carrier phase out, this entire post, and quite a few other pages, I have some general knowledge.

So after a few beers, I convinced myself it was a good idea to try to turn on VoLTE using the “screen” command in terminal. I went through the steps, cycled the modem, attempted a call, and it worked. I had the phone set to 4G only, so I know it didn’t switch over to something else. The next morning I called my phone from anther, and it rang and picked up.

So here’s the short version of the data point I acquired:

VoLte worked immediately on PureTalk (AT&T MVNO) after enabling it through the terminal commands. I didn’t even have to cycle the device power - just the modem.

And the only hair-raising part was typing in the terminal commands just right on the phone keyboard with my fat fingers. Also learned in the process that using the backspace key in the screen command doesn’t really echo back like one would hope… duh.


I executed the commands with screen as @Kyle_Rankin wrote flipped the hardware switch (waited 10 seconds to re-enable) and it seems that both incoming and outgoing call stay in 4G (same with mobile data on or off). I tried 8 calls. 1 switched to 2G. The rest 7 remained in 4G. The preferred method is “2G,3G,4G”. So do I leave the modem as is (in VoLTE state) or there may be other issues? I guess if it works, it should be left on. Yes? The carrier is in Greece (cosmote). I write this for maybe a user in the same country (or for tourists :slight_smile: )

Unless the UI had crashed and only shown 4G :upside_down_face: But I will try again after reboots.


It stays at 4G after a reboot.


That may depend on your tolerance for risk. I think Purism is intentionally not enabling VoLTE by default. It probably hasn’t had a lot of testing with a lot of carriers around the world. Comment @joao.azevedo ?

My recommendation would be: if you choose to leave it enabled then keep a copy of the instructions to enable and disable with you at all times, either printed out or saved on your phone or both.

1 Like

The following behavior is observed systematically:

  1. Boot from L5 being powered off.
  2. After boot and after it connects to the mobile carrier with 4G we dial out.
  3. The connection drops to 2G
  4. The HKS is flipped. If enabled in a couple of seconds it can not dialout or in.
  5. If HKS is re-enabled after 10 seconds. Calls work.
  6. Dialout now stays with 4G and does not drop to 2G.

I have repeated this sequence from yesterday 4 times. It is always the same results.


Yes! that is exactly what I have done!. I have copied the commands in a file on the L5.


VoLTE on the Librem 5 is not yet enabled by default for a reason. It is still under tests, and it has risks at the moment. I would not recommend enabling VoLTE to anyone that is not willing to accept the risks. And accept that if it does not work they will have to troubleshoot the modem.


OK, then, I will disable it… :cry:

Unfortunately has no effect on AT&T network US with Awesim. 4G still does not pass calls, and people calling are directed to voicemail.

Please work with our support team if you aren’t receiving incoming calls with AweSIM so we can figure out what’s going on. We will be able to get it to work.

1 Like

Can some of the folks who are using VoLTE already on Librem 5 share their experience?

I consider to switch on VoLTE because at work the GSM (2G) signal is pretty poor while LTE (4G) is very good. So when I get called and the modem goes down to GSM (there is no 3G in Germany anymore). The call quality and stability is then pretty poor. If the GSM signal is good, I don’t have major issues with calling :slight_smile:

1 Like

As a U.S. customer, I bought my L5 pre set up with 4G and Awesim sim card. (so my experience may or may not mimic yours), But so far, I’ve found the call quality/signal strength to be equal to my iPhone with AT&T.

I have a L5 with a SIMple service plan, and VoLTE calls/cellular service have been fine for me in my location.

I am using VoLTE in Germany can you DM me your carrier name?

1 Like

Its Deutsche Telekom.