VPN Not Working Properly (Librem Tunnel)

I set up Liberm Tunnel on my Purism 13 v4, it’s not working. It says I’m connected but my physical ip address is still visible. I repeated the installation steps and still the same results. There are no indications that I am actually NOT connected to the VPN. This is unacceptable for a paid subscription service.

Can you provide more detail on how you are checking your IP? It may be useful to understand what might be going wrong.

For me, I just checked with whatismyipaddress.com. I went to the website off VPN, checked my IP, connected to VPN, refreshed the page, and it still showed my original IP, but if I left the page and returned, it then displayed the new IP from the VPN. So maybe refreshing isn’t enough (something gets cached, perhaps).

I did exactly:

“I went to the website off VPN, checked my IP, connected to VPN, refreshed the page, and it still showed my original IP, but if I left the page and returned, it then displayed the new IP from the VPN. So maybe refreshing isn’t enough (something gets cached, perhaps).”

In both cases- connected or disconnected from the VPN it shows the same ip address which is my physical ip address. When connected to the VPN is should be showing a California IP address, which it was last time I checked it after initially installing Librem Tunnel last week.

Hmm, ok, well, you may wish to email support@puri.sm then. These forums are mostly community-driven, though Purism staff do appear occasionally.

I’ll tag @joao.azevedo @Richard too, as they are the staff I see most frequently

Thanks for your help! I do appreciate the attempt! I’ll just cancel my Librem One service and go back to IP Vanish via OpenVPN.

You have Librem laptop so I assume you are running PureOS.


You see that lock between the WiFi logo and speaker? That lock means the VPN is enabled. if you don’t see that then it is not enabled.

Click on that area, select where it says VPN Off and choose your Librem One VPN. Will take a sec to initiate and you should be good.

It was enabled. Still returned a physical IP. Numerous times, even after a reinstall. PureOS won’t enable VPN at all over OpenVPN. Gave up and am attempting to install a different OS now, first tried Mint which I totally gave up on as CoreBoot would not recognize the ISO beyond text, after several hours of dealing with Mint ISO, I’m not getting some movement with Fedora but stuck on disk partition issues. So regretting my purchase, should of just stuck with my old 2009 iMac running Mint… :frowning:

Perhaps your best option is to pursue that issue and get support with that. Perhaps there are log files that show you why the VPN seemingly didn’t activate.

1 Like

I tried. Support from Purism is basically nonexistent. This whole situation is regrettable, I will not recommend anything from Purism at this point until I can get an OS installed on hardware that is functional. Purism states you can replace PureOS with any OS if you do not prefer it, good luck doing so though, there is no instruction I can locate that states what to do. Purism, from an end user point, has locked a customer out of her laptop. A pretty expensive laptop considering I could install Mint, Ubuntu, Fedora or just about any other Linux distribution on Crapple hardware for the roughly the same amount of money hardware wise. :frowning: Just want to run Linux on something that it’s supposed to work on hardware wise. Had such hopes…

Out of curiosity, have you edited your VPN settings at all?

From my experience, with setting of the VPN connection to LibreM Tunnel, the configuration defaults to using fetching and IP and DNS from the LIbrem Tunnel server. I know that you can edit this under the VPN Settings for the connection and change the routing information and also to only get an IP, foregoing the DNS. In the last case, if would explain how you would be showing a connection to the VPN, but not showing an external IP address change via a web IP address lookup service.

The only other thing I could think of would be if you had manually set your DNS servers for your main connection, that might override whatever NetworkManager was trying to auto-configure for you. As you’ve said you did a reinstall, that is probably not the case, unless you also reconfigured your DNS manually again.

I’m still not convinced your cache is getting cleared. After connecting to your vpn, use Ctrl+f5 to refresh, that will force the page to actually reload. If that doesn’t work, go to ipleak.net, you may find some info there. It’s a more thorough test anyway.

I did not. All I did was follow the instructions from Purism. Odd thing is Librem Tunnel was working, I checked it and my IP was showing California (I’m not in California). I checked it the next day and it was still showing California. It showed the proper icon as being connected for almost two weeks. I checked it yesterday and it showed me at my physical IP, updated, rebooted, reconnected to Librem Tunnel, showed me as connected but returned my physical IP when checked. I did clear the cache, several times.

I’m now running into CoreBoot issues so the VPN issue is on the back burner.

@hugov I tried to reproduce your issue on my laptop, renamed my Purebrowser home folder to use Purebrowser “as new” without any of my configs.

Then search for my IP in Duck Duck Go, with the Tunnel VPN Off and then On. And the page did was indeed cached, so after refreshing the page two or three times it showed the California IP for Librem Tunnel.

I see that one of the members of our team: MrChromebox already went to your rescue with your OS situation.

But in any case if you are still having this issue with Tunnel, please contact the support team via email: support@puri.sm