Wayland issue with Wacom Tablets

Hello all,

Unfortunately, it looks like my Wacom Bamboo tablet refuses to work with Wayland properly. Attempting to use it creates a second cursor that can’t seem to click on anything in Krita.

Curiously, checking the Wacom settings pane returned a message saying that no tablet was connected.

A quick search led to this bug report, which I believe is related: https://bugzilla.redhat.com/show_bug.cgi?id=1397898

Are there any workarounds that might get my drawing tablet working?

1 Like

Have you tried with X session?


Yep, that totally worked! Thanks for that. :grinning:

So it appears that Wacom works out-of-the-box on Xorg, but has some pretty bad configuration issues / is semi-undetectable on Wayland. It appears that an upstream release of Gnome (3.24) addresses the configuration issue, and an upstream release of XWayland (xorg 1.20) may ultimately help compatibility along.


I trust it will work with Wayland in the future (I know it is actively being worked on), we just have to be patient for development to be completed and updates to trickle down. It might take a year or so for all puzzle pieces to fall into place. in the meantime, tablet users need to run an Xorg-based GNOME session indeed.

Beyond GNOME/Wayland itself, this might also depend on individual painting apps’ native support of Wayland tablet input, I’m not entirely sure.

1 Like

Yeah, that’s totally fair. Krita is my tool of choice for the moment. I know that generally KDE has Wayland support now, but haven’t done a whole lot of homework on which painting apps have a Wayland/XWayland backend yet.

All in all, it works perfectly in Xorg, so I’ll just use that as a workaround for now. :slight_smile:

On the bright side, I’m pleasantly surprised at how smooth Wayland feels overall. I almost didn’t even realize I was running it initially!

1 Like