Weekend update issues

The weekend update has created the following issues on my end:
With automatic suspend mode set to “on” and only the network kill switch turned on together with
the tunnel switch the following happens.
An incoming call will be heard but the screen has to be opened with the password, then the default call app has to be opened. The phone is ringing the call cannot be answered or shut down. Only the power switch can turn off the call by closing the phone itself.
If that is not enough also the network is turned off together with the tunnel switch, not having touched the kill switch.
Sounds exiting no?
Adding another browser to the redundant apps I already have, is not working for me.
I just want the Librem 5 to be a phone at this stage, working with the Librem one software mainly the tunnel to be fully integrated with the PuriOS.
When you have only the network activated, the tunnel will not turn on anymore. Only the wifi will allow for the tunnel switch to be turned on. To recap:
So to save my battery power I use the suspend mode,
To be able to use the Librem One tunnel I need to turn on the WiFi switch together with the Network switch (I want to the Librem 5 to be a phone, remember?)which will reduce the just saved battery power back to the beginning of this unending circle.

Last but not less important; Can I delete the newly added browser?

1 Like

Obligatory joke: I thought this was an SNL skit :wink:
And is this or this L5? :smiley:

Seriously: If I understand your problem, your network is shut down when the wifi hardware swith is used (off) and this interferes with calls as well? Having the wifi on is unfortunate as it uses power as it automatically is set on when using HWswitch? And I take it “the tunnel” refers to Librem One? Or is it some other VPN (or some other connection)? Is about right?

There’s a lot to unpack there.

1 Like

I just want the Librem 5 to be a phone at this stage, working with the Librem one software mainly the tunnel to be fully integrated with the PuriOS.

In the meantime we are back to square one,
The erratic behaviour I mentioned has not reoccurred till now. But turning off the WiFi switch will automatically turn off the Librem one Tunnel switch even if the Network switch is turned on.
Network switch only allows for the Tunnel switch to be turned on but the the Tunnel switch will disengage around about the time the set suspend time kicks in.


Sounds like you need to contact support@puri.sm

Just to be clear, by network switch you are you referring to the network switch that is in the settings and not the top hardware kill switch, which is the mobile (and mobile broadband) kill switch? There are a lot of switches and what you wrote can be interpreted different ways. And your tunnel does go through mobile broadband and not wifi - or are you using an adapter for a cable network?

I have contacted Support but they think it is a bug and will be addressed sometime in the future! The Librem One Tunnel is not for free, so yeah!

The network switch is the top kill switch I use to turn on the mobile network. No cable connection.

Ok. I think I may have experienced similar or same behavior at least a couple of times: to get wifi up after switching hw switch on, I’ve had to have the mobile switch on too. Not too bad for my situation, so probably a bug. However, as behavior goes, I’d like to have a software setting to select if I want to have wifi or BT on after putting HW switch on. Mostly I have to separately switch one or both off from SW switch. I see this as a “security by default” option that hasn’t been implemented (at least yet). No connection means less attack surface and less chance of broadcasting yourself for anyone/anything.

So why having a phone?
My idea of having a safe phone is barren of apps, only have the ones needed for the necessary functionality of the phone. But…. It all should work seamlessly.
That is Librem 5, maybe a year from now hopefully.

1 Like