What can we do with the 13 v2's USB-C port?


#1

I’ve seen the existing threads about USB-C charging, so understand that it’s not (yet) possible. Having never owned a device with a USB-C port before… what all can we do with it? What sorts of USB-C peripherals would be compatible with the Librem/PureOS? Can we do anything “unusual” with this port other then the expected USB-3-speed data transfer?

Having fun exploring this new laptop’s capabilities… just having a new machine is a nice change from my six-year-old MacBook Air. :smiley:


Librem15v4 USB-C for Thunderbolt 3 Data Transfer
#2

I was going to try to post something on this topic for my Librem 13 v.2. So far, I have not found anything that works in the USB-C port. I tried a standard USB-C to USB-C cable to just plug in my phone, the phone is not recognized and does not charge. I tried a USB-C hub, and none of the ports on the hub worked, not the USB-A ports, not the USB-C port, nothing.

I understand that the power delivery doesn’t work currently, which is fine, but honestly I’d be happy if I could just get some data to work over the port. At this point, it seems to be completely useless.

Does anyone use the USB-C port for anything at all?


#3

Just tested here on my 13v2 and 13v4. On both devices, connecting my phone via USB-C immediately begins charging the phone. Connecting a USB-C hub with USB-A devices attached (USB flash drive, USB ethernet adapter), all devices are immediately recognized and available to the system.

Are you running the latest firmware? Are USB-C devices recognized when attached per dmesg log?


#4

Thanks for the response! My firmware is:

Version: 4.7-Purism-3
Release Date: 03/02/2018

I actually don’t have the cable with me so I can’t check dmesg (I will be back home on Sunday and can do it then), but neither the phone nor the computer recognized any connection when I plugged it in.


#5

I don’t believe there are any USB-related fixes in the newer firmware, but it wouldn’t hurt to update for the microcode/security updates - see https://puri.sm/coreboot

I’d recommend updating the firmware, then retrying and checking the dmesg log. You might not see anything when the phone is connected since most default to charge-only mode, but you definitely should for connecting a hub or any other peripheral


#6

So, I checked this. Nothing happens at all on dmesg or /var/syslog when I plug in the device. Also, it is not charging. Sounds like maybe a hardware issue which I should take up with purism?


#7

definitely, if nothing else support may be able to think of something I’m forgetting


#8

I have the same problem here, weirdly iPhone USBC cables and Apple USBC-3.5mm converters work?


#9

So a little update. I was able to get an Aukey USB-C --> 4 port USB 3.0 hub to work, which is great. Unfortunately, a straight USB-C --> USB-C cable still does not work. I have upgraded to the latest firmware, no change.


#10

I have some questions to your "straight USB-C --> USB-C cable "…
Maybe try a different one?