What is the last good devkit.img build to run the Librem 5 in qemu?

I wanted to check the current state of the Librem 5, so I went to https://arm01.puri.sm/job/Images/job/Image%20Build/ and downloaded the latest image file at:

Unfortunately, I can’t get it to boot with this command:
# qemu-system-x86_64 -boot menu=on -drive file=devkit.img -vga virtio -display gtk -m 2G -enable-kvm

It gets stuck at “Booting from Hard Disk…”

A previous post from January had the same problem and @david.boddie gave a link to the latest good build, which no longer exists on the server. What is the latest good build that we can use?

Few days ago i downloaded the one from 7th or 8th of August, which works fine for me.

Try this:

BTW, it looks like you’re trying to run an ARM binary on a x86_64 emulator.

1 Like

I had the same issue yesterday - using the qcow2 it worked for me

(sudo qemu-system-x86_64 -drive file=qemu-x86_64.qcow2,format=qcow2 -m 3G -boot menu=on -vga virtio -smp cores=4 -enable-kvm)

i use this with qemu. I download xx_64 and with qemu( is possible with interface) create cow2 .

Thanks for the help everyone.
Has anyone tried running Build #1950, which is the latest one available?

OK, I’ll try downloading Build #1949, since it has a .qcow2 file, unlike Build #1950 which only has a .img file.

Edit: OK, I see the problem. I was using devkit.img which is for the Dev Kit with an ARM processor, which I don’t have, so Barugon you were right. Build #1949 is the last image available for x86_64.


FYI, if you want the dark theme (I sure do) then add this to .profile:

export GTK_THEME=Adwaita:dark

The devkit builds are all ARM64, as they are meant to run on the dev kit. What you want is a qemu build, which will run in qemu.