Why Can't I Remove This Game?

Hello, in PureOS I went to the start menu, then I clicked on the Software briefcase icon, then I went to games, then I downloaded the free version of Tetris.

Then I didn’t want the free version of Tetris. I went through the usual procedure of right click on icons, click “show detail”, click remove… but then it says I can’t remove it because there are “no packages to remove”. Obviously I can still click on the game and play it, so something is there.

How do I remove this?

Thank you.

Sometimes the Software app doesn’t seem to want to remove something that was just installed.

Try this in the terminal: sudo apt remove quadrapassel

That should work :slight_smile:

2 Likes

Amazing. Worked perfectly. Thank you.

Hello, I have since tried this same method to remove other things I have installed from the “app store” it is not working as it did with the quad game thing.

I tried the same terminal entry but typed chromium instead. With no success.

I think in the terminal its called chromium-browser

… unless it’s a flatpak or similar.

1 Like

I typed ‘sudo apt remove chromium-browser’ and nothing happened, but I saw in the text that was generated in the terminal that it said to try something like ‘sudo apt autoremove’ so I tired that. It it did things that made it look like the browser was removed. But the icon still shows up on the app menu.

1 Like

I’ve had to reboot (or log out and log back in) to get the icon to go away before.

Is there some command I can type in that will say what everything I have installed it “called” in the terminal? I see that each icon generates a title underneath it. But clearly just copying that title into the terminal doesn’t necessarily call up what that app is technically called.

This should do it, except for flatpaks:
ls /usr/share/applications | awk -F '\\.desktop' ' { print $1}' - | tee applist.txt; exec bash

This prints the list in the terminal and also creates a .txt file for you in the home folder.

On systems that use a standard applications menu, you can enter edit mode (of the menu itself), then check the properties of a particular application to find its package name.

You can also do: apt search followed by a keyword that you think might be in the name. Ex: apt search chromium
This checks both installed and uninstalled packages (and lets you know if its installed).

A combination of both of your suggestions led me to my desired result. Thank you.

1 Like