Why is Screen Sharing Disabled in PureOS?

I have changed the display server to use Xorg instead of Wayland.
I have confirmed and updated the vino package.
And when I go to Config > Sharing I only have 2 options: File Sharing and Media Sharing.
Where is the Screen Sharing option?

I am trying to access my desktop from within my LAN.

This was a new installation of PureOS 10.
Poking around I saw reference to gnome-remote-desktop.
I ran:
sudo apt install gnome-remote-desktop
(it needed to add: libvncserver1 package)

Now when I open the sharing setting I see the 3rd option for “Screen Sharing”.


Thanks for sharing! :wink:

1 Like

I did this and also saw the option, however when I try to connect I get the following error in syslog:

gnome-remote-de[3277]: Failed to start session: GDBus.Error:org.freedesktop.DBus.Error.Failed: Failed to start remote desktop: Failed to create PipeWire source

I’ve tried making sure the PipeWire service is available but I still can’t successfully connect. Has anyone else encountered this?