WIckr in pure o/s

Searched long and hard and it appears wickr cannot be used on pure o/s. Tried every way to do this but failing miserably.

Any help very much appreciated.

It seems like Wickr’s support for Linux is pretty limited. They only claim to support Ubuntu 16.04, not even 16.10 or later. Did you try the Ubuntu instructions? There’s a remote chance they will work, since Ubuntu and PureOS are both based on Debian, but given Wickr’s explicit statement of “this will only work on Ubuntu 16.04”, I kinda doubt it.

If you must use Wickr, you could run a Ubuntu 16.04 virtual machine through GNOME Boxes in PureOS, then install Wickr on the virtual machine.

Hey thanks for the quick reponse, this forum is really good.

Yeh i tried to work around with the Ubuntu download but have hit a wall. Was hoping to have it sit on the pure os rather than the gnome box. But it is what it is.


I just tried installing it, and yeah, it seems like the only part I can’t resolve at the moment is that it’s requesting a specific, older version of Unicode for some reason. I think that if I were able to resolve that, I could get it working, but I can’t go too deep on it now. Maybe others can take a crack at it and find the solution, or maybe I’ll get some more time later this week to dig deeper.

Thanks for taking the time. Would be extremely helpful if you or someone else could work that out . It’s beyond my capabilities.

If it depends on a specific package version, you can try to ignore it during installation. If it then fails to load, missing that specific version, it often works to fake that. You can run ldd path/to/Wickr to check if it misses a library. You could then create a symlink that points to your installed unicode version. (And check again with ldd). No guarantee, but worth a try.