wifi/BT HKS off not working if wifi is soft disabled

Hi all,
When I enable wifi/BT with the HKS and then disable wifi from the pull down menu, but enable BT from
the same menu, then if I disable wifi/BT with the HKS, the wifi/BT icons remain on top of the display.
I would expect to see them go. From there, I cannot interact with the wifi/BT icons in the pull down menu.
To get rid of the icons on top, I need to re-enable wifi/BT HKS, then enable wifi from the pull down menu and then I can switch the HKS in the off position.
Is that a bug or a feature ? Am I the only one ? I didn’t see such report so far.


Assuming you have a Sparklan card: it works, the kernel just doesn’t notice it until it tries to communicate with the card. It’s a harmless driver deficiency that is going to be fixed at some point, but probably not at high priority.

The icons on top should disappear already if you try to soft-enable WiFi while it’s hard-disabled.