At boot usually get a list of error messages. Lately get “contact www:// for update of missing firmware” What is that all about?


I have the same error message in system log :

[ 1.227556] i915 0000:00:02.0: firmware: failed to load i915/skl_dmc_ver1_27.bin (-2)
[ 1.227569] firmware_class: See for information about missing firmware
[ 1.227580] i915 0000:00:02.0: Direct firmware load for i915/skl_dmc_ver1_27.bin failed with error -2
[ 1.227585] i915 0000:00:02.0: Failed to load DMC firmware i915/skl_dmc_ver1_27.bin. Disabling runtime power management.
[ 1.227589] i915 0000:00:02.0: DMC firmware homepage:

this seems related to the will of Pureos maintainers to keep only free firmwares in Pureos.
I found more information here:
and here:

I wonder if this problem is related to my issue with HDMI: I cannot get my HDMI second screen working (it works with a live USB linux distro…). I will continue to search for a solution.


Having had the same messages on a newly bought librem 13 v3 i’ll fish it up to perhaps gain a little bit additional attention as the question hasn’t been solved.


According to this, they are just warnings:

1 Like