WINE installed, not in list of applications

I just installed wine via the software application on my librem 15 v3 and I don’t see it anywhere in my list of applications when either trying to open an .exe file on my drive or in my list of applications. Clicking ‘launch’ in the software application doesn’t do anything either.

Sounds to me like there’s no .desktop file. .desktop files are usually either in /usr/share/applications/ or ~/.local/share/applications/

If you look in those directories, you will probably see existing files already in use by whatever programs you have installed, and can see what the general format looks like.

That said, seems like getting a simple .desktop file for WINE isn’t so easy. You can look through this link and mess around with what they say.


I have the same problem. And it seems like there is no wine in the applications file, even if the software application of Gnome said it is.
Have you found a solution?
Thanks :slight_smile:

Hi @fredbastiat, @NeoJ,

Have you tried to open a terminal and run the wine command to see whether it is actually present or not?
The terminal is called Tilix in PureOS.

When open, try to type in winecfg
If a configuration windows pops up, then wine is installed, and you can configure it.

You can run your Windows programs from the terminal by running wine path/to/your/program.exe

1 Like

It’s working for me :slightly_smiling_face:
Thanks a lot for your help @thib

Hi guys, I rebooted my librem and it showed up in the list at that point. That said, I was trying to load up the Kindle application which is 32 bit and the librem won’t support i386 architecture, so I had to give up at that point.

Steam is also 32 bit but I managed to install it. Technically i don’t know how this is called, but you install some packages that make 32bit apps run on a 64 bit architecture.
If you’d ask me how I did that, then I’d say, perhaps not the best way, since I didn’t know what I was doing, but I added Debian’s repositories (stable main contrib non-free) and just installed all the packages that the app told me to. :thinking:

Could you elaborate on that a bit? I can’t find how to download wine32 (seems to be missing/renamed from the apt repositories) and multiarch support does not work with my wine 64 version…

I’m myself not very tech savvy, but you could start from here. If I knew more, I’d have helped you with specific steps or smth. :roll_eyes:

I am still working on my wine install. I also encountered the oh my gosh wine isn’t in my list of installed applications. I downloaded and compiled a specific wine version (the one recommended for playing WoW if there are any other WoW addicts here). Those instructions didn’t include “install” as it is not needed “if you are running your application from the command line” so I tried the wine “make install”. Still no wine in the list of applications even after reboot. I ran winecfg (still working on all the error messages from that) but it created a wine configuration file for my user account and voila wine is now in my list of applications! I hope this may be helpful for the next person trying to get wine going. Cheers!

So, I too have installed WINE. I have run winecfg, and set it up as a Windows 7 environment. On reboot, all sorts of Wine-related icons were in Gnome. Tried to run a Windoze exe, but it tells me it is a bad EXE, because 32 bit support isn’t installed…and PureOS doesn’t support 32 bit. Which begs the question of why there is a 64 bit version of Wine in the first place, as there is bugger all on Windoze that is 1) popular and 2) 64 bit only.

So my next question is how do I install 32 bit support for Wine? I keep seeing stuff on line about multiarch support. I would connect to Debian and install it, but I am an inexperienced Linux user, and don’t want to hybridize my system into unusability. Any suggestions?