Wine won't launch

Just installed PureOS 8.0 “Prometheus” Beta 1 on a PC. One of my first tasks was to install Wine. I found it in software and clicked on the “Install” button, it proceeded to install and a “LAUNCH” button appeared. Nothing else happened. I looked in “Software” under installed and it was there, but with only a “REMOVE” button. How do I access Wine in PureOS? Or will it simply be available when I want to install a “windows” app? Thanks

hey ! sudo apt install wine in terminal window - it requires some 700-800mb

hey reC
thanks that worked that worked to get wine installed, however I am getting this eror when I open winecfg in terminal:

la@labud-pc:~$ winecfg
it looks like wine32 is missing, you should install it.
as root, please execute “apt-get install wine32”
la@labud-pc:~$ sudo apt-get install wine32
[sudo] password for la:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package wine32 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package ‘wine32’ has no installation candidate

What does it mean I should do?
I prefer to use cli when I can, i am just more familiar with Suse than Debian and not too sure my way around just yet.

wine32 is 32bit software, I don’t know if pureos has 32bit software.

I am on a 64 bit system but with openSuse it was necessary to install the 32 bit also, for some reason. Maybe it is not necessary for PureOS. I will install a windows program to how it works.

It appears that even though PureOS says wine is installed I cannot get it to install any windows programs. I have tried to install by right clicking on the windows .exe file but all I get is the archive manager. I don’t see Wine listed in installed programs, but if I try to install it [via cli] I am told it already is installed at the latest version. I try to start Wine [via cli] but it tells me there is no such file or directory. I can see wine in the file manager under /Home/.wine.

I think what uzanto was alluding to, although I’m not 100% sure, as I’m not that familiar with the Linux kernel and how it operates, is that the kernel which comes with PureOS only has support for 64 bit processes. There isn’t a portion that emulates 32 bit processes. For this reason you are probably not having luck. As of right now, using PureOS, you will not be able to use Wine.

1 Like

and yet Wine is offered in the software area.

Looking through the reviews in the software center this was suggested:
dpkg --add-architecture i386 && apt-get update && apt-get install wine32

I’d give it a whirl and see if fixes the problem.


Maybe you can use a Docker Image like:


I’ll try it when my Laptop is back… :wink:

1 Like

Well I can say that if you just install steam, you’ll see that wine in fact works. This is because the steam image downloads all missing dependencies as part of the installation process. I know this isn’t what people want to do on their FOSS system per se, but it does demonstrate that wine works fine when all of the necessary dependencies are present.


installed WINE from software

running exe from WINE in TILIX :

~$ wine ‘/home/au/Downloads/foobar2000_v1.5.2.exe’
it looks like wine32-development is missing, you should install it.
as root, please execute “apt-get install wine32-development”
it looks like wine32-development is missing, you should install it.
as root, please execute “apt-get install wine32-development”
wine: Bad EXE format for Z:\home\au\Downloads\foobar2000_v1.5.2.exe.

what is the fix , please?

PureOS does not have any 32bit files in their repos.

This means that you will need to do some Linux trickery to get it working if you don’t want to use something like Steam, as suggested above.

If you can use Steam than that suggests (correctly, as I understand it, though correct me if I’m wrong) that the issue isn’t the kernel. PureOS simply doesn’t maintain any 32 bit code, because (except for wine and Steam) there’s no real reason to.

You can add one of the Debian repositories to your apt sources to get the i386 architecture files you need, and that oughtta work. If so, then ensure your wine prefix is 32 bit and your .exe files are also 32 bit. Last I heard 64 bit wine doesn’t work as well.

Yes, the PureOS kernel handles 32-bit executables, I checked this one:

This means that statically built binaries run. I guess the problem for Wine is that there are no 32-bit shared libraries available.

Running it in Docker or Flatpak or another kind of container will likely work.

1 Like

so have any users been successful in running WINE on pure os? how did you do it?

Just ran into the same problem. I made a mental note that I’d want to try to solve it by use the missing 32-bit dpkg packets from Debian by pinning. If I’ll get around to do so, I’ll write down here what I did.

If anybody knows that pinning is not an option - please let me know…

@jeremiah, there is no use in having the wine packet in the repo if it cannot be used with 32-bit software.

I’ve run into this same problem. It’s a shame that PureOS doesn’t offer the kernel’s configuration options via /proc/config.gz like a sane distro would…

x86_64 supports i386 as a matter of backwards compatibility. Why shouldn’t PureOS support multilib?

I will try PlayOnLinux and Lutris, maybe they have pre-made wine versions that will work on the hardware… but the kernel needs to support it first.

Have you made any progress with this question concerning the Lutris and PureOS?