Wine won't launch


#1

Just installed PureOS 8.0 “Prometheus” Beta 1 on a PC. One of my first tasks was to install Wine. I found it in software and clicked on the “Install” button, it proceeded to install and a “LAUNCH” button appeared. Nothing else happened. I looked in “Software” under installed and it was there, but with only a “REMOVE” button. How do I access Wine in PureOS? Or will it simply be available when I want to install a “windows” app? Thanks


#2

hey ! sudo apt install wine in terminal window - it requires some 700-800mb


#3

hey reC
thanks that worked that worked to get wine installed, however I am getting this eror when I open winecfg in terminal:

la@labud-pc:~$ winecfg
it looks like wine32 is missing, you should install it.
as root, please execute “apt-get install wine32”
la@labud-pc:~$ sudo apt-get install wine32
[sudo] password for la:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package wine32 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package ‘wine32’ has no installation candidate

What does it mean I should do?
I prefer to use cli when I can, i am just more familiar with Suse than Debian and not too sure my way around just yet.


#4

wine32 is 32bit software, I don’t know if pureos has 32bit software.


#5

I am on a 64 bit system but with openSuse it was necessary to install the 32 bit also, for some reason. Maybe it is not necessary for PureOS. I will install a windows program to how it works.


#6

It appears that even though PureOS says wine is installed I cannot get it to install any windows programs. I have tried to install by right clicking on the windows .exe file but all I get is the archive manager. I don’t see Wine listed in installed programs, but if I try to install it [via cli] I am told it already is installed at the latest version. I try to start Wine [via cli] but it tells me there is no such file or directory. I can see wine in the file manager under /Home/.wine.


#7

I think what uzanto was alluding to, although I’m not 100% sure, as I’m not that familiar with the Linux kernel and how it operates, is that the kernel which comes with PureOS only has support for 64 bit processes. There isn’t a portion that emulates 32 bit processes. For this reason you are probably not having luck. As of right now, using PureOS, you will not be able to use Wine.


#8

and yet Wine is offered in the software area.


#9

Looking through the reviews in the software center this was suggested:
dpkg --add-architecture i386 && apt-get update && apt-get install wine32

I’d give it a whirl and see if fixes the problem.


#10

Maybe you can use a Docker Image like:


and

I’ll try it when my Laptop is back… :wink:


#11

Well I can say that if you just install steam, you’ll see that wine in fact works. This is because the steam image downloads all missing dependencies as part of the installation process. I know this isn’t what people want to do on their FOSS system per se, but it does demonstrate that wine works fine when all of the necessary dependencies are present.