Wont Turn On Without Battery, (but plugged in) - Librem 14

My battery is bloated and expanding. I think that’s dangerous right? Could catch fire?

So I unplugged it, and then plugged in the barrel plug and tried to power on. No dice. So then I tried a 30W USB-C charger to the USB-C port on the right side, next to the 3.5mm aux. Still wont power on.

Am I doing something wrong? I feel like it should be able to power on without the battery connected, but sufficient power. I even tried both the barrel plug AND the USB-C power port, still nothing.

1 Like

The Librem 14 should still be able to boot without the battery and using either external power supplies, but the bloated battery sounds like a serious issue. I suggest contacting Purism Support (support@puri.sm).


@JAnthony Please contact support@puri.sm so we can determine the problem and discuss options for your device. Unplugging the battery is a good precaution.

It should boot with power connected and no battery. While 30 W on USB-C isn’t always enough, you also tried the barrel jack charger and it should have booted from that.


Thanks, just sent them an email.

In the meantime, I’m gonna buy a 118W (6A at 19.6V) USB-C charger. I think my problem here is that I’m using a barrel plug rated at 20V 3.25A, which is 65W … But I believe the stock barrel plug is rated at 95W. Altho I wouldn’t say that Purism makes it easy to find these specs.

Maybe the Librem 14 needs the full 95W to actually turn on.

1 Like

65W should be able to power on the system, especially if the battery is not connected. You’d at least see the white power light come on as it tries to power on. We do ship 90 W adapters now so they are better able to charge the battery and crank the CPU at the same time, but 65 W should be able to boot it.

You’re welcome to try a bigger USB-C charger, but power isn’t the issue with the 65 W adapter. Unless the adapter itself is not working (you could check with a voltmeter), the system should be able to boot with 65 W.