Yet Another Wifi Driver Issue

Greetings, I installed PureOS onto an old PC of mine. However, drivers for the wifi are presumably missing. I’ve copied the drivers under lib/firmware/. I then copied the drivers to lib/modules to no avail.

How does one install drivers manually to PureOS using downloaded drivers through an external flash? Thanks.

Pure System is for Free Hardware, if you have an Opensource/Propietary machine go for

I can’t specifically solve your problem but note that “drivers” and “firmware” are two different things (but which are sometimes inter-related). Some WiFi hardware might have a problem with both on PureOS (or with any other given Linux distro), some WiFi hardware might have a problem with only one of them, and some WiFi hardware just works.

You should use the forum search function to find existing topics that cover the general problem.

Basically a better approach might be to grab the right .deb file from another distro that is at the same approximate release version - and then manually install it.

Even if not choosing to run Ubuntu, Ubuntu can be a good way of determining whether the particular WiFi hardware is dead in the water with the Debian family or might be able to be gotten working with PureOS. That is, doing a Ubuntu Live Boot may give you guidance about that.

1 Like

Both Ubuntu and Debian works with this PC. I tried getting specifically the .deb package, however, dkpg didn’t seem to be on the system - may be a mistake of mine.

These are standard intel drivers gathered from here:
7265 should be accurate to the adaptor I’m using.

Did you mean dpkg ?

You’re incorrect, I have a Toshiba laptop with proprietary WiFi card and SD card reader and they work well with PureOS.

As for @F35H’s question, for my Intel WiFi card I was told to copy a .ucode file into /usr/lib/firmware and then restart my computer. (I have never heard of /lib/modules)

Could you please confirm you’ve found the correct .ucode file for your WiFi card and restarted PureOS?

Congratulations you are a golden opensource user. :joy:

lspci shows “Intel Corporation Wireless 7265 (Rev 59)”

Intel® Dual Band Wireless-AC 7265,
Intel® Dual Band Wireless-N 7265,
Intel® Wireless-N 7265

I specifically tried downloading and moving files from this link to /lib/firmware/

It had two .ucode files which I moved into the file by terminal.

I’m currently on an Acer Aspire 5.

Here is link including related (iwlwifi) workaround (I hope): Wifi adapter issues?.

Edit note: @F35H, please conclude above instruction(s) with: sudo systemctl reboot.


Now I feel quite dumb. I swear I tried that beforehand with it saying there was no command. I must’ve mistyped it - dummkopf I am. Thank you, I will now give myself 30 whippings [metaphorically].

1 Like

Glad you found a solution :slight_smile:

Little mistake on my side: I was told to copy my .ucode file into /usr/lib/firmware and not /lib/firmware.

That’s what I still use currently, I’ve never had to install a .deb package.

I corrected my previous post, sorry for the inconvenience :sweat_smile:

Have a nice day everyone :sunny: