4k @ 60hz output on Librem 13v2 (via USB C or HDMI)


#1

Just wondering if anyone has had any success in getting 4k @ 60hz output with their Librem 13v2? I have tried 4 different ‘high speed’ HDMI cables and have been unsuccessful on 2 different 4K @ 60hz capable displays.

Additionally, has anyone tried to use a USB C > HDMI converter, USB C > MiniDP or USB C > Displayport converter to achieve this?

(running stock PureOS)


#2

bump

Can anyone confirm what the maximum resolution I should be getting over the HDMI port at 60hz?


#3

HDMI ver 1.4 only supports 4k @ 30hz.


#4

Thanks for that.

Do you know if there are any USB C or USB 3 > HDMI adaptors that are compatible with the Librem to pump out 4k @ 60hz?


#5

Just tried a USB C to HDMI adaptor:

www.comsol.com.au/Products-by-Category/HDMI-Video-Cables/COCMHFAD

Claims it doesn’t need drivers, but it doesn’t do anything, just blank screen. Long shot, but anything I need to do to perhaps initialise the hardware?


#6

No, our USB-C does not support video, this is planned in the future.


USB-c to VGA adapter on Librem 15v3?
#7

For folks who have gotten 4k out the hdmi port on the Librem 13v2 did you have to do anything in particular? I tried plugging in a 4k monitor but the OS only lets me select up to 1920x1080.


#8

I plugged the HDMI out directly into the port labeled ‘HDMI 2.0’ on a 4k monitor and the max res I got to choose was 1080p :frowning:

Tried multiple cables, including ones that I knew could do 4k on other devices on the same monitor.


#9

I can get 2560 x 1400 out of the HDMI port on my 13v2 in Xorg mode by manually adding Modelines with xrandr. I have not been able to get these higher resolutions in wayland following these instructions. Upon boot there is an error that the firmware was not loaded. I have also tried setting options to the drm_kms_helper with a modprobe.d file:

$ cat /etc/modprobe.d/drm-kms-helper.conf 
options drm_kms_helper edid_firmware=HDMI-A-1:edid/2560x1440.bin

but either way it seems I am getting the error

[drm:drm_load_edid_firmware [drm_kms_helper]] *ERROR* Requesting EDID firmware "edid/2560x1440.bin" failed (err=-2)

#10

This is being tracked in https://tracker.pureos.net/T298.

From my research it is not a PureOS-specific issue and is most likely an issue with the kernel and the i915 module in the 4.x series with some Skylake hardware (I’ve seen similar reports for some Dell XPS laptops).

I tried a number of different distribution Live USB disks and was only able to get full resolution out of a 4k display if I went back to an old Ubuntu 14.04 live USB disk that ran a 3.x kernel.

We are continuing to research the issue to provide a solution. Keep an eye on the ticket for updates.


#11

Like hazybluedot, I was able to add a mode in Xorg (but not Wayland). I wrote up the steps to do it and make it permanent in the official PureOS ticket on this issue.


#12

I have just tried it with my Librem 13v2 with a DELL U3818DW via HDMI and Ubuntu 18.04:

There is no 4K output possible ATM due to the bug, the max. solution offered in the display settings for the external 4K-monitor is FullHD (1920 x 1080).

So you have to apply the workaround by adding modlines. The allowed values may be limited by the GPU performance (Intel 520) so 4K could be possible only with 30 Hz… (to be verified)


#13

I have managed to add 4K (or WQHD) to my installation of Ubuntu 18.04.01 using this description:

http://ubuntuhandbook.org/index.php/2017/04/custom-screen-resolution-ubuntu-desktop/

Note: To make the changes permanent you have to add them to your .profile file.
Watch out not to use sudo in the .profile or you cannot boot anymore and have to start the recovery via grub2, as described here:


#14

Hi @tovadiratum, I’m using the Dell 3818 too and the highest refresh rate I’ve been able to obtain at full res is 3840 x 1600 @ 26 fps. What cvt settings are you using? Thanks.


#15

@jonatack I have 30 Hz refresh rate, more is not possible with an Intel HD 520 (limited to 300 Mhz core clock speed, see: https://en.wikichip.org/wiki/intel/hd_graphics/520).

My settings:

# 246 MHz
# xrandr
# cvt 3840 1600 30
sudo xrandr --newmode "3840x1600_30.00"  246.25  3840 4040 4440 5040  1600 1603 1613 1630 -hsync +vsync
sudo xrandr --addmode HDMI-1 "3840x1600_30.00"


# Picture-by-Picture settting (supports 60 Hz)
# 260 MHz
# cvt 1920 1600
sudo xrandr --newmode "1920x1600_60.00"  260.75  1920 2064 2272 2624  1600 1603 1613 1658 -hsync +vsync
sudo xrandr --addmode HDMI-1 "1920x1600_60.00"

The core clock speed is specified as "up to 1,050 MHz but I guess this is just a short “boost” - not a permanent speed so I did not try 60 Hz fps with 3840 x 1600.


#16

@tovadiratum thanks! So if we’re limited to 300 MHz, it seemed worth testing near that limit. Turns out the best refresh rate my 15v3 can output 3840 x 1600 at is 35 FPS… right at 291 MHz:

   # 3840x1600 34.98 Hz (CVT) hsync: 57.19 kHz; pclk: 291.00 MHz
   Modeline "3840x1600_35.00"  291.00  3840 4064 4464 5088  1600 1603 1613 1635 -hsync +vsync

I’m currently using the Dell 3818 monitor with that setting stored in /etc/X11/xorg.conf.d/10-monitor.conf:

Section "Monitor"
    Identifier "HDMI-1"

    # Auto detected
    Modeline "1920x1080"   148.50   1920 2008 2052 2200   1080 1084 1089 1125 +hsync +vsync

    # 3840x1600 34.98 Hz (CVT) hsync: 57.19 kHz; pclk: 291.00 MHz
    Modeline "3840x1600_35.00"  291.00  3840 4064 4464 5088  1600 1603 1613 1635 -hsync +vsync

    Option "PreferredMode" "3840x1600_35.00"
EndSection

#17

Forgot to mention that the ddccontrol tool does now support the Dell U3818DW including PBP and main/sub input source settings:

Not yet available at the DEBIAN repo but you can just copy the XML config files onto your computer after installing the tool…

Successfully tested with Ubuntu 18.04…


#18

do you mean future hardware or software/firmware?

just got a librem 13 and theres a lightning icon next to the usb-c port. what does that mean?