Anbox on Byzanthium

Hi everyone :smiley:

I’m, also looking for a way to run Anbox on my Librem 5. I also tried to follow the steps recommended by @dos but after putting the Android image in the right place, nothing happens: no crash nor particular display of anything, just nothing.

The only thing left holding me from making the last step towards a privacy-friendly future is the availability of a standalone version of Signal for Linux (running on my Librem 5). :sweat_smile: after that, I swear I’ll really get involved in the Librem 5 development. :wink:

Anbox is broken with recent kernel versions (5.18), so that’s not unexpected. I guess I’ll have to prepare some instructions on how to install ashmem DKMS package to make it work again.


:+1: That would be great indeed since the standalone registration for Signal is not exactly a complete feature.

1 Like

Hi @dos , any news regarding the DKMS package ?

Failed to start as either binder or ashmem kernel drivers are not loaded

I’m still getting this after starting anbox-container-manager.

Good day to you :wave:

I recently re-flashed my Librem5. anbox doesn’t work. will not start. Anyone got anbox working?

1 Like

Anbox is not going to work anymore unless it gets updated to not rely on ashmem in the kernel, which is unlikely. If you need to go back to your Android container to access something in it, you should temporarily switch back to 5.17 kernel. I’ve started working on getting Waydroid usable on L5 and made some progress, but it will take some time until all fixes flow down through all needed components.

(I have that blinking already fixed \o/)


Awesome news!

1 Like

How is the development progress of Waydroid?

1 Like

I expect it to be easily installable sometime in October.


Awesome! We are waiting for the completion!

1 Like

@dos, can you share instructions on how to install and configure Waydroid on Librem 5?

1 Like

Let me reiterate:

I expect it to be easily installable sometime in October.

I have already shared some instructions in another thread, so you can find them if you want to, but I really don’t recommend following them just yet unless you’re capable of dealing with anything that can go wrong in the process by yourself.


This is so awesome. Keep up the awesome work.

1 Like

I am having challenges with bringing up Waydroid GUI on Librem 5. Looks like mesa is not getting setup properly.

@dos, can you comment if install instruction at for Debian/Bullseye will work on Librem 5?

It won’t. Several components inside and outside Waydroid need to be patched, which is why I recommend waiting until next month when I expect all that stuff to find its place in the repositories.


@dos, Thanks, I will wait for an update

@dos, you can choose not to answer my question since it is not really related to Librem 5 software.

I followed this link to install Waydroid on my Librem 5;

Other than the kernel, I installed all other components. Waydroid gets installed. When I start it, there is a annoying pop-up; “Trebuchet has stopped”. After that the Waydroid UI keeps restarting and with the same pop-up message.

Did you also see this issue? If so, can this be addressed easily or as you suggested, wait till October?

Thanks much in advance for answering (I know you will :slight_smile:)

That’s something that happens on upstream images when using software rendering. Sounds like you might have followed some other instructions earlier and don’t really have the configuration described by what I wrote.


Other than the kernel

You’re going to have a bad time :stuck_out_tongue: There’s a reason why these components have to be installed together and it’s not just about getting Waydroid to work.

1 Like

@dos, I was excited with your video ( As shown in the video, Waydroid appears to be more smooth and stable compared to Anbox. This appears to be a solution for missing Apps for Librem 5.

I tried to use instructions from this link; but as you mentioned on dependencies now have a messed up Librem 5 since I am not able to install the 5.19 patches kernel. The Waydroid UI comes up but keeps crashing and restarting.

Can you provide instructions on how to install the patched kernel ( ) on Librem 5?

It may be better to let the poor guy get on with his work so that we can all have Waydroid, officially released, integrated, working, not requiring advanced hacking skills, …