Anyone Successfully Run WayDroid on Librem 5?

Yes, I have:

About GPS:

Which DISTRO= did you choose?

I don’t use Unbuntu and can’t get the image generated under arch right now. Can someone share this with me?

I’m about to write updated instructions. Turns out that the current upstream images are broken again, so I have to figure out which exact change is responsible, but that shouldn’t be a big deal - I still have a set of working images here locally. Don’t use the old ones I posted earlier, there’s a lot that has been fixed since then.


will the camera be usable in waydroid ?
I don’t wish to use any android apps but my banking app
identifies me at install time by taking a photo.
Last time I tried, that was before receiving my librem5, on a
pinephone, but it crashed when trying to access the camera.

No, as it is right now Waydroid is not able to use the cameras.

I’m using bullseye:

sudo wget -O /usr/share/keyrings/waydroid.gpg
echo "deb [signed-by=/usr/share/keyrings/waydroid.gpg] bullseye main" | sudo tee /etc/apt/sources.list.d/waydroid.list
sudo apt update
sudo apt install waydroid
sudo mkdir /usr/share/waydroid-extra/images/
sudo mv system.img.xz vendor.img.xz /usr/share/waydroid-extra/images/
pushd /usr/share/waydroid-extra/images/
sudo unxz -T 0 system.img.xz vendor.img.xz
sudo waydroid init
echo "persist.waydroid.use_subsurface=true" | sudo tee -a /var/lib/waydroid/waydroid_base.prop
sudo systemctl restart waydroid-container

Thank you it’s working quite nice.

1 Like

I just installed it, and ran Conversations and Slide.

Apps seem to be working just fine, except Waydroid got into a bootloop when I opened Slide from Phosh app drawer, and then closed it.

I also noticed that now my phone wakes up every few minutes from standby, will test if that’s because Waydroid is running.

Nope, just a coincidence, no idea what triggered it that one time.

This is an old image with many issues that have been resolved since.


Do you have an updated image available?

dos is going to publish info on how to install WayDroid soon.
This will be with the updated image.

I can’t tell you what soon means, but I can assure you that asking “when is going to be ready?” is more likely to delay the delivery instead of speeding it.


Worked perfectly for me. No more error messages. @sim6, Thanks for sharing.
I am not sure what changed but for most of the part, I had all the packages installed but it was still not working. But then, I executed the script you provided and viola, it now works. :slight_smile:


An update on continuing further with installing required apps on Waydroid, I was able to install the general apps such as WhatsApp using the waydroid app install command with the APK downloaded from APKPure. It works fine and app shows up and is usable too. When I tried similar approach for some of the banking apps, the app, the command gets executed successfully but the apps do not show up. Not sure what happens with them.

After some looking around on the internet, I then switched to using the Aurora AppStore. The banking apps get installed properly when installed through the Aurora AppStore and do show up as expected. Although, I am not sure how authentic and reliable the Aurora AppStore is (since it is a third-party Appstore)

I am not having an issue with the bin formatted apps. There is no app in Waydroid that can open the *.bin formatted installer.

On a side note, am still waiting for @dos to provide the document or for that matter, update the images at location

I’m not going to update these images. We’re going to use upstream images, and Waydroid’s dependencies are now on their way to PureOS to make it easily installable.


@buzzLightyear For some apps, I’ve been able to figure out the reason why they’re not appearing by looking at waydroid logcat for hints.

FWIW I’ve been using aurora app store on clayx for a couple years now, I haven’t seen any issue with it.

1 Like

Thanks @sim6 for your instructions !

I download the newest Waydroid system and vendor image (18.1/Android11) from here (arm64)
and it works.

Your have the choice with or without GoogleApps.