Anyone Successfully Run WayDroid on Librem 5?

I already fixed some issues seen on this video:)

Here are early and experimental instructions on how to replicate my setup:

When I say early and experimental, I really do mean it. You need patches in kernel, Mesa and Android image - but there’s nothing in those patches that’s inherently hacky or dirty, so I’m hopeful that it will all work out-of-box in a not so distant future:)


That’s pretty awesome, thanks for your work on this dos!

Are there any plans to package waydroid with PureOS in the future?

1 Like

I don’t know whether Waydroid itself will be packaged in PureOS (it allows you to easily download images with proprietary code included), but I’m certainly interested in at least making installing it just a matter of a single deb package.


I not interested on Waydroid, either with .deb. I just saying…

It offers an option to download an image with Google Apps included. I’m not interested in that one either and that would clearly be against the policies in PureOS, so this feature would sure have to go out. By default, however, it does download a FLOSS image (at least as far as I’m aware - I haven’t made a full audit of what’s included in this particular blend of LineageOS). I would still be careful with it downloading it automatically from 3rd party servers outside of our control - which is why I’m generally not interested in packaging Waydroid into PureOS at this time. Maybe once there are Replicant-based images available :wink:


Is something supposed to happen on the screen when tapping the “Waydroid” icon on the screen? I tried following @pini’s instructions and things appear to work, I get that icon, but then … nothing. (I waited about twenty forty minutes so far).

% journalctl -fu waydroid-container.service
-- Journal begins at Tue 2021-07-13 19:29:25 CEST. --
aoû 30 21:00:58 librem waydroid[651]: [21:00:58] Failed to add service waydroidhardware: -1
aoû 30 21:00:58 librem waydroid[651]: [21:00:58] Failed to add service waydroidhardware: -1
aoû 30 21:00:59 librem dnsmasq[17456]: Lecture de /etc/resolv.conf
aoû 30 21:00:59 librem dnsmasq[17456]: utilise le serveur de nom
aoû 30 21:00:59 librem dnsmasq[17456]: Lecture de /etc/resolv.conf
aoû 30 21:00:59 librem dnsmasq[17456]: utilise le serveur de nom
aoû 30 21:01:28 librem dnsmasq-dhcp[17456]: DHCPDISCOVER(waydroid0) 00:16:3e:f9:d3:03
aoû 30 21:01:28 librem dnsmasq-dhcp[17456]: DHCPOFFER(waydroid0) 00:16:3e:f9:d3:03
aoû 30 21:01:28 librem dnsmasq-dhcp[17456]: DHCPREQUEST(waydroid0) 00:16:3e:f9:d3:03
aoû 30 21:01:28 librem dnsmasq-dhcp[17456]: DHCPACK(waydroid0) 00:16:3e:f9:d3:03


% waydroid status                           
Session:        RUNNING
Container:      RUNNING
Vendor type:    MAINLINE
Session user:   purism(1000)
Wayland display:        wayland-0

That’s with waydroid 1.3.0…

1 Like

Thanks for your work. Any tips on getting the GPS to work?

Installation too complicated for me.
However WayDroid will become essential for me because although I use “PassCyberplus”
for my banking transactions, this one is abandoned for the Android application.

@dos did you already submit the waydroid patches?
If so, could you link these so we can follow the progress and have an idea when it will become broadly available on the L5?

1 Like

@dos created two merge requests, one for mesa drivers and another for linux kernel. These two merge request are already merged but not released yet.

About waydroid, @dos only modified the source of waydroid related to build the debian packages. So we can use the packages released by waydroid.

1 Like

ok, thanks for this information!

pureOS released @dos’s changes related to linux (v6.0.2pureos1) and mesa (v21.2.6-1pureos4) described in previous comment (Anyone Successfully Run WayDroid on Librem 5?). Do you know if waydroid was added the changes to android image (

1 Like

@sim6 Does that mean we can sudo apt update and we can use waydroid? Not sure how to get that working…

1 Like

Yes, I have:

About GPS:

Which DISTRO= did you choose?

I don’t use Unbuntu and can’t get the image generated under arch right now. Can someone share this with me?

I’m about to write updated instructions. Turns out that the current upstream images are broken again, so I have to figure out which exact change is responsible, but that shouldn’t be a big deal - I still have a set of working images here locally. Don’t use the old ones I posted earlier, there’s a lot that has been fixed since then.


will the camera be usable in waydroid ?
I don’t wish to use any android apps but my banking app
identifies me at install time by taking a photo.
Last time I tried, that was before receiving my librem5, on a
pinephone, but it crashed when trying to access the camera.

No, as it is right now Waydroid is not able to use the cameras.

I’m using bullseye:

sudo wget -O /usr/share/keyrings/waydroid.gpg
echo "deb [signed-by=/usr/share/keyrings/waydroid.gpg] bullseye main" | sudo tee /etc/apt/sources.list.d/waydroid.list
sudo apt update
sudo apt install waydroid
sudo mkdir /usr/share/waydroid-extra/images/
sudo mv system.img.xz vendor.img.xz /usr/share/waydroid-extra/images/
pushd /usr/share/waydroid-extra/images/
sudo unxz -T 0 system.img.xz vendor.img.xz
sudo waydroid init
echo "persist.waydroid.use_subsurface=true" | sudo tee -a /var/lib/waydroid/waydroid_base.prop
sudo systemctl restart waydroid-container