Anyone Successfully Run WayDroid on Librem 5?

purism@pureos:~$ apt show linux-image-6.0.0-1-librem5
Package: linux-image-6.0.0-1-librem5
Version: 6.0.6pureos1

hi all when i try to compile
gbp clone --debian-branch=pureos/byzantium
cd libgbinder
sudo apt build-dep .
gbp buildpackage --no-sign

i get the following error.

make[2]: Entering directory ‘/home/purism/waydroid-deb/libgbinder/test/binder-ping’
make[3]: Entering directory ‘/home/purism/waydroid-deb/libgbinder/test/binder-ping’
make[3]: warning: jobserver unavailable: using -j1. Add ‘+’ to parent make rule.
cc build/release/binder-ping.o -fPIC -lgio-2.0 -lgobject-2.0 -lglib-2.0 -lglibutil …/…/build/release/ -o build/release/binder-ping
make[3]: ‘build/release/’ is up to date.
make[3]: ‘build/release/’ is up to date.
make[3]: Leaving directory ‘/home/purism/waydroid-deb/libgbinder’
strip build/release/binder-ping
install --strip-program=true -m 755 build/release/binder-ping /home/purism/waydroid-deb/libgbinder/debian/tmp/usr/bin
install: WARNING: ignoring --strip-program option as -s option was not specified
make[2]: Leaving directory ‘/home/purism/waydroid-deb/libgbinder/test/binder-ping’
make[1]: Leaving directory ‘/home/purism/waydroid-deb/libgbinder’
debian/rules execute_before_dh_installman
make[1]: Entering directory ‘/home/purism/waydroid-deb/libgbinder’
for n in debian/tmp/usr/bin/binder-; do
help2man -n “testing tool for libgbinder” -N --version-string=‘1.1.26’ “$n” > debian/${n##
help2man: can’t get --help' info from debian/tmp/usr/bin/binder-bridge Try –no-discard-stderr’ if option outputs to stderr
help2man: can’t get --help' info from debian/tmp/usr/bin/binder-call Try –no-discard-stderr’ if option outputs to stderr
help2man: can’t get --help' info from debian/tmp/usr/bin/binder-list Try –no-discard-stderr’ if option outputs to stderr
help2man: can’t get --help' info from debian/tmp/usr/bin/binder-ping Try –no-discard-stderr’ if option outputs to stderr
make[1]: *** [debian/rules:27: execute_before_dh_installman] Error 127
make[1]: Leaving directory ‘/home/purism/waydroid-deb/libgbinder’
make: *** [debian/rules:32: binary] Error 2
dpkg-buildpackage: error: debian/rules binary subprocess returned exit status 2
debuild: fatal error at line 1182:
dpkg-buildpackage -us -uc -ui -i -I failed
gbp:error: ‘debuild -i -I --no-sign’ failed: it exited with 29

Am getting error:

~/waydroid-deb/libgbinder$ gbp buildpackage --no-sign

gbp:error: You have uncommitted changes in your source tree:
gbp:error: On branch pureos/byzantium
Your branch is up to date with ‘origin/pureos/byzantium’.

Changes not staged for commit:
(use “git add …” to update what will be committed)
(use “git restore …” to discard changes in working directory)
modified: Makefile

Untracked files:
(use “git add …” to include in what will be committed)

no changes added to commit (use “git add” and/or “git commit -a”)

gbp:error: Use --git-ignore-new to ignore.

Subsequent install of:
‘sudo apt install ./libgbinder1_arm64.deb ./libgbinder-dev_arm64.deb’


What’s the output of /home/purism/waydroid-deb/libgbinder/debian/tmp/usr/bin/binder-ping?

purism@pureos:~$ /home/purism/waydroid-deb/libgbinder/debian/tmp/usr/bin/binder-ping
/home/purism/waydroid-deb/libgbinder/debian/tmp/usr/bin/binder-ping: error while loading shared libraries: cannot open shared object file: No such file or directory

Ah, my bad! I have pushed a fix, you can remove the libgbinder directory and retry the commands since gbp clone.


works perfectly thanks

I ran into trouble once I got to the launch the waydroid app. It didn’t seem to do anything. Had to run sudo waydroid init and things worked fine after that.

Also thought it was interesting that after building a lot of the debs it tell me it doesn’t want to use the rpm I built, and installed it from pureos:byzantium. So seems like a lot of the pieces are now in pureos!

Also, word of warning. When doing the install I recommend disabling your cell data (or just switch the modem off). Found that if you don’t have a ipv6 address on local wifi it will download the images over cell data… Which fully drained my data allowance when I tried installing waydroid last :stuck_out_tongue:

I have got it running but even though you can reach the internet from “sudo waydroid shell” most apps keep looking for wifi like stereo but a few work (like element, and authy) ip addr show shows a different network than my wifi as well… looks like

That is cool. I have been able to install APK and it seems to be running well even with offline maps downloaded. They use their own map sources for Czech republic but the rest of the world maps are based on OpenStreetMap.

The APK is not downloadable directly from, but the next grab
9240006-APK-8e8eb689e0a81744261eae366e6a0cd4 is confirmed by the project development team leader at (Jan Havlicek) to be the last version (9.24.0) and checked to be genuine. Sent sha1sum 5680eacdd8e076b8e92657aecde841f1e202e4fc matches.

Thank much to the great work. And it seems that Pavel Machek hacks on Millipixels seems promising as well, I have compiled the last version and it seems to auto-focuss to the right position today the fist time…


I am not so droid familliar that I recognize if this is the normal behavior why many apps say they cant talk to the wifi… it shows me this…

if it could just use the phones internet every time… then I could make use of some apps that don’t need bluetooth etc

There’s no WiFi exposed to the container; that’s expected and by design. The container uses a virtual Ethernet network that routes via phone’s connection (whether it’s via modem, WiFi or USB, with VPN or not - doesn’t matter, Android has no way to know the difference). I’ve seen that there are some ways to expose a fake WiFi network to particular applications to workaround poorly behaving apps that check for WiFi presence, but I haven’t used that option myself.


thank you that is exactly what I was guessing was happening, and since you have seen it I might be able to find a work around… I thought it was bad for to ask for direct access to the wifi … it seems that since it’s to control the appliance they manufactured they think it’s fine, but I am not a fan of that (I am glaring at you pioneer LOL) it seems most the apps I want to use have some need for direct access to something or I could already do it in linux

1 Like

I have seemed to hit a snag towards the end of the installation. After entering sudo apt install ./python3-gbinder_*_arm64.deb I get an error.
E: Unsupported file ./python3-gbinder_*_arm64.deb given on commandline
I have tried to search for this package with apt search and nothing comes up. I followed the instructions line by line up to this point. Did this package not make into the repository? Everyone else here seems to have had success installing everything. Should I continue installing the rest and circle back to this?

I ran across a post about this particular issue for Ubuntu here and
and went to the Waydroid site
which tells me to add to my source list and set the distro then install Waydroid with apt. which none of this coincides with the instructions posted for the L5 so I am hesitant to do anything from the Waydroid site. Am I missing something here? Apparently I must have. I have gone back and and started over and still come up with this error when I get to that line again. I am guessing no one else has come across this problem since I do not see any complaints about this particular error. Any insight on how to remedy this problem would be greatly appreciated. Once this is resolve and I am able to install my financial control apps I just have to wait on pulse audio to implement the packages needed to connect to my vehicle for hands free operations while driving and the L5 will be worthy enough for daily use and I can lose my current data sucking phone.

1 Like

I have always enjoyed using the Librem5. I have a question, but can Librem5’s waidroid use Bluetooth and Japanese? I cannot input Japanese. Is there a way to achieve Bluetooth and Japanese input implementation?



Japanese input

Input is handled within Android, so it’s the same as it would be on Android phones. It’s hard for me to tell more since I barely know Android, and I know Japanese even less :slight_smile:


@dos, two questions: Is it now “much simpler” after three weeks and your installation guide reflect this, i.e. was updated? Thanks for your work. I will not install this on my L5, but perhaps on the L5 of my 12-years old son to avoid buying him an Adroid phone, because his Ubuntu E4.5 does only support 2G network (due to a hardware limitation).

1 Like

has anyone else had trouble with the clipboard inside waydroid? it seems to copy from any app but paste is never an option… which has made typing my random / log passwords quite a challenge

There is a clipboard dependency that you need to install on your L5. I ran into this same issue. If I remember correctly, installing xclip resolved it

sudo apt install xclip