Axolotl librem 5

Anyone know how to set this up? I tried install electron and flathub axolotl package but no luck.

Best bet is to compile signal for mobile.

It looks like pretty bad scaling but worst of all is that install process. Makes me feel sick :confused:

1 Like

I did not try it myself yet, but according to Kyle there is (or at least there was at some point) a build for mobian that could be used on the Librem 5:

1 Like

Try the build for Mobian (the Flatpak on Flathub has never worked for me), it should work for you on PureOS Byzantium (it’s slow on first launch, so give it time), unless something at Signal has broken signing up again:

If Axolotl is not working for you, Signal Desktop might be an option, but the build for Mobian Unstable definitely does not work on PureOS Byzantium.

The other option, as previously mentioned, is SignalRs. I’ll am currently experimenting to see if I can get my build of it for Arch Linux ARM (PinePhone) to run on Byzantium.

Edit: Looks like I’ll need to recompile SignalRs for Byzantium.


I’ve installed the axolotl-mobian-package on my L5 Byzantium as linmob mentioned above. It works! It doesn’t recognize neither my adressbook nor my camera, which is quite annoying, but it can handle images and movies, real 21th century stuff… :wink: I’m really happy.

1 Like

I don’t understand how to build axolotl. I followed instructions there and 1.0.8-2 gives notice saying something about connection to signal servers then crashes my phone. Signal you just said doesn’t work and I have no idea how to install signalrs as I can’t meet the dependencies to compile.

I’ve been trying to build SignalRs on the Librem 5 yesterday.
The dependencies I’d install from it’s dependency list (which, as base-devel suggests, is relating to Arch or Arch-based distributions where the following:
sudo apt install build-essential qtquickcontrols2-5-dev kirigami2-dev qtwebengine5-dev curl

Mind you that this list of packages may be incomplete, as I’ve compiled other things earlier on my Librem 5.

Why curl? Well, we need rustup which can be installed as described on it’s website. While going through the installer, make sure to choose nightly, as that’s a requirement for compiling signal-rs.

Now, clone the repo
git clone

cd into it and run
cargo build --release

This is going to take a long while, it took me more than 12 hours. I ran out of RAM once, which is why you should use zram, a swapfile or something – or add a -j2 after build and run the command again after rebooting the phone – luckily it starts of where it failed.

Honestly, if you have a more powerful ARM device (e.g. a Raspberry Pi 4 with 8 GB of RAM), I suggest you to try to use that device to compile – Debian Bullseye ARM64 should be similar enough to PureOS Byzantium.

Or just download the binary I compiled:
sha512sum: 97f6ed034b87d10ec4716a418220c05be8cc9e1db427357c9a9f4f39a6e1141df881e2ba888140d498f8fbf4bf1a6d77f8438ef361254189a4937a68d977f709 signal-rs-bin-l5-20211226.tar.gz.

(You’ll still need to have the dependencies (at least qtquickcontrols2-5-dev kirigami2-dev qtwebengine5-dev, or whatever the packages are that these depend on, you don’t really need the headers I guess) installed for this, and there’s a simple “” script in the archive (it requires curl to be installed) to make installation easier.)

Have fun!

Quite comprehensive. Will follow and add a new message on the thread once it fails or works.

So I tried the axolotl-mobian-package mentioned by @ehoff above and it worked for me. The first time I ran it it seemed to hang, but since he said it took a while the first time I waited. I killed it, and tried again and I entered the phone number and it sent me the code (after a CAPTCHA screen). Didn’t pull in my contacts. Added one manually and was able to communicate. There is an import contacts option that I haven’t tried yet. Note that Signal doesn’t like two devices registered with same number at the same time, so if you register one, the other becomes de-registered.

Anyway, this is one more app I need to make the Librem 5 usable, as I have some contacts that use Signal. Since it is working, this is definitely progress. Thanks @ehoff for providing the info.

1 Like

I just got it working but it is pretty terrible for many reasons like not being able to set timer in chat (only decided by recipient), no contacts synced, no voice recording button, keyboard input not taken sometimes, no option to move chat history, no voice call and couldn’t keep using pin. At least it can text message people on signal but it is pretty far from perfect.

Well I tried following all your instructions but got error when building and when using your binary, it says module qtwebengine is not installed despite me installing.

Please post the exact error, maybe I (or someone else) can help then.

If you run the build command (cargo build --release) again, does it fail exactly the same way? Also, what’s the error when launching the binary?

I did again and it was the same. For the binary, it just tells me qtwebengine is not installed and the app doesn’t crash or anything but it doesn’t show anything so I control C.

Maybe run apt search qtwebengine and install some (or even all) of the additional packages?

Installed qml-module-qtwebengine and it launched but once I linked it as a secondary device, it doesn’t really work. I can’t see when someone sends me a private message, I can’t see group chats or really do anything.
there’s a button to create a group chat but it does nothing.

Hm, unfortunate and strange, I bet something changed in Signal again. It still worked ok for me quite recently, but not anymore either…(I only tested whether it would launch on my Librem). Sorry. :frowning: I suppose we’ll need to create an issue/send a bug report.

That’s known, read

Link Signal Desktop and then you can set timer there. Works for me.

After a lot of f*ing around with different Signal solutions (axolotl, waydroid, anbox, carrying an android phone :roll_eyes:) , I ended up writing a non-puppeting bridge (i.e. relay) for signal to matrix:

You can run it directly on your phone though I’m not sure how battery-friendly that will be, or you can run it on any kind of server you have (I run it on a RPi in my house), and it will allow text-messaging with Signal using a matrix chat client (e.g. chatty, nheko) without the need to run your own matrix homeserver.