Battery drain while suspended


#5

Yeah, I’m still seeing this too. What could be draining battery while suspended? Display backlight is on? HD / SSD is powered?

All it should be doing is keeping the RAM alive, yes?


#6

I have the same problem on my 13v2 with Ubuntu 16.04


#7

How can I check that too?


#8

@kakaroto do you think this is bug in coreboot?


#9

I am impacted by this issue as well, on a Librem 3 v2.

Can it be related to firmware having been stripped down in PureOS?

/var/log/messages:Apr 3 21:27:32 librem kernel: [ 1.320460] i915 0000:00:02.0: Direct firmware load for i915/skl_dmc_ver1_26.bin failed with error -2
/var/log/messages:Apr 3 21:27:32 librem kernel: [ 1.320465] i915 0000:00:02.0: Failed to load DMC firmware [https://01.org/linuxgraphics/downloads/firmware], disabling runtime power management.


#10

On my Librem 15v2 (with AMI bios and Debian), I have the same problem. I once left the laptop suspended for ~48 hours, it fully drained the battery. Please note that I configured the USB ports to sleep when idle through powertop (and it works, since I have to toggle them back to “normal” if I want to plug in a usb mouse, otherwise the mouse goes to sleep after a very short time of inactivity).


#11

@mladen Does someone investigate the problem? Do you think it can be fixed by software?


#12

Hi @Honza,

When looking for issues on the tracker I couldn’t find anything open when searching with the keywords “suspend”, “battery” or “drain”.

If you have an account you may want to open a new issue. If not, I can open the issue for you if you don’t have feedback from @mladen in the meantime.


#13

Issue opened: https://tracker.pureos.net/T419


#14

This could be indeed the fault of stripping down the intel nonfree firmware - anyone with Debian can compare their behavior now and once they enable nonfree repo and add the missing firmware (isenkram is useful tool for detecting lacking firmware) to confirm this.


#15

I am seeing:
Failed to load DMC firmware i915/skl_dmc_ver1_26.bin. Disabling runtime power management.

On boot


#16

It seems that the “Failed to load DMC firmware i915/skl_dmc_ver1_26.bin. Disabling runtime power management.” is driven by pureos not including proprietary software that would be necessary for GPU power optimization. It could be the source of the issue, but that makes it seem less likely to me.


#17

Same trouble with my librem13-v1 on Debian Buster: the battery is fully discharged after each night while the host is suspended.


Enhancements Librem Laptops by experience
#18

Yeah same for me on my Librem 13v3…power steadily drains away while the laptop is closed and suspended.


#19

After checking, I don’t have any “failed to load xxx” in my dmesg. But isenkram found a few missing packages: firmware-misc-nonfree and firmware-iwlwifi for the following extra firmware files:
i915/bxt_dmc_ver1_07.bin
i915/bxt_guc_ver9_29.bin
i915/bxt_huc_ver01_07_1398.bin
i915/kbl_dmc_ver1_04.bin
i915/kbl_guc_ver9_39.bin
i915/kbl_huc_ver02_00_1810.bin
i915/skl_dmc_ver1_27.bin
i915/skl_guc_ver9_33.bin
i915/skl_huc_ver01_07_1398.bin
intel/ibt-11-5.ddc intel/ibt-11-5.sfi
intel/ibt-12-16.ddc intel/ibt-12-16.sfi

I have now installed them, I will let the laptop suspend for a night and let you know how it went…


#20

All these firmware packages are installed on my buster installation and still seems to have the trouble.

$ dpkg --list | grep firmware-linux
ii  firmware-linux                         20170823-1                              all          Binary firmware for various drivers in the Linux kernel (meta-package)
ii  firmware-linux-free                    3.4                                     all          Binary firmware for various drivers in the Linux kernel
ii  firmware-linux-nonfree                 20170823-1                              all          Binary firmware for various drivers in the Linux kernel (meta-package)

Will wait for @bavay report.


#21

So, after installing the missing firmware and fully charging my Librem 15v2, it went from 100 down to 75% in 18 hours (suspended for the whole time). So a fully charged laptop would drain its battery while suspended in 3 days. For my usage, this is not a huge problem, but we are far from what is achieved by other laptops…


#22

I had this issue on a Librem13 v3 runining Manjaro and powertop seems to have stopped the bleeding. Basically I ran “powertop --html” and it generates an HTML report. There is a “Tuning” tab with a list of commands you can put into a script and run on boot and essentially change settings that waste power. This has stopped my lose of power when suspended. This page is Manjaro specific but I believe it will work on most distros.

https://wiki.manjaro.org/index.php/PowerTOP_to_Optimise_Laptop_Power_Consumption

Hope it helps.


#23

I tried the Powertop thing on my 15v3 and maybe it helped some, but it doesn’t seem to have fixed the underlying issue.


#24

Have you done a “sudo apt-get full-upgrade” ? I went back to PureOS to get the most out of the machine and saw (somewhere) to run the “full-upgrade” which I was not familiar with. It installed some more packages and my machine has been running well and the battery has been lasting well. Not sure if the full-upgrade is related but thought I would mention it.