Battery? - what battery?

Battery discharged when off.


  1. List item Opened box, followed step x step from little manual.

  2. List item Place phone on flat surface, put cable into phone other end into adapter, and that into the wall. A red light came on.

  3. List item

  4. List item Waited 2 1/2 hours - so unplugged it, removed cable.

  5. List item Battery showed 81% Turned it on, walked through some setups.

  6. List item Touchy keyboard, just wave my finger over a link and we’re off to a unknown screen.

See addendum below

1 Like

While having the phone off the charger, and turned off the battery had already dropped to about 1/2 .
Earlier, I tried to turn it on, but I’d get past the 2 passwords, the desktop(?), and suddenly shut down. I kept at it and I got faster, and the battery looked empty. I put it to charge. After about 2+ hours, red light was still on battery at 81%. I turned on the phone, logged in and noted usage high. Left phone to continue it’s charge then 45 - 60 minutes again, checked.
Aha!? When I went back to the phone, tapped, a few times to see if it would wake from a sleep, it din’t, I pressed Pwr button and immediate;ly, I was at Usage! No going by passwords? So, it doesn’t sleep when pressing & holding the Pwr button. But, battery is where it was much earlier - CPU 81%.

The usage remains high till the screen closes. It’s like the light in the fridge - how do we know if it goes out - same thing how do we know if usage drops off? More important, why draining so fast?

When charging, all 3 switches are in Off.

Oh really? Then you can Swap the Battery of the Phone if the Phone is really off. However it will lose Energy too physically like any other Batteries too.

But the Issue is another. And you will take care about your phone. However try to update and use it locally on wire, till it got updates for common usage. It will safe energy and hold fore more than two or three days if the code is fixed and save energy with suspend, in the future.

Could you record a video showing the issues you’re experiencing? It certainly doesn’t sound normal to me, but I’m not quite sure I understood what you wrote well.

Who are you asking? You replied to the post, but didn’t say who you’re replying to.

to your post of course, no one else has written.

You said “swap the battery”. Swap it with what? I an’t get any from the US without flying to California to find one to swap with. The phone is possessed. I do not understand what you mean by

in less than a hour? Without use? I know batteries will drain, I also know this phone should hold a charge longer than that.

I fail to understand that.

Too bad the USB is so short or I could use it with the charger plugged in unless I use a extension cable to plug the charger into BUT, last night I did read here about current and such stuff and if the gist is what I think, if I read it right, then the charger must be plugged into the wall. A cable might not do what the wires inside the wall can do. I certainly won’t take it anywhere because I cannot depend on it so why carry more weight or have.

I just managed to past the 2 security logins and the Desktop showed up, see the battery has something orange over it. This phone was preset set to show screen zoom set at 200 and even then, it’s too small to see what is over the battery. But I saw enough of the battery to see it’s empty. When it finally charged after 4 hours (blue flashing light) I checked and the battery was up to the bottom of the nipple. I went to “Usage” and saw it was running in between 110%. If the CPU needs so much to just sit there displaying Desktop, why not find out what it is that’s causing 3 - 8 second delays between a key being pressed and the system responding.Like I said it’s possessed.

1 Like

I assumed you were responding to me or the post you didn’t notice of course.

You’ll have to take my word for it. No one I know has a camera that can video micro screens. What part do you want a video of, accessing the two security pass-whatever (password, passphrase, access code, then the desktop flash on and off? Anyway, 2 quick photos are colour-bashed, very grainy, and light worsened distortions. Please, no not insult with any …‘did you…’ stuff.

I didn’t say I never knew how to use a cell phone, my reputation is that I never owned one, until now.

Thanks for the read,

Any part of it. As far as I can tell, you’re the first person in history to have those issues on the L5. It’s extremely difficult to diagnose what’s going on from just the description.

Thank goodness the L5 doesn’t have a micro screen. Any camera on a phone made in the last 10 years will suffice.

As long as the content of the screen is visible and somewhat readable, it’s all fine.

1 Like

I haven’t got that far yet of taking and sending images. But do you really need a very screen shot of my desktop. OK. When I figure out how to make flash work. Maybe it just needs a lot of light.
Now, I just need to have enough power to last at least a hour.

Fine. it! 1 2 3 4 5 6 7 8 9 10

For what it’s worth;
@dos @irvinewade @dcz @Quarnero


L5 was plugged into a wall outlet.
then it was shut down
(Shutting Off: Press power button.)

Not Charging the battery - charger not plugged in.
7:42 PM 96%
9:46 PM 83%
2:12 AM 53%
2:48 AM 49%
9:40 AM 2%

All Kill switches were in Off position.
Phone was only used to view the %'s.
Started re-charge at 9:45 AM today.
(All times in PST
Uh OH! It’s possible that upgrades/updates may have happened but I didn’t do it!
I saw there were updates when I had 10 - 20 seconds of view time before it would shut down. That issue seems to have corrected - when plugged into and charging.
Let’s see what charging and drain does today. Meanwhile, I’ll try and get @Quarnero and @dos they want done and sent.

I reached out to last night.
My Time Zone PST/GMT -08:00

1 Like

I’m not sure how much battery life you are expecting from the L5, that seems pretty normal, you went more than 12 hours on a single charge. If there are updates you should run them, they are always working on security and performance enhancements. This isn’t a Samsung or an Apple phone with billion dollar companies behind their development. The software is still very much a work in progress.


I was told here not to run the updates yet ,but that may have happened without my doing it… Ask 10 artists to paint your portrait and you’ll get 10 different portraits. :wink:

As long as you are in charge over your phone just go ahead: Talking about Librem 5 in French language. sudo systemctl reboot would be another optional command (sometimes needed).

P.S. I consider upgrade of software as mandatory action and not something that should be avoided, in short.

I guess there is a misunderstanding about upgrading the OS (and Apps) and upgrading firmware.
Upgrading the OS is recommended, upgrading firmware is only needed when advised by support or if you feel save to do so and understand what the implications might be and how to solve them.


The updates that I was talking about are firmware updates for the ancillary devices (like the WiFi card, modem card, USB-C PD, …)

Updates to the vanilla Linux software (operating system and applications) should generally be applied when available.

Indeed. That’s one of the benefits of going through Purism support. One artist. One portrait.

Anyway, I hope at least one of the 10 portraits turned out.

1 Like

Unless the phone is locked up, shutting down should generally be done by using the menu that you get from the top line of the screen.

1 Like

Sure but I have trouble loading the PureOS Store - eventually it loads, but if I click on “Work” category, it opens but all lists are blank. Same with “Learn”. BTW, the [<] button doesn’t work anywhere. I close the screen by swiping it up, then up again, then again, then it closes - maybe - I don’t know. Unable to find reference to Turning phone on, or close application(?), or Shutdown. I just use the power button - a lot.

Sorry it’s taking so long. But sudo apt get required a “password” and it didn’t like the default it came with. I can login through crypt and login with ‘default’ 123456, (use same in both - for now). The ""[sudo] password for purism: [] refuses to accept any input. Just looks kewl blinking. Then after a few seconds, it hangs A reboot is necessary. I’ve tried this 4 times now - there is so much wrong.

Perhaps, if I send a USB/thumb/drive/stick/memory to Puri, they can load the USB thing with a screen and video capture, and send it back? Is going to a lot fast than working with a poltergeist.

If I can’t use the phone as a stand-alone, is there a way I can hook it up to a PureOS desktop and make changes from there? Do I have a expensive paperweight?