Battery? - what battery?

You can ssh in from just about any computer but you would first have to enable the SSH server on the Librem 5, and your Librem 5 would have to be on your local network (e.g. WiFi configured and working - is it?)

Or you can try connecting the Librem 5 via USB cable to a desktop/laptop and that should get you networking over USB (but either the desktop/laptop needs to have a USB-C port or, you need a USB cable with USB-A at one end and USB-C at the other end, or you need a USB-C to USB-A adapter - obviously the first choice is easiest since in that case the needed cable came with the phone).

You will be able to install software while you have ssh‌ed in.

Hmmm. @dos I’m thinking Purism should load the screen capture tool by default. It might be more useful than Chess for new users.

Press and hold wake/sleep button (button at the top of the right hand side of phone) until green LED comes on.

The password is not echoed on the screen for security reasons (but is still accepted)?

1 Like

I need a lot to do to get network to comply. Learn in’s and out’s of “ssh”. Then buy the cables, and then I’ll be able to take a screen cap/video to send to you guys so we can get this thing fixed?

Thanks for your help tho. I’m not prepared mentally, physically, nor able time-wise to rebuild a phone at this time and am not refusing help, nor refusing to cooperate. I am, and have been , and spent the entire day trying to get that file so I can can screen cap and send DOS a pic of stuff as requested.

Point is, why do something the hardest way when the device should should act like it can do something. and something does not include driving users crazy.

1 Like

Take any other phone and make a video. That will be enough.

Please start here: Beginner’s first steps, on how to use grim package. Simplest one would be (the one that I’m fine with):
sudo apt install grim

Open New Window from Terminal upper right corner and type:
sleep 7; grim

Now you have 7 seconds to flip to the screen that you need to save for you record. Above command puts screenshot directly into /home/purism directory, therefore you would want to use: sleep 7; grim $(xdg-user-dir PICTURES)/$(date +'%Y%m%d_%H%M%S_grim.png').

In my point of view @Sharon is the one that will master Librem 5 up to her pure satisfaction.

Some seem to be of the mind that everyone was raised handcuffed to a cell.This was going to be a gift. The giftee chuckled when I suggested it was for him. So it’s mine. I won’t repeat what he said about the -phone-.

The list keeps building and the issues go on. I should not have to use another cell phone to take pictures of a cell phone screen so I can fix so it can take pictures. WTH!

BTW - do you know how to turn the device off? Really OFF?

That looks completely reasonable. Maybe a bit short (I’d expect a few hours more with all kill switches off), but it depends on what may be running in the background anyway.

You select “Power Off” from the power menu, accessible after swiping the top bar down while unlocked. If you just short-press the power button, you only turn the screen off and lock the phone.

1 Like

Maybe relevant:

1 Like

That point only matters for long-term storage though. That “small amount of power” will discharge the battery in a matter of weeks, not hours.


Charge on my Purism 5 goes down to 0 in 1 hour. Turned off everything not needed and it still uses power too fast. Have to keep the phone turned off and carry a charger everywhere I carry the Purism 5.

Something is definitely wrong with your phone. Maybe a virus? You should try to reinstall the PureOS. Mine can stay with the modem on for about 10 hours.

Thanks. Many of the issues were solved with a upgrade. A full reinstall is my last resort.
Appreciate the thoughts

1 Like

I find most ‘upgrades’ anywhere is just another beta test. Upgrades always look good on paper and on the latest hardware. I’m retentive when it comes to M$ upgrades, patches, fixes etcetera, so I wait until their upgrades and such have been out for at least 4 weeks, then I review their forums to see just how buggy the upgrade is before installing that one. Habits are hard to break.

In the case of the L5, we started out with A LOT of bugs and catching up. The reason why we publish upgrades is to get rid of them. Windows has been some 30 years on the market, they had time to catch up already. They update for different reasons.

1 Like


In the PureOS store, using the magnifying glass icon, search for “screen shot” (two words) to find and install Purism’s own L5-adapted application: List of Apps that fit and function well [Post them here.]

Then search “screen recorder” to find and install Screen Recorder: List of Apps that fit and function well [Post them here.]
(Also choose a video player to work in conjunction with that, as described in the link.)

By the way, in the software store, in the Preferences, you’ll have to enable “Show Incompatible Applications” - a misnomer, actually, as many (but not all!) PureOS apps outside Purism’s curated selections for the L5 will work fine, or well enough, on the L5.

Sometimes it takes a while for these to populate, as it has to load the complete catalog over the network from Purism’s repository each and every time. (My Linux Mint computers also have such a delay loading from the Mint repo.)

Thanks @amarok but I have just about run out of patience with all the reading I’ve been shown to do, then translating acronyms, and the geekinese, I’m so far, still at the starting point with a $1,200. clock.

I was not prepared for the amount of time I would have to read, the time interpreting geekinese, to find out, that the object isn’t working yet, and no idea when it will, or if, be ready. And now, to learn and retain using SSH and other commands. WHY? Never mind.

I’m told it should work out of the box. What should work? Today I find out the camera won’t work AFTER long hours of reading and reading :face_with_symbols_over_mouth: only to be told it’s not working but to “use the flashlight”. The is NO “flashlight”! And I doubt they me and for me to use a hand-held flashlight. Maybe, they mean the “Torch” Hmmm, well as candle is 4 time brighter than the dim yellow the “tocrh” outs out, if that is what they mean. So, I should carry a spotlight around with me.

There are enough disappointed friends and co-workers over this - most laugh though and tell me to buy a smart phone which they know there is no such thing.

I’m hoping I will find out what will or will not work and decide then if I sell it for parts, or keep as a reminder.

Who told you that? Both cameras work. If they don’t work for you, how does that manifest?

It was doing that before I connected it to wifi or used the phone to call anyone.

Camera has no flash told me.

It’s easy to know the camera doesn’t work by taking a number of pictures, then looking at them Voila! Looks like a explosion in a yellow-crayon factory.

I don’t know what you mean by manifest.
Do you use a translator by chance?

Too, it’s the “flashlight” (icon says “Torch”) that is a work in progress
I must have missed the memo when reviewing the ads.


The camera works, but the flash is kind of do-it-yourself. Sorry about that.
Could you show the crayon factory explosion? I haven’t seen it on my photos. Perhaps your camera lost its configuration somehow.

As to whether I use a translator, let it remain my secret. Suffice to say, you had understood me as intended.


@dcz interesting you say the camera works. I can’t get the camera to work myself.

I can’t get it to snap a photo. Also, when you say it works, do you mean without having to manually adjust gain, exposure, etc? I have to manually adjust those settings to be able to see anything from the camera. Then, clicking the photo button, doesn’t work for me?

With everything I’ve been reading in these forums about the focus of work being on camera, I was assuming the camera is still not to an ideal state of functionality, operabililty? Am I mistaken on that?

1 Like