Bios boot drive


#1

After a recent coreboot update, my boot drive order was messed up. I tried using the coreboot script to fix the boot drive order but it doesn’t seem to work.

Is there some way I can change the default drive used to boot? Every time I restart I need to interrupt the boot process and manually pick the correct drive.


#2

Might I ask for more details? Which coreboot version, what error message you see?


#3

Absolutely.

We can focus on the coreboot version that messed up the bios considered boot drive, but I think the more critical issue, at least now, (not that this is super critical to begin with) is that the scripts ability to reorder the boot drive doesn’t seem to work or stick at reboot.

I pulled the script yesterday using wget. Then ran it just to see if updating coreboot would fix it. It fixed a gummed up initramfs but did not fix the boot order.

I was wondering if there is just something I can run that would do that. I suppose I could just look at what the script is doing but want to be cautious as I’ve got my librem quite setup and don’t want to risk messing that up, again. Thanks for your help!


#4

what is the default order you’re setting via the coreboot utility script?
what is the order shown when bringing up the SeaBIOS boot menu?
what device is your boot drive?

also, please pull the cbmem boot log using the cbmem utility as follows:

curl -LO https://mrchromebox.tech/files/util/cbmem.tar.gz
tar zxf cbmem.tar.gz
sudo ./cbmem -1 > cbmem.txt

then throw the log on pastebin (eg) and link here. If cbmem gives an error, you may need to reboot and add the kernel parameter ‘iomem=relaxed’ to your grub kernel arguments

you’re the first to complain about this, so sounds like a corner case is being hit somewhere. The function is working for all the cases I tested, and for the vast majority of users, otherwise there’d be more complaints


#5

2.5 Sata drive
NVMe Drive
external drives

SeaBIOS has it ordered:

NVMe Drive
2.5 Sata drive
external drives

Boot device is the 2.5 sata drive (Samsung 250gb SSD). There is however the NVM drive, and when I first got the laptop, PureOS was installed on it. I wanted to use the bigger drive, and let the NVM drive be the VM storage.

Here it is:
https://pastebin.com/YHUANPYp

(first time using pastebin, so hopefully sharing settings are right on it… if there are even sharing settings.)

Sorry, I didn’t mean to make it seem like the script was the only possible culprit. I agree with you completely, I’m probably a fringe case, and I appreciate you even taking the time to address it.


#6

looks like it wasn’t able to read from /dev/mem properly, can you retry with the kernel param I mentioned above?

of course, I don’t like it when my code doesn’t work properly


#8

Sorry decided to trust a random search and got it working. New pastebin paste here:
https://pastebin.com/DZwmSDXG

Thanks again!


#9

ok, looking at your bootorder file from the log, it’s showing:
2.5" SATA
USB
m.2 SATA

which isn’t what you want. I just used the script to generate a bootorder file with the order that you want, which is:
m.2 SATA
2.5" SATA
USB

and verified that the file output is correct. So I think the confusion comes from the fact that 1) you don’t have a NVMe drive, and 2) the m.2 SATA drive is your boot drive (the 250GB Samsung), not the 2.5" SATA (120GB Biwin SSD)


#10

Can we delete this thread? I can’t believe I overlooked something like that.

Problem solved.