Bluetooth - Logitech 'M240 silent' mouse not found

Hi friends!

I tried to connect a bluetooth mouse ‘Logitech M240 silent’ to the Librem 5 but it is not shown in the bluetooth menu. The mouse works and is found by my (Ubuntu) Laptop. Do you have an idea, what to do?

Thanks in advance

have you connected with success other bluetooth devices to librem 5?

Have you check the bluetooth killswitch is on?

Hi Tonyp,

yes the killswitch is on and I can see the list with bluetooth devices. I could connect the Librem 5 to my Laptop via bluetooth and send files with success. The mouse does not show up in the list (Librem 5). But the mouse shows up in the bluetooth list of my Laptop.

idk perhaps it is a driver issue. Gnu/PureOs is free software and doesn’t work out of the box with private drivers as ubuntu does.

Do you have the SparkLAN card (L5 shipped early 2023 onwards) or the Redpine card?

If it’s Redpine it needs a firmware update to enable Bluetooth LE mode which most if not all Bluetooth mice require.

Mmmmh I don’t know.

How can I check, if I have the SparkLAN or the Redpine card? And how would I update the firmware?

When I type
nmcli -f GENERAL.DRIVER d show wlan0

then the output is
GENERAL.DRIVER > lines 1-1/1 (END)

So I can’t see which LAN card is in. Is the bluetooth controller part of the LAN card?

On the same line as “GENERAL.DRIVER:” on the far end should be the beginning of the output. It could be hard to see on the phone screen

Aaah nice. In the landscape mode I could see it. The output is

According to the link of irvinewade it should be a Redpine Systems card. How can I now update the firmware?

To update the Redpine firmware you can follow the first steps on this post:

Hah, OK, my bad.

I think when I executed that command, I was sshd in from another computer - and that is another workaround.

I updated the Wiki.

Hi @Sarcasmo220,

thanks for your reply. I followed the steps but the command

sudo dmesg | grep redpine

did not output anything. I entered the commands

sudo apt install wget
sudo mv RS9116_NLINK_WLAN_BT_IMAGE.rps /lib/firmware

and rebooted the phone, but the first command still gave no output and I still can not find the bluetooth mouse.

Do you have further ideas?

Hello @angus.ainslie can you tell us when we can get the newer Redpine firmware/driver for L5?
Thanks of advance.

Hmm, unfortunately no, as I did not write the instructions and I don’t have that level of knowledge when it comes to dmesg logs.

Did you have the bluetooth enable? Hardware kill on and bluetooth on in setting.
If it’s on, you should have the bluetooth icone on the top left.

This command can be dangerously wrong i.e. if the /lib/firmware directory did not already exist.

I suggest you confirm whether the above command bogusly created the directory as a regular file - or whether it worked correctly - by posting output of ls -l /lib/firmware