Bluetooth stuttering

Sure, no argument there. :slight_smile: Maybe a stop searching button, then.
(In any case, don’t force people to open the bt settings.)

Shouldn’t it time out? It seems to run continuously.

wouldn’t mind a search on/off button

I don’t think so. I think running “continuously” is the way it should work i.e. scan forever for new devices. That’s basically the way WiFi works too i.e. it is always on the lookout for beacon frames from new Wireless Access Points. (There are differences though between BT and WiFi as to how this works.)

So I think that if you want to pair more than one device then pair all the devices one after the other before playing any audio over BT - or if you want to pair a new device while playing audio then it may be a nicer user experience to pause audio playback while pairing the new device.

Is there something going wrong here? I don’t know. I don’t have that level of knowledge of the internals of BT.

It would be nice for purism to add an option to turn continous wifi, bluetooth or mobile network scanning off by default, even with settings open. Its a security issue and leak especially if you are already connected to known network of said wifi, bluetooth, or mobile.

Also gnome settings in that regard kinda is at fault, i created a user story a while back to stop wifi scanning when connected to a wifi spot already and the modem manager actually has a setting for it, its not used for convenience i imagine, but then standard distros arent focused on privacy as much as pureos is.

It should be a button, user clicks on to scan for additional or new networks otherwise just dont!

Benefits additional privacy, lower power consumption, and less interference.


Depends whether scanning is passive (listening) or active (transmitting something and listening).

That’s tricky though because of the need for roaming. WiFi needs to listen for other WAPs offering the same SSID even when you are already associated with a WAP for that SSID.

Maybe that is more likely to be an issue at work than at home - but that would mean it’s an attribute of the SSID, not a global attribute.

WiFi can do both passive and active scanning. Probably you are right that active scanning should be off by default. (I thought it was already but I haven’t checked.)

However as this topic is about BT, maybe we should leave WiFi out of it.

Then it is easy. Provide a button for “Roaming On” for wifi. It only sounds natural for a security enhanced phone to be able to stop BT scanning (as well as wifi scanning). In most use scenarios continuous scanning is not needed and disabling it will save some battery energy.

Here’s a new one: lately the L5 appears to connect to bluetooth speakers and receivers - the equipment generates a connection beep and/or the connected light comes on - but the music still comes out of the L5 speakers, not the speaker it says it is connected to.

Almost makes you long for the stuttering days…

That isn’t new…I’ve had to do the bluetooth dance turning things off and on (both L5 and devices) and rebooting etc…maddening. There is no rhyme or reason to it. Bluetooth at the best of times is temperamental. For some reason the audio path isn’t getting established after connection, not sure if it’s a timing thing or a handshake thing. Some times when I think I have the right combination of reseting (soft and hard switching) it throws me another curveball. Definitely needs work.

Well. it was new for me. I experienced the stuttering, and I had to manually connect every single time (start music, switch on bt, wait for it… nothing, open settings, click the device, connect the device, close both settings windows to prevent stuttering, enjoy music), but at least it connected and streamed pretty reliably.

Now, not even manually connecting works. Had not expected this kind of regression to be honest. I expect it to be a temporary thing.

Yes I can’t remember which update but this new behaviour came about after that…less stuttering but less reliable connection attempts. One in particular is when I have bluetooth connected and then when I get a call and I want to use the handset audio, I have to turn off bluetooth and then after the call and I turn it on again, I am unable to connect again to my bluetooth device. Let’s hope the next update solves this problem. It will go a long way to ending probably the most frustrating thing I find with it…other than that I love it.

Yeah, love it to bits! Really do. :wink:

1 Like

on occasion i make sure to forget the device, and re-pair, which addresses the no connect issue, once that is done it connects, even to my car fairly reliably - but I feel bluetooth is like a dance, you have to have your feet in the right place at the right time so you don’t step on your partners feet, there is no stuttering except:

  1. at beginning of connection
  2. when you leave the bluetooth scanning gnome settings page open while streaming
  3. as mentioned above sometimes you need to toggle not only the L5 bluetooth but the other device as well to get it to connect

Yes, sure. I know about all that. But my bt worked really well for months on end, Now it doesn’t. I wonder what went wrong. I haven’t changed a thing. Was there an update recently?

Good question, maybe there were some kernel updates to get things lined up for Debian 12. That is all i know.

General comment on linux regressions, seems like there is a general lack of rigorous testing that large companies are good at like Apple, or Android,- Linux on the other hand just doesn’t have that so over the last 4 years of my experience, i can tell you that if something works (don’t upgrade it!!) I know that is of little consolation though. Linux also makes it hard to not upgrade certain things since all packages are related between apps. So you have to upgrade app B to fix a break, while it breaks app A, sortof common.

I’ve had that happen to me too. It works well enough until suddenly it is constant stutter or no output at all; no matter if re-pair the devices or reboot.

At first I would just wait a week or two and then it would suddenly start working again. Last time I tried fully shutting off the phone, including taking the battery out for about 30 seconds, and it seemed to help. But with how random this issue is, who knows if it actually helped or not.

Wait! It gets weirder. It’s only Spot(ify) that doesn’t stream over BT.
Music from Amberol and Radio (the app) stream properly over BT. Music from Spot does not; it comes from the L5 speakers.

Could this be a bug in the Spot app? If so, how is that possible?

I am also experiencing the problems you describe with my bluetooth headset.
When this happens, and to avoid a reboot, I turn off the Bluetooth, open the terminal and enter the commands:

purism@pureos:~$ sudo systemctl restart bluetooth
purism@pureos:~$ pulseaudio -k

Then I turn on the Bluetooth, I launch the settings application and on the Bluetooth page I reconnect my headphones.

It also happened to me that my Bluetooth speaker was detected as a mono speaker. But my solution was not effective for this problem.

I found another solution. Hopefully.

Recently, when I tried to connect to any output device, the L5 told me it was connected (lights and all), but the sound would still come from the phone.
Reconnecting or removing the device and reconnecting, did not make a difference.

Now, after I have started the music and connected the device (manualy in the bt settings), I swipe down from the top, select the sound settings and switch the output to something else than the headset and back again. Then the sound switches from the L5 to the external device.

Simple :rofl:!


Once I get my phone working on the cell network again I’ll have to try this out. Right now it’s sidelined while support figures out what’s wrong with it.