Bluetooth stuttering

I can not confirm this. I just installed latest updates but still stuttering like hell.

What apps does it do this for or is it across all apps using BT sound?

All apps which I am using :

  • Spot (spotify client)
  • Shortwave (internet radio)
    I will give it another try with Kasts and some other…

Ok, tried the followimg :

  • Kasts : working fine without stuttering. Stream is downloaded first before playing.Probably not a high bitrate audio stream.
  • playing live stream eg friskyradio : working fine with screen on. When screen is locked, it stutters once in a while when headset and phone is in a steady position. When I move the orientation of the phone and/or headset, it starts to stutter very bad again.
  • Spot always stutters very bad. Probably a high bitrate audio stream.
  • Shortwave always stutters. Dont know if this is a high bitrate stream.

The range between the phone and headset was about max 50cm, so that should be no problem.

Maybe there are multiple issues involved in this problem with stuttering :

  • bitrate of audio
  • cpu workload during playback
  • powerdown/powersave modes of the phone
  • orientation/position of phone and/or headset

For now, only Kasts is working fine with bluetooth, the rest of the things I tried are unusable.

I don’t think it makes a lot of difference.
But I will check whether streaming apps (either through a data connection or over wifi) stutter more than apps playing music stored on the phone itself.

Just for the record I used the command-line mpv. It worked decently with L13. Stuttered only at the beginning and when the screen lock kicked in.

Ok so I’m getting some stuttering with Monophony. So it must be the same issue with traffic on the wifi causing issues with the bluetooth I’m thinking…that’s probably why Kasts doesn’t have an issue because it’s downloaded material.

i tried now the different suggestions here in the thread.
my phone did not returned to listen-able state. for week or so it was ok.

pretty unpredictable!
(today i installed latest update)

For Stutering please just wait until Purism is fixing this. Purism already TRACKED this bugs.
So i recommend start first checking or upgrading all firmwares for L5.
Phosh v26 it out!

1 Like

do you have a link to the bug tracker?


has 36 open bluetooth bugs. none for keyword WPAN.

how to find the bug in question?

Well, there is more wrong with the bluetooth than just the stuttering. Or so it appears.
Frequently what happens, is that it seems like a connection is established (indicated by either a light or sound signal), but the sound still emits from the phone instead of the speaker(s), or no sound is heard at all.
Removing and re-connecting the receiver/speaker does not alter this.
Haven’t got a clue what might be happening there. But it seems like a seperate problem entirely.

I have had this happen and I have found that the solution is to go into bluetooth settings and toggle the particular device off and on and then it properly routes the audio. But after the last OS updates it seems to be doing that less often.

I think so too. I tried connecting, disconnecting, removing and re-pairing earlier. Nothing worked. I even tried rebooting the phone. Also didn’t work.

Ok I was going to say that if the toggling method doesn’t work then the only option is a reboot and that usually fixes it for me. But maybe it’s the particular BT devices I’m using as well.

It may be way out of left field but ever since I globally disabled IPv6 on my phone I noticed that it’s running better. Not sure if it could be somewhat related to this problem? Not sure if you can disable it but in general I have noticed the phone running faster if that makes any sense.

When it comes to the L5 there is very little that surprises me. But I have no idea how that might work :slight_smile:

Have you tried adjusting the sound settings under output while your speaker is connected?

Why would that be necessary? When it works well, it works without any adjustments (like a ‘normal’ bt-connection should).

To illustrate: 16 hours ago I gave up trying to get a decent stream going from Spot running on my L5 via bluetooth to the little receiver I have hooked up to my stereo. (It’s a dirt cheap little gadget that nevertheless works consistently well with every bt-source in our house.)
On quite a few occasions it worked well with the L5 no matter the app I streamed the music from, and without any ajustments to any audio setting.
Yesterday the L5 did not connect autimatically to the receiver, and after I made a manual connection it stuttered like mad. And after resetting and re-pairing and reconnecting it stopped playing the music entirely.
Edit: In this case there was no music coming from either the phone or the stereo. At other times the music still plays but emits from the L5 speakers, even though the phone says there is a bt-connection with the receiver or speaker.

Today, with the exact same setup, I still needed to make the connection manualy (in BT-settings), but the stream is flawless. No need whatsoever for playing around with any audio settings - which us how it should be, of course.

Hence my earlier choice of words: it is erratic.

2 Likes

I may have discovered something regarding stuttering. It has been good except when I connect to an access point at work. This particular access point was using mixed mode. When I set it to strictly do 802.1n (it’s an older access point) the stuttering practically vanished. Not sure why mixed WiFi mode might aggravate stuttering, but try it yourself to see if that makes a difference.

I also experience this on the Redpine RS9116. Looks like buying the SparkLAN does not resolve this, which is good to know.

What I do to counter the stutter is the following:

  • Wi-Fi 2.4GHz and Bluetooth use the same frequency, and using both at the same time causes interference. So I disable Wi-Fi or connect to an SSID that only sends over 5GHz. (And: if you have bad Wi-Fi connectivity due to interference, turning off Bluetooth will likely help.)

  • Stay away from other sources of interference, such as microwaves (you don’t know what stutter is until you stand next to a working microwave :smile:).

  • If I use the GUI to control Bluetooth (through Settings > Bluetooth), after connecting, I make sure to exit the Bluetooth settings screen. It looks like this disables Bluetooth scanning which improves the audio quality of whatever I’m listening to.

    Actually, I’ve reverted to using bluetoothctl, because I can’t connect quickly or reliably through the GUI. So now I run this in my terminal:

    until bluetoothctl connect AA:BB:CC:DD:EE:FF; do :; done
    

    This will try to connect the device until it succeeds.

Even so, I experience stutter frequently whenever even a small object or person is between me and my phone. So, whenever I can bear it, I use the headphone jack.

I would recommend the sparclan card tho. stuttering in general was vastly improved by it, not to mention the higher wifi throughput.