Bluetooth support for Librem 5

Does something simple like orientation of the phone make a difference?

Like AM radio?:wink: No, I don’t think so. I haven’t seen a pattern so far.

Kinda. The symptoms being described sound like interference, or maybe a bad antenna connection. May be worth reseating the antenna wires.

Too soon to start fiddling with the innards of my L5 just yet. I still getting used to actually owning one. :slight_smile:
But, if coming firmware upgrades don’t improve things, I might have a go at that.

@dos you are using the AP6275S, what about HSP and HFP support with this one?

("…and now for something completely different") While thinking bluetooth, something that has nagged me for a while got an answer that may interest: if anyone else is bothered by BT coming visible/enabled by default after switching wlan on from HW switch, just edit /etc/bluetooth/main.conf and find the line AutoEnable=true and replace it with: AutoEnable=false. Some other settings there too.

The behavior seems a bit peculiar, as this doesn’t keep BT off at all times. At boot it still seems to automatically switch on (like going to some default settings, forgetting the .conf - not unlike screen zoom level), and if BT was on before you used HW switch to off, it will be back on when HW switch is used again (not what I’d expect). The small positive is, that now, if you have switched BT off (from SW, from top bar), it seems to stay off (unless reboot) when using HW switch.

Anyhoo, a minor improvement to security/privacy by default. (“Now back to your regular programming…”)

Audio works, although without a PulseAudio patch that’s not yet in PureOS it plays in slow motion. Other features don’t work yet, but that’s a matter of software.


I think, in one of the bluetooth threads, I mentioned that my BT was working ‘flawlessly’. I want to retract that. The bloody stuttering is back. Furthermore, the automatic connections to paired devices are no longer happening, connections made do not result in music being streamed over BT (the music still emits from the L5’s speakers), and speakers that connected without a problem before no longer connect now.
What happened?! Is this the result of a software update (I think I saw one recently), or just more of the same misery?
(And please don’t tell me it works better when wifi is off - streaming wifi to bluetooth is something I do on a daily basis, so it is a make-or-break feature for me (one my eight year old Windows Phone still does wonderfully well, btw).)

I have a local library of music, and even when I turn off WiFi I have all the same issues.

It’s a bit erractic at best. Sometimes it works, sometimes it doesn’t. All this advice on switching on or off this or that or the wifi sounds a bit like superstitious learning, really.

1 Like

happened to me due to the pulseaudio updates recently you have to forget and remove all your bluetooth devices and re-pair them.

The stuttering indeed happens still with Spaklan, but for me only with WiFi on and not as pronounced as it was only a week or so ago (kernel, base phone setting updates i think)

I seem to remember that all my pairings disappeared after the card replacement and I had to repair them anyways.

Safe to say that bluetooth connects every time, but only plays sound properly approx 10% of the time if that. Most of the time no audio, still plays through the speaker…still work to do on this.

@dos you said you had this working on yours flawlessly but have you run into the audio path not coming through the bluetooth and just playing on the handset speaker? Or have we not seen those improvements yet since the last update?

If it helps, my pixel does that from time to time. Seems like either the order I turn Bluetooth and the device on matters or Bluetooth needs some time to turn on fully first.

I hear you, but I doubt it fails to deliver the audio over the bluetooth path that often. This morning I was doing fine with it then now this afternoon no matter what I do I cannot get the audio path to play over a supposedly connected set of bluetooth earbuds. There seems to be no rhyme or reason to it…albeit bluetooth is generally quite a fussy protocol.

I think I figured something out. I think it’s when the phone is in convergence mode. When it’s plugged into my Nexdock and I haven’t connected my earbuds, no dice, they connect but no sound coming to the earbuds, I just now disconnected the L5 from the dock and boom connected with audio…problem solved.

Perhaps it’s playing sound through nexdock’s audio output? (I think it has one)

No that has never worked…nor does it show up in the audio section in settings as a destination. I know the dock has speakers but the sound never comes through them. It sure would be nice if it did tho…

EDIT: Just checked with my Samsung S22 connected to the dock and it too does not play sound through it, it seems it would through the HDMI port as the DeX settings in the “change audio destination” show an image of an HDMI connector which I do not have connected so perhaps that’s a limitation of the dock or the implementation of the standard? No idea. Doesn’t the display port support audio as well?

It’s very hard to discern any pattern. Maybe the Pulseaudio updates were to blame for the lost pairings - I can’t tell, and even if it was, that would be a different issue than the stuttering problem. I am sure I didn’t do any convergence stuff, so that’s definitely not it for me.
I am guessing the stuttering problem will be solved somehow.
Hopefully the same goes for the backward compatibility with my (14 year old) car. Being able to do handsfree calls is quite a biggy. I will probably buy another car somewhere in the future, but untill then I would like to be able to make safe calls, without having to resort to awkward solutions like a headset.

My car is less than two years old and the SparkLAN card has trouble connecting to it. There are similar issues that @raenrfm has reported.

The only thing left to do is be patient and wait for a software fix.