Boot from USB is not showing

Just got my 14. Trying to install elementaIry os from usb. used unetbootin as well as dd methods to flash usb drive.

when i restart, I press the esc key. It says:

SeaBios(version rel-1.14.0-1gab81922)
Select boot device:

1. ANCI 1/2: Sammsung ssd 060 evo m.2 etc etc
2. Payload [coreinfo]

t. TPM Configuration

i have tried both usb slots, 2 usb drives, reformatted the drives, again, used unetbootin as described here:

I have used dd as described in some other posts here. still never shows up.

The USB drive shows up fine once PureOS is booted.

any help would be greatly appreciated!

also for anyone looking at getting the 14, the tiny right hand shift key is SO ANNOYING.

the USB not showing in the boot menu means it failed to initialize when SeaBIOS enumerated the boot devices. Try using another port or another USB stick. Not all USBs are spec compliant and the handshake delays are pretty tight/close to specs

Found the solution.

Using unetbootin is apparently not good. When I flashed it with balenaEtcher it worked like a charm.