Librem 14: First Impressions, Keyboard, Audio, and USB Boot


  • Beautiful laptop, very fast (under Manjaro), no regrets.
  • Using PureBoot bundle w/ Coreboot+Heads, many OS installer USB’s including the PureOS installer, don’t seem to work (Qubes did). After switching to Coreboot w/out Heads, USB boots work fine.
  • Aux port automatic detection not working due to a codec issue, external microphone not working (as mentioned in the footnotes here:
  • My keyboard seems to be possibly defective, “a” key not working reliably, waiting on Purism support to see about keyboard replacement.

Hello world!

Wanted to share my experience thus far (about a week in, was delivered May 17th, 2021) with the Librem 14, and potentially get some feedback/suggestions for a few issues I’ve been running into.

First off, the laptop is beautiful, love the sleek, simple, unbranded design:

Having purchased the PureBoot Bundle, the laptop came with PureBoot/Coreboot+Heads and a Librem Key. Having this process detect tampering of the firmware and unencrypted boot volume resources is really neat, and a feature I really value, unfortunately, I’ve decided to go without it for now, you’ll see why shortly.

The laptop boots up with PureOS by default, walked through the installer, and into the fresh UI, wow it’s fast. This is where I noticed my first issue. The keyboard is wonky. I’ve emailed Purism support about this, and hopefully they have a workable fix or can send out a replacement keyboard. I haven’t seen anyone else complaining about this, so I’m hoping it’s not systemic.

Next up, getting audio setup so I can listen to some tunes while I set everything else up. Plugging in my headset into the Aux port, second issue, I noticed the audio was still playing from the laptop speakers. I remember reading something about this… Yes @nicole.faerber mentioned there was an on-going Codec issue with this ( Hopefully this gets resolved soon.

[1] Headset microphone and headset plug-in detection is not yet working. The wiring is there but there is still work that needs to be done on the software side with the codec.

Okay, well my headset supports Bluetooth. But PureOS doesn’t seem to, I did some reading and it sounds like there is still work being done an open-driver that supports BT. Still no external audio working out the box. So I decide I’ll try a differen’t OS, Qubes looks really cool.

Install Qubes, really neat OS, love what they’ve done with it, and the documentation is quite good. Ran into a lot of issues with Qubes out of the gate, and I had to really massage it to get into a state that I was happy with, took a while, but at the time I was willing to spend the extra effort to take advantage of the app/domain separation that it provides.

Bluetooth worked out of the gate with Qubes, and even the Aux port I was able to manually enable through the UI, something I couldn’t see an option for in PureOS – however, I was never able to get the microphone on my headset to work through the Aux port, possibly also related to the Codec issue? Third issue, trying to use Bluetooth for audio input (microphone) from my headset. If I manually set the input to my BT headset, the audio quality becomes extremely poor. This isn’t an issue with the Librem 14, seems to be headset<->kernel related and I found some discussion board posts showing active kernel dev. to resolve this. Hopefully it’ll be incorporated into a kernel update soon. So even with Qubes, I’m still stuck with using the built-in laptop microphone.

After some time with Qubes, realizing this was probably not going to be the “just works” OS going forward, and the inevitable performance hit that comes with heavy virtualization, and my limited amount of RAM (16GB). I decided to move on to something else that would be less maintenance-heavy in the future.

In the past I’ve been a heavy Arch Linux + i3 user, and while i3 is nice, my brief experience with the PureOS UI (Gnome) was really nice – and on a fast laptop, why not. Installing Manjaro w/ Gnome, fourth issue, using Etcher I burned the Manjaro ISO to a USB stick. Tried booting from it the same way I did with Qubes, by choosing the USB boot option in the PureBoot menu. No dice. Okay… tried PureOS installer on a USB, also no dice… Sigh. Both get stuck at the following screen:

Searching for some answers, I came across this post: Boot from USB is not showing

When I try pressing “esc” at boot, nothing happens… doing some additional searching, the menu that @Sachio222 was seeing seemed to possibly be the Coreboot firmware without Heads. So I decided to revert my firmware to the non-Heads Coreboot using these instructions: to see if I’d have better luck booting USB installers. Success! Installers would boot, and I was able to install Manjaro w/ Gnome (note I believe you need to manually partition, as Manjaro seems to by default not setup partitions correctly for booting under Coreboot). Unfortunately, this means I can’t use my Purism Key… Maybe I’ll try installing Heads again at a later point now that the OS is installed.

The issues I had with Coreboot+Heads may simply be ignorance, there may be some nuance to how it works with USB booting as compared to Coreboot non-heads, and I haven’t read through the documentation to know if this is the case:


Outstanding issues (Librem 14-specific):

  • Keyboard “a” key issue, waiting on Purism support to respond.
  • Aux port “codec” issue, preventing use of wired audio without manually switching audio outputs, also preventing external microphone?:

While I ran into a number of issues trying to get it setup the way I wanted, and some of those issues may be due to my own ignorance, or due to a lack of documentation, or outright bugs. The laptop itself is beautiful, performance is amazing, and with Manjaro+Gnome installed on it I’m excited to start using as my daily driver! No regrets w/ the purchase or the long wait for delivery.

Great work Purism team!


Did you have to do something manually to get audio coming out of the aux port? Qubes is always showing the headphones as unplugged for me.

@Purism, is there a public issue tracking the codec issue for the headset? Should audio out for headphones work?

@wanderingshort It’s been a few weeks now since I had Qubes installed and unfortunately my brain didn’t save any details about my Aux port experience to my long-term memory, all I remember now is that I did have the audio-out working via the Aux port in Qubes – but no dice for audio-input.

To provide some additional updates:

Keyboard Issues

So the issues I was having with the “a” key persisted and never got better – I did some further investigating and it looks like these keys when you press them down lightly, what happens is at a certain amount of pressure they “pop” into the pressed position, for all the keys this registers the key press except for the “a” key, so likely some very slight defect with the spring mechanism for that key.

When I opened up the laptop and took a look at how you’d remove the keyboard it looks like it might not be possible :grimacing: … not sure about that design decision given it’s one of the most common parts of a laptop to need replacing/maintenance.

I reached out to Purism support and they were very supportive and ended up sending me a replacement laptop, and had me return the original. The import taxes/duties is a bit annoying to deal with as I have to follow up directly with my government to get reimbursed for the taxes/duties paid again on the replacement laptop, but it is what it is and Purism was kind enough to do the research for me on how to do this. The new laptop’s “a” key is working great.

Intel Sticker

You’ll notice that the original photos in the thread post there’s no “Intel” sticker, the new laptop has one applied (I might remove it though, I like the clean design, don’t tell Intel).