Booting from rescue partition

I recently received my Librem 13 v2 preinstalled with PureOS. During the installation, I aborted it early, which resulted in that now when I try to boot it hangs at “Booting from hard disk”, since no OS is installed.

While installing another operating system I noticed a partition labelled “rescue”. Is it possible to boot from it somehow, and install PureOS from there?

I don’t know, and even if it is possible, don’t do that—you will lose time and nerves. Since this was a first install, you don’t have any data on it, so simply download latest PureOS image, burn it to your USB drive, boot from it and follow install instructions.

Thanks for the advice. I tried that yesterday, and I ran into the same issue as described in this thread Problem booting PureOS, with unavailable kernel modules.

Although I only tried with the iso available on the pureos website, not the snapshots. Right now I’m trying to install Qubes in the meantime.

1 Like

Choose the latest snapshot and try:

1 Like

When I tried with the latest snapshot 2017-07-24, I boot the installer and get to the step “Load installer components from CD” and I get the error message

"There was a problem reading data from the CD-rom. Please make sure that it is in the drive. If retrying does not work, you should check the integrity of your CD-ROM.

Failed to copy file from CD-ROM. Retry?"

And when I choose “Yes” it shows the same error message.

I verified the checksum of the iso, and created the bootable USB-stick with dd.

EDIT: I also tried with the 2017-06-12 snapshot and I was able to install pureos. Although the touchpad doesnt respond to touch, even though it is turned on in the “Mouse” settings and dmesg show “ETPS/2 Elantech Touchpad as /devices/platform/i8042/serio1/input/input6”.

Although if I recall correctly I also had this problem with the touchpad when I booted to initial setup right after I unboxed the laptop.

EDIT 2: After apt update && apt dist-upgrade the touchpad works fine with the 2017-06-12 snapshot.

Strange, I haven’t experienced this. I’ll do a more thorough testing.

1 Like