BYD touchpad - tap to click

Under Settings > Touchpad I have Tap to click enabled but it does not seem to be working.

What else should I do to get it to work?

The touchpad currently is not presented to the OS as a touchpad, but rather as a mouse. When you do a two-finger scroll, it’s signaled as if you rolled the scroll wheel. A proper touchpad driver is (or was) in the works, the last mention of it I can find is here:

We are working on mainlining our latest work to Linux, so we hope it should be present out-of-the-box ASAP.

Seriously how is it possible to release a laptop announced to be able to run Linux freely and 6 month after the release such important part as the touchpad is still not working on main distro?

The driver is now presented in Linux kernel 4.6 but two-finger scroll is disabled as it wasn’t working as expected (we will revisit driver and touchpad hardware in a week or so).

Got my Librem15 yesterday! Tap to click is working for me using the latest PureOS 2.0 but I’m trying to find a way to disable the touchpad when an external mouse is plugged in.
Tried dconf-editor but can’t see any options. Thought about just commenting out the mouse in /proc/bus/input/devices but I don’t know if that would have unforeseen consequences…
Any other ideas for modifying the touchpad behaviour?

1 Like

hello, how to create bootable usb for pure os from win10. THX

@Kris Fn + F1 disables the touchpad, that’s what I do when I use a mouse

1 Like

lol an absurdly simple answer, thanks Gert!

1 Like

The touchpad driver is still very “basic” and… annoying on PureOS 2.1. One year after shipping…

How can I disable tap to click ? (on Librem 13)
and only keeping physical clic to click (click to click) please

NicolasWeb, is there an option for disabling tap-to-click in Gnome interface settings? If not, edit your “/etc/X11/xorg.conf.d/60-libinput.conf” file and add this just under the </>Identifier “libinput touchpad catchall” line:

Option "Tapping" "off"

Save and restart interface.

As mentioned at the 2sd comment of this thread, it seems that the Touch Pad is set as an physical mouse. So, no, in Settings/Mouse&Touchpad, this option is hidden.

BTW, the file and the directory you mention do not exist. So I can’t add a line after something. What’s the solution please ?

I found the file /usr/share/X11/xorg.conf.d/60-libinput.conf but that do not disable the tap behavior.

sudo mkdir -p /etc/X11/xorg.conf.d/
sudo cp -iv /usr/share/X11/xorg.conf.d/60-libinput.conf /etc/X11/xorg.conf.d/
sudo gedit /etc/X11/xorg.conf.d/60-libinput.conf

Make sure to have libinput xorg driver installed, add

Option “Tapping” “on”

…under the “libinput touchpad catchall”, save and restart session. There should be option now to turn off tapping in GNOME settings. Report back if it worked. :slight_smile:

It works!
Try starting with options seen here and make adjustments as needed:

Section "InputClass"
    Identifier "libinput touchpad catchall"
    Driver "libinput"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
    Option "Tapping" "True"
    Option "DisableWhileTyping" "False"
    Option "NaturalScrolling" "False"
    Option "HorizontalScrolling" "True"
    Option "AccelProfile" "adaptive"
    Option "AccelSpeed" "0.02"
    Option "ClickMethod" "clickfinger"
    Option "MiddleEmulation" "True"
    Option "ScrollMethod" "edge"
    Option "SendEventsMode" "disabled-on-external-mouse"