Byzantium configuration

Just flashed my phone with Byzantium. All went well. I need some help to configure the following:

  1. Keyboard does not switch to anything else than “terminal” when you are in terminal. However, I often need to write in Greek in terminal. how to unlock this? It was working fine with Amber.

  2. How to change the fonts used in the interface? I do have fonts installed in ~/.fonts/ but how do I choose them?

  3. I had some shortcuts to speed dial some numbers on my first screen. These where created by placing a .desktop file in .local/share/applications/
    Now they only appear if I scroll down and click on “show all apps”. Somehow one should be able to tell the system that that app is OK to by default display in the list of the adaptive apps.

There isn’t a Greek terminal layout as you can see here youǘe got two options.

  1. Create a new Greek terminal layout based on the French one, replace the content by the greek characters and place the file in /home/purism/.local/share/squeekboard/keyboards/terminal/gr.yaml you can use as well as reference
  2. copy the normal Greek keyboard to the terminal folder but you won´t be able to use the terminal specific commands

Install from terminal an app named gnome-tweaks, from it you will be able to change the fonts, theme, icons.

In the desktop file that you created add in the last line:


And you’ll be able to see them


I think it might be worth filing this as an issue in the tracker. Right now the Greek terminal is missing, so the fallback is to generic terminal. It could be possible to switch to plain Greek, but that’s a different fallback direction, and I think this needs to get input from the designers to be actually useable.


This will install a lot of stuff:

The following NEW packages will be installed:
  bolt chrome-gnome-shell dconf-cli gdm3 gir1.2-accountsservice-1.0 gir1.2-atspi-2.0
  gir1.2-gck-1 gir1.2-gcr-3 gir1.2-gdm-1.0 gir1.2-gnomebluetooth-1.0 gir1.2-graphene-1.0
  gir1.2-handy-0.0 gir1.2-ibus-1.0 gir1.2-mutter-7 gir1.2-nm-1.0 gir1.2-nma-1.0
  gir1.2-polkit-1.0 gir1.2-rsvg-2.0 gir1.2-upowerglib-1.0 gnome-menus gnome-shell
  gnome-shell-extension-prefs gnome-tweaks gstreamer1.0-pipewire ibus ibus-data ibus-gtk
  ibus-gtk3 im-config libgail-common libgail18 libgtk2.0-0 libgtk2.0-bin
  libgtk2.0-common libmutter-7-0 libpciaccess0 libstartup-notification0 libxcb-res0
  libxcb-xv0 python3-ibus-1.0 switcheroo-control xserver-xephyr xserver-xorg
  xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-libinput
  xserver-xorg-input-wacom xserver-xorg-legacy xserver-xorg-video-all
  xserver-xorg-video-amdgpu xserver-xorg-video-ati xserver-xorg-video-fbdev
  xserver-xorg-video-nouveau xserver-xorg-video-radeon xserver-xorg-video-vesa
0 upgraded, 55 newly installed, 0 to remove and 0 not upgraded.
Need to get 26.7 MB of archives.
After this operation, 123 MB of additional disk space will be used.

gnome-tweaks does not include this configuration. I just installed it and the only options it gives are:

  1. Animations
  2. Suspend when laptop lid is closed
  3. Over-Amplification

Nothing else. And even these are not selectable. In any case this is not a solution. Since it installed a lot of packages I will now remove it.

Something is strange. I launched it from the terminal and it says:
WARNING : Shell not installed or running
WARNING : Shell not running
NoneType: None
WARNING : Error detecting shell
Traceback (most recent call last):
File "/usr/lib/python3/dist-packages/gtweak/tweaks/tweak_group_shell_extensio_
raise Exception(“Shell not running or DBus service not available”)
Exception: Shell not running or DBus service not available

OK, but I will also create a Greek file for the terminal. But yes a better fallback mechanism would be useful.

@uzanto 2 out of your 3 solutions worked flawlessly. Thanks. It remains to find a way to fix the fonts issue as gnome-tweaks does not work. (by the way, after installation of gnome-tweaks it installed gdm3, and actually run it! I saw gdm starting before it was overlayed by the regular lock screen) I had to remove it and all it’s dependencies.

You just see that options because it doesn’t fit in the screen if you scale the screen you’ll see the app properly.
The other way is to use gsettings to change them.if you want to see you actual fonts use:

gsettings get org.gnome.desktop.interface monospace-font-name

gsettings get org.gnome.desktop.interface document-font-name

gsettings get org.gnome.desktop.interface font-name

gsettings get org.gnome.desktop.wm.preferences titlebar-font

And to replace them use for each of them, using the font name that you would like to change (mind that in this case is set instead of get).

gsettings set org.gnome.desktop.wm.preferences titlebar-font ‘Ubuntu Bold 12’

Oh yes, I forgot about this, when I installed it, the phone took longer to start as it was running gdm3 at startup but I just removed it and it was fine, to be truth I’m just using the phone to play with it but I should consider that people is using it as their daily use one.

1 Like

Please take a look if sudo apt-get --no-install-recommends install gnome-tweaks helps not to add gdm3.

Yes, this worked! Great thanks.

Another issue is about hotspot. It is very nicely added to Byzantium. However something is wrong when the phone gets its connection through Ethernet.

When the phone connects through Mobile data, enabling the hotspot everything works.

But when it connects through Ethernet, and then Hotspot is enabled, other devices connect to the phone (so hotspot works) but the phone itself looses its internet connection it had through Ethernet. Of course the clients that connected to the hotspot do net get internet. Maybe it is a routing problem? Is this easy to solve somehow with some commandline? In any case is it a bug to be hunted?

1 Like

Can you do:

ip route

and show what comes out?

[purism@pureos Documents]$ ip route
default via dev usb0 proto dhcp metric 100 dev usb0 proto kernel scope link src metric 100 dev wlan0 proto kernel scope link src metric 600
[purism@pureos Documents]$

The Network Manager on the laptop still shows that L5 is connected to ethernet and the icon on L5 bar that apperas when Network is not availabe is NOT present. Still internet does not work on L5 and hotspot clients.

Ah, yes. I ran into it:

It seems that you have connection sharing configured on your laptop and the Librem 5 is getting ti’s internet connection through that share via Ethernet over USB and then you have the WiFi hotspot feature on the Librem 5 enabled also?

NetworkManger on both the laptop and the Librem 5 are using the same ( IP address/subnet causing confusion.

Just change one of the shares to use a different address range, I don’t know if the hotspot connection is created dynamically from scratch each time? It’s prbably easiest to change the IP range on the laptop…

nmcli con mod <connection_name> ipv4.addresses
1 Like

Thanks, it worked flawlessly! A dream to come true phone.

By the way, L5 produces a QR code for the hotspot. If you scan with an android you get the name, encryption and password. Is there an app/way for android that scanning this will automatically connect to the hotspot? Or this is just to easily copy the password?

About sharing. SSH works fine.

When I enable sharing of the Public folder, I am supposed to access it using dav://pureos.local
However, on the laptop I get
Could not display “dav://pureos.local/”.
Error: HTTP Error: Could not connect: Connection refused
Am I missing something on the desktop? I tested that on MATE desktop with Caja file manager with davfs2 and mate-user-share installed.

Same thing with nautilus. Connection refused.

And how do you access Music, Videos etc with Media sharing?

No. The purpose is, as you surmise, for automatic connection to the hotspot.

For Android, no idea, but for iPhone this works out-of-the-box. That is, scan the QR code on an iPhone and it prompts for confirmation to connect to the hotspot.

I only have a passing familiarity with Gnome’s basic file sharing so there may be other issues, however, the link/url that is offered up is missing a key ingredient, namely the port it’s listening on which is allocated dynamically.

With file sharing enabled on the phone, then from the phone’s terminal…

ps -ef | grep "user-share.*Listen" | awk '{print $13}' | head -n 1

…that should give you a 5 or 6 digit number which is the listening port, if you then tack that on to the end of the url dav://pureos.local:<port> it should now connect. For example, if the above terminal command returned 39427 the url would be dav://pureos.local:39427.

If the above terminal command didn’t return anything try ps -ef | grep gnome-user-share and dig through the output, you are looking for the number after “Listen”.
With nautilus, it should show up within the network section of “Other Locations” automatically without the need for the port number.

For the media share, once enabled it should be immediately visible to any applications/devices on the network that support DLNA, which applications/devices are you using to try to access the media shares?

For file sharing I would recommend looking at sshfs, it runs over SSH and is stable and robust. It is also fairly trivial to set it up in such a way that the phone gets automounted when it appears to a machine on a connection share, giving a similar level of convenience to simply plugging in a USB drive.