Cannot connect to network

Just letting you know I’m not ignoring you. I just have’t had time of late to try your ideas. I will - promise :slight_smile:~s~

1 Like

sudo is formed by joining together “s”+“u”+“do”. in other words

  1. s (stands for super)
  2. u (stands for user)
  3. do (stands for do or it refers to an action - a verb)
    it’s basically saying something like this :
    “i’m the highest ranking user here and you will do EVERYTHING i tell you to after i give you my password”
    so you
    or you
    sudo (mostly)
    it’s not a big mistery. you just need to get with this autistic way of thinking :sweat_smile:

Any Linux distro will be better for the mainstream when you don’t have to know what sudo is. However in this case @sharon wrote “had no idea”, not “have no idea”.

But then you get companies trying to trademark a “look and feel” etc., which forces other companies to be a bit different, particularly those who don’t have millions of dollars to spare for multi-year lawsuits.

The link only shows what is in some 30+ packages. It’s just a non-linking list. A search for " firmware-realtek (20190114-2)" that I got from your “sudo-” line (above).

I get 7 results with weird names bedside them. The only one coming close is "buster (stable) (kernel): Binary firmware for Realtek wired/wifi/BT adapters [non-free] 20190114-2: all Would this be the one? It’s link is Buster Stable. The list with the Buster link links back to the list - getting dizzy now!

SORRY!!! Just discovered that it’s a merry-go-round.** The list link is a list. The Buster link goes to the list. More circles.

The idea of using Ubuntu first was already tried, and Mint as well. Ubuntu wi-fi worked, Mint just draws a black screen once desktop is loaded.


1 Like

Yes, Buster Stable link (dpkg -i firmware-realtek_20190114-2_all.deb) should work under PureOS umbrella, but no promise it will work out-of-the-box. Please don’t forget that apt update and apt upgrade (if needed) needs to be executed before such installation.

First, I’ll have to translate what a “iw” is and I need a few days to find out what “hostapd” needs because “There are three implementations: Jouni Malinen’s hostapd , OpenBSD’s hostapd and Devicescape’s hostapd

Could such a thing become more confusing? YES! Because each of those has a weeks worth of classes to take to understand what it is, which is the right one, how to get past the explanations, and find it, then install it. Is Linux/PureOS designed to keep out us riff-raft that were not born with a Linux manual in our heads? They don’t make it easy. Must be a reason.


I did “forget” because I wasn’t told. OK, order then is IW (still looking up that H–k that is!) then each of the " hostapd" (trial an error?) then the “Buster Stable link”?

Wish I had know about the IW and hostapd BEFORE I followed the instructions (twice) for Buster.

Maybe. I should just wipe the drive, reinstall PureOS and then do the IW (is that a i or a L (lowercase)?), hostapd and Buster in the correct order? Is there anything else I should have done pre-Buster?

It is explained within above link:
root@localhost:~# apt-get install iw (direct link) and PureOS one is here,
root@localhost:~# apt-get install hostapd (direct link), yet for this you need to change approach because of few dependencies. Perhaps under PureOS you already tried to use:
sudo apt install iw
sudo apt install hostapd EDIT: NOT to be used with PureOS!

Or usage of only dpkg -i firmware-realtek* was successful?

No, you already noted that:

and therefore clear that you need to follow very same setup under PureOS, but with non-free Debian Buster package(s).

I know you are very busy and are not expected to remember everyone and their ‘thing’, but Ubuntu as previously explained, is on another laptop and I did say, MINT is ON this ONE as dual boot option.

PureOS WiFi is still not working. And I did manage to track down what ?w is, and did that as well as hostapd and then the realtek install again and still get those errors:

cryptsetup: WARNING: The initramfs image may not contain cryptsetup binaries
nor crypto modules. If that’s on purpose, you may want to uninstall the
‘cryptsetup-initramfs’ package in order to disable the cryptsetup initramfs
integration and avoid this warning.

BUT, cable works!!!
I do not see how installing Ubuntu on here, then deleting it and re-installing Pure will leave behind the correct drivers so Pure can use them. With it being MINT, not Ubuntu on here as dual-boot, Mint booted, but then screen goes black and Mint as only on because someone suggested it. So MINT is just baggage right now.

WHAT EVER! I’m wasting your time, server space, and bandwidth and my ulcers are having babies. And because today is my day off and I thought I’d ‘tinker’ again, at least I got cable working and can use the 'net again and start getting to know PureOS BEFORE blowing $2k± on a laptop that might work for me. Remember/update/reminder that I wanted try out PureOS that comes on the Librem 15 to see if at least the 15, I, and OS are compatible.

I’m sure L-15 will have a very nice, and buggy-free Wi-fi. Now I can at least play with PureOS cabled again.

FYI: I intend to remove MINT and just put PureOS on here (again), and use it to get use to PureOS until I save enough for the Librem 15. Almost there.


Perfect, sounds good! You did it (hit it with needed Ethernet driver)! Perhaps I’ll (or someone else) be back to you related to Wi-Fi card (that you might want to replace), but not now.

No, nothing would be left behind, as new OS installation is just like a new week, new start.

As you want (insist) to have working hardware on your TOSH laptop with PureOS that includes non-free firmware you need to read carefully this chapter (second paragraph) about Debian’s /firmware folder. That’s why I told you to install Debian (link above to amd64-DVD-1.iso, one option would be to replace MINT and compare two /firmware folders, one with all HW working Debian automated installation and the other with only partially working HW after PureOS installation).

Besides, I thought you were already asked to post here following output (print of some errors in red / missing .bin files) from PureOS:

sudo dmesg (like = firmware: failed to load) and

sudo lspci | grep -i wireless,

yet might not choose above explained approach (but still lessons to be understood/learned) to solve this issue with non-PureOS HW and do an install with optional step-by-step method (includes needed non-free packages).

As you are having now working Ethernet connection (Internet from within PureOS) let us go back to another experimental work(around) by using apt or aptitude package manager:

First you need to edit (as sudo/root) /etc/apt/sources.list and add following line(s), first one isn’t optional:

deb stable non-free
deb buster/updates non-free (optionally)


sudo apt update
sudo apt upgrade

Now you might download debian-archive-keyring (optional, not necessarily).

sudo dpkg -i debian-archive-keyring_2019.1_all.deb

Finally, execute following:

sudo apt update && sudo apt upgrade
sudo apt install firmware-linux-nonfree
sudo apt reinstall firmware-realtek
sudo update-initramfs -k all -u

Afterwards you might be able to:
sudo apt install firmware-whatever-needed in order to avoid W: Possible missing firmware error when running:

sudo update-initramfs -u

Also (still helps somewhat), very similar not connect Wi-Fi issue that wasn’t resolved:, but you might persist on trying to resolve yours.

And, I admit that your late in the night questions were for myself pretty much out of the blue.

P.S. By the way (sorry), hostapd is absent in PureOS repository and therefore leave it aside, please. And, if not used at all (from your side): sudo apt purge cryptsetup-initramfs (but it might be linked to some other packages, who knows :roll_eyes:).

from this i assume that you have a very specific reason why you need a laptop. if not you may very well discover that the Librem Mini does it’s job well enough at 700 dollahs. you could grab an iNUC for a fraction of that cost if you’re to mess with non-free-firmware …

Hi @reC,

Specific use depends on COVID-19(84) and whether or not, and when, countries will open their borders, businesses return to their offices, the world-wide economic machine is churning again, and I don’t lose everything by then. I’ve lost friends, lovers, and of course virginity, but nothing compared to what this maddemic has stolen. :worried:

There is no sense increasing payables right now until receivables start a healthy receiving again.

1 Like

Here is my output (as already recomended in this thread):
sudo update-initramfs -u -k all
update-initramfs: Generating /boot/initrd.img-5.9.0-5-amd64
update-initramfs: Generating /boot/initrd.img-5.9.0-4-amd64
W: Possible missing firmware /lib/firmware/ …

I mean under (perhaps) /lib/firmware/rtlwifi/ in accordance with this post (last one) and this link (if corresponding to your WiFi card).

To be sure which WiFi card is built-in, from this orientation link:, you might execute:
sudo lspci -nn | grep Network

As well you might edit/add this repo (with or without main) to your sources.list as described here:

by adjusting/including above post up to this Debian link here with non-free.

Thanks @ Quarnero

Your help is greatly appreciated, and does not go unnoticed by me. I have not ignored your last response. I have tinkered with other laptops, and since I almost always use cable (faster, private) I have been involved in 3 major projects - all overseas. Travel is out as you know so Wi-Fi fell to the wayside.

I’ve still been adding to the ltop budget a bit here and there. Just had to buy a new one and was groaning that I had no time allotted to wait for Librem 15.

I have PureOS working now on a old ltop.

Tomorrow I will be working through your suggestion. First, I have to learn just what you’re talking about and how I do it. At least I am able to make mistakes and start over.

Your help hasn’t been wasted,


1 Like

I think (by recognizing my partial fault, organizational one), it is much more about back and fourth logic on how to achieve your goal by yourself and not that I’m able (was able) to explain something consequently or didactically (especially not in language that is not my native one).

Let me try again, please start with this two (three) commands (within PureOS Terminal):
$ sudo update-initramfs -u -k all
update-initramfs: Generating /boot/initrd.img-5.9.0-5-amd64
W: Possible missing firmware /lib/firmware/yourWi-Fi_card/?????????.bin

$ sudo lspci -nn | grep Network and/or $ sudo lspci -vnn | grep -i net

As said, doesn’t matter which command is first or second (at this point), but that (if) your PureOS (linux-image) recognizes your Wi-Fi hardware is important (to ensure) to know this exact hardware fact.

For example you should start (as well) with:
$ cd /lib/firmware/
$ ls -la

and see (just look) which files are already there: showing that your Ethernet, files needed (firmware data) are already installed (as they are).

And, please prepare your commands in your text editor (gedit for example, with Oblivion color scheme :new_moon_with_face:) Wi-Fi_ToDo.txt file before copying them to your Terminal! Start by taking them down from this Forum (thread+provided links, etc.), only copy needed commands, explanations, just necessary things to stay focused to your Wi-Fi.txt file.

P.S. Tomorrow I decided (actually need) to reinstall other Linux distribution on one of my old ltops too, although last installation was just about two weeks ago, as just wasn’t happy how I made (sized) my partitions … trying to say: “I wasn’t focused, all the way, last time with my own ltop”.

EDIT: Using $ sudo dmesg | grep wlan0 or $ sudo dmesg | grep wlan1 might help to identify your WiFi card to.

I have been trying to install both, Pure and Win 10 together but on two separate HDDs on a HP Z-400 workstation station with 2 new HDDs. I did spend a lot of time searching but everyone is plagiarizing the other guy that assumes everyone has ONE HDD. AskUbuntu has more ‘this was already answered’ than they have help. I guess they think a answer for 5 years ago is good for today. So I black listed them from my ever landing there again, even.

So I’m going to ask here - my last resort (because I talk too much here :slight_smile: ) it will be my next post.

I have a feeling you are successful with your re-sizing partitions and making it work. Once I have to two working together. Next Wednesday.I am going back to that ltop and try your suggestions which I copied out and printed in case I blow up my modem/computers/house/city/planet.

Putting two OSes on two hard drives is the same process as putting them both on one. The only difference (in my experience, and I don’t think this is a set-in-stone rule, but it’s what I do) is where to put the bootloader for Linux.

So: first, go into your BIOS settings and ensure it boots in UEFI mode (again, I don’t think this is strictly necessary, but it works for me). Once done, install windows before installing Linux. After it’s installed, boot into it and ensure that it works.

When you’re satisifed windows works, go ahead and install your Linux distro on the second hard drive. In the Linux installer, choose to put the bootloader on the drive windows lives on (as that’s where the windows bootloader is).

Here is a picture with the option I’m speaking of circled.

Then proceed as normal. Reboot and ensure that your Linux distro boots as it should.

If you don’t see grub (screen with some text giving you boot options before actually booting your Linux distro) or if you don’t see windows in the list of boot options, open a terminal in Linux and run sudo update-grub. It should show up after that, and you should see something about “Windows Bootloader” in its output.

if you have any questions or need more detail, lemme know.

I’ll try (start over) remotely with PureOS and Tosh A660–0QE (not for real) once more, as simple as it gets (this time).

Open Tilix or GNOME Terminal and enter (just for your orientation if Realtek® RTL8191SE indeed in question here):
sudo lspci -vnn | grep -i net

Open Files here (/etc/apt):
01_2021-01-24 21-50-08
Type Ctrl+L and write up front /etc/apt (above line) admin:// to get admin:///etc/apt, hit Enter (+ your sudo passwd), to get this:
02_2021-01-24 22-04-16
Open sources.list file with other application (enter passwd):
03_2021-01-24 22-14-09
Add this new line, save sources.list and close it:
deb buster non-free

Connect Ethernet cable and back to Terminal to enter following commands:
sudo update
sudo apt install firmware-realtek
sudo apt install firmware-misc-nonfree
sudo reboot

After reboot open Settings / Power if you see:
04_2021-01-24 22-41-15
If successful select your Network and enter required Wi-Fi passwd:
05_2021-01-24 22-44-35