Cannot connect to network

Re-re-reinstalled PureOS again. Each attempt to log in to network results in same thing - “Connection failed > Activation of network connection failed”

If I use the connect icon (lightning bolt) at top right of ltop, a list of networks is presented. When I select mine, I don’t even get asked for the password… it just spins for 45 seconds then err’s our to connection failed.

When I use the gear beside My network, and tell it to “Forget Connection”, and try, I am asked for the password, but even though I made password very simple for this process, it still gets the same error.
The password IS correct.
I am connecting to the right network (2.4g).

This same issue occurred during install. I simply skipped that part after so many tries.

I think the PureOS boots from the USB stick.



sudo lspci | grep -i wireless

Please post output here … but I’m out for now … just about to shutdown my computer.

Are you experiencing these issues on a Purism Librem computer or some other computer?

1 Like

OK, after ‘sudo’, how do I post the results if there is no Internet connection?

No matter, when I type it, and hit enter, the pureos@pureos:~$ prompt reappears, and I checked the command line spelling. Assuming Tilix is the program to use to enter the sudo command.

UPDATE: After opening every available access except MoBo, I found a manual for the Tosh A660–0QE that says “LAN, Realtek wireless 801.11 bgn,…” (Ewww!)

There is no access to the WiFi like other ltops. No idea where this is inside ltop.

Toshiba Sat A660

I know already that Pure is built for Librem, and I have also read the horrendous number of similar, but different issues related to not finding the W-Fi card. My issue is ““Connection failed > Activation of network connection failed””
No connection includes trying with a cable plugged in direct to to router. Router doesn’t see Wi-Fi or cabled. But does with everything else wi-fi or cabled.

I better get over to the thread about suggestion to Devs because that turned into off-topic.

You might use and modify this one: with … debian/ buster non-free (without main, without contrib under sources.list).

But even without modifying PureOS sources.list on your TOSHIBA Satellite A660-0QE you might download (with other online computer) to some particular folder:, use cd /home/user_name/firmware command to reach that folder and execute: sudo dpkg -i firmware-realtek_20190114-2_all.deb and this should bring your Wi-Fi to life (perhaps just after restarting your laptop).

PureOS is based on Debian. maybe you should try FIRST creating a boot-able storage medium (usb-thumb,etc. - not spinning disk that is too slow) from the latest Debian 10.5 Buster GNOME live images that ALSO have non-free-firmware included. is your CPU 32 bit only or is it 64 bit (x86_64/amd64) ?

if the CPU is 64 bit only you might have better luck installing Ubuntu 20.04.1 and after you get that working you can see about how to JUMP to PureOS.


Following the instructions, the screen ran though a lot of -stuff- then said I should restart, and did and now there is NO "Wi-Fi " in “Settings”, just Bluetooth. Cable does nothing either.

At the end of the sudo command you provided above, when it was done, it left me with no WiFi in Settings, and the following summary.

me@my-pc:~$ sudo dpkg -i firmware-realtek_20190114-2_all.deb
[sudo] password for inicpure: 
(Reading database ... 201029 files and directories currently installed.)
Preparing to unpack firmware-realtek_20190114-2_all.deb ...
Unpacking firmware-realtek (20190114-2) over (20190114-2) ...
Setting up firmware-realtek (20190114-2) ...
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.132pureos1) ...
update-initramfs: Generating /boot/initrd.img-4.19.0-5-amd64
cryptsetup: WARNING: The initramfs image may not contain cryptsetup binaries 
    nor crypto modules. If that's on purpose, you may want to uninstall the 
    'cryptsetup-initramfs' package in order to disable the cryptsetup initramfs 
    integration and avoid this warning.

I learned 2 of the latest cusswords, and invented 3 new ones

1 Like

Based on the manual, specs are:

Satellite A660-0QE
Intel® Core™ i5-460M processor 2.53GHz, Genuine
Windows® 7 Home Premium, 16.0” HD LED, NVIDIA
GeForce® GT330M, 4GB DDR3, 640GB HDD S-ATA,
DVD Super-Multi Double Layer, LAN, Realtek Wireless
802.11 bgn, Integrated Web Camera, HDMI

Intel® Core™ i5-460M processor (2.53GHz/2.80GHz, 3MB
Smart Cache) With Enhanced Intel® SpeedStep®
Technology, Intel® TurboBoost Technology, Intel® Hyperthreading Technology

10/100 integrated Ethernet LAN
Realtek Wireless LAN (802.11 bgn)
Integrated VGA Web Camera for Video over IP
Integrated microphone for Voice over IP

For the record, this is a 64-bit CPU. (You can get that info from the Intel web site.) Even though the CPU is 10 years old, these days you would struggle to find any Intel Core CPU that is not 64-bit.

I strongly endorse the comment made above by @reC which I will quote:

you might have better luck installing Ubuntu 20.04.1 and after you get that working you can see about how to JUMP to PureOS

You need to fault isolate between
a) limitations of PureOS because it only supports hardware that has freed drivers, and
b) other things that are going wrong.

You can just Live Boot Ubuntu and verify that the ethernet works and verify that the WiFi works - or not. And then decide where to go from there.

Also, it is nearly always easier to get ethernet working than to get WiFi working. Best case for ethernet working: you plug it in. It works. Easy.

So I would stick with that for the time being. Once you have ethernet working then it will be less hassle interacting between this computer and the internet.

When ethernet doesn’t work … a number of things could be going wrong. Yes, it could be that the laptop is using some proprietary ethernet chip for which no driver exists at all under Linux. But you also need to fault isolate

  • bad cable
  • bad port on router
  • failed ethernet negotiation (I note that your specs say that this is 10/100 ethernet only i.e. no gigabit ethernet)

I would start by just looking at the lights on the router. Obviously I don’t know what router you have, so I don’t know what interface and capabilities it has but … did the light that corresponds to the port come on to indicate that the ethernet link is up? do the lights indicate “slow” i.e. 10/100 speed? On many current routers / switches … a green light would indicate “link up at gigabit speed” and an amber light would indicate “link up at slow speed”.

Unfortunately there are a mass of different Realtek WiFi chips and you would need to know which one you have (i.e. model number). Some simply don’t work at all with Linux. Most will work but may need unfreed firmware (i.e. should work out of the box with Ubuntu).

Focus on the ethernet for now.

USB flash drive to move a file to a different computer (that is on the internet)?
Take a photo?


@Sharon as kieran said above there are a number of unknown variables in this equation (many things you did not provide us with or COULD not because you don’t know how to identify them yourself or you don’t know where/how to look for them - it comes with the territory - we weren’t born with this knowledge ourselves you know)

ethernet MIGHT NOT work for you if you connect directly to the ISP gateway(the modem box that is a little bit more complex than a client modem/router/switch) with nothing in between your host machine and the local-gateway … that being said we can’t help you here because we don’t know what/how/where your ISP handles things …

there are MANY ways to connect to the www and i’m not talking about your local host+modem/router/switch combo … have you asked your ISP for support ? or a local technician etc. ? again we don’t know what your particular situation is and things like this tend to be rather SPECIFIC and PROBLEMATIC if you don’t have a general understanding about how things work … even then …


Within BIOS: Advanced Power Settings: “WLAN Always ON” and second link mentions that @Sharon need to have installed (besides firmware-realtek) iw and hostapd. Third option would be how to activate Ethernet within this PureOS combo and fourth issue might be how to make NVIDIA GeForce® 330M graphics work so I would, with this laptop, jump to other Linux distro that includes non-free repo right from the start, as @reC and @kieran already recommended.

@Quarnero @reC @kieran

One thing I’ve learned over the years is, that if I give people all the info I think will help, their replies show they didn’t read that far. If I’m brief, I get blasted. Either way, I concede that most people here know way more than I. And I too wasn’t …

That aside, I may have discovered why the network worked, then didn’t.

It wasn’t a secret, nor info I purposely left out, but some replies turned on a light so I hope the following information helps:

The Tosh laptop that HAD network working with PureOS was set up as follows.

  1. The Tosh had Windows 10. I wiped the drive during installing Linux Mint. And only toyed with Mint a couple of times.

  2. Days - weeks later, I dloaded PureOS, used Etcher to create the USB boot and shoved USB into the Tosh and booted.

  3. Using PureOS, I replied or made a post here that indicated PureOS was working. WooHoo!

  4. I saw the Install PureOS icon in the “Activities” menu and wiped the drive during the PureOS O/S installation.

  5. I could no longer connect Wi-Fi - should I have repeated those errors, and the suggestions I followed to enter SUDO’s?

SUMMARY: I am only guessing, but think that perhaps the USB version of PureOS was using the Mint drivers on the HDD to connect. When I removed Mint, it removed the drivers?

What @kieran and @reC recommended is way over my head. I’m not sure where one starts learning all that without a great deal of time catching up to the two. But I have other ltops I can sacrifice. As it stands right now with ltop O/Ss; I have Win 10, Win 7, Ubuntu 20.x, and a Debian (which I’ve not touched since install) plus this PureOS one that had/has no network - yet/again.

IMHO: If PureOS and Librem are to become popular, they have to be as easy, or easier than the competition. I started this journey to restore my right to privacy, or fight for it with Librem and PureOS as my sword and shield - not support a long and steep learning curve. Or is it for hobbyists and geeks alone.


1 Like

$ sudo lspci -v will show you detailed information about all devices and you should post here info about the one you need help with.

Also, as we can see above your laptop don’t like (sort of) cryptsetup-initramfs. Why not to try to remove it, if helps:

$ sudo purge cryptsetup-initramfs

And repeat: $ sudo dpkg -i firmware-realtek_20190114-2_all.deb

If PureOS developers doesn’t provide support for non-free repo why should I try to fix this? Even Index of /cdimage/unofficial/non-free from Debian is unofficial (but why that is so cannot be another discussion here), as well. And, does Debian Gnome looks or feels much different than PureOS Gnome?

P.S. With dpkg --get-selections someone might take all (other than their self-maintained ones) of PureOS packages to minimal Debian if chosen by someone to do so … if there are other ways that we my rethink over how to modify PureOS main approach (but this is not part of subject how to help you with your PureOS/TOSH combo).

both PureOS and Ubuntu are “forks” of Debian so they are more like different flavors of the same GNU/Linux Debian … but yeah having every type of firmware shoved in there (both free and non-free) does tend to make people think that Ubuntu is easier to install because it supports more HARDWARE out-of-the-box but that does NOT make it a better solution for people …

The live USB (the one you plugged in and ran PureOS off of before you installed it to your system) uses its own drivers and software to do everything, so it wasn’t using mint’s.

Honestly, that being the case coupled with the fact that you can see the WiFi network(s) leads me to believe that this isn’t a driver issue, but rather a connection one. I’ll do some searching for you and see if I can’t find something useful.

1 Like


that is my impression so far as well …

So this is all I was really able to find, which does suggest it could be a driver issue. Maybe so, I’ve had things work on live USBs that didn’t after installation, but they were usually graphics related, never wifi.

Also, if I’m remembering correctly, you said that either you misspelled your wifi password initially or it acted like you did. You can try going into your network settings, then to your connection settings for your network, and enter the password in manually there and see if it takes.

My only other idea is to back up your stuff, reinstall the OS, and try again. A bit extreme, but straightforward, at least.

1 Like

Yes, I would repeat installation too. And, if it is about RTL8191SE this modified version of the RealTek WiFi driver fixes some issues with RealTek cards on Linux.

Nothing to backup. As I said, it’s a tryout as intro Librem products PureOS features. I don’t care if the laptop opens a hole and swallows me up :slight_smile:

I’ll retry installing and if possible, have it wipe the drive again.


1 Like