Command line won't take password

Terminal will not take any keypresses with [sudo] password for purism: [] after about a minute, the cursor (that’s me now) stops blinking, but still won’t take any input.
I’d provide a screen cap, but that’s what I’m trying to install - a screen cap.
Catch-22 :face_with_symbols_over_mouth:

Is the Ctrl key activated? If so, you have to click it off.

1 - tried it again with CTRL On, because it was always off, and with On, I am permitted to enter one character - the number “1”, after that nothing, screens goes near black and I wait for the screen ti lighten up, enter password and and it doesn’t move. If I can, I’ll change the password to “11” because that’as all it accepts before either it thought Enter was pushed. I’m not stupid. The device was setting flat on a table top, I was extremely careful to hit the right keys.
With CTRL closed, the line accepts nothing - just the Enter key.

2 - It’s hard too because the screen has decided it will cycle through bright as bright can be, then every 2 seconds, cycles 1 shade darker, and I try to hurry, but can’t keep up, with that, nor the jumping out to desktop.

I set the display brightness to middle. Auto to Off. It isn’t even a good strobe light.

I put a sticky on the back as a reminder how much it cost, so I don’t throw it onto the highway!


That sounds really frustrating :frowning: Do you have a bluetooth keyboard available that you can connect to, to type in the password? (might still be hard if the screen is dimming on you)

My current phone is a Pinephone, but runs phosh so has the same interface. I’ve gotten pretty good using the Terminal in “phone mode”, but I can definitely say it is easier using the Terminal when I have a keyboard connected to it.

Seriously! I need to drag a keyboard around with me every time I want to access this this …
The ‘device’ is tap enabled. If it can’t let me put in the password using tap, what else is FUBAR in it? Let me show you a list! It lets me use several attempts to login past the crypt, and then to desktop. I hear two of three ain’t so bad. Why did I have to pay for this!!!

There is a serious issue with this device (doesn’t deserve name ‘phone’, cell’, and certainly is not a ‘smart’ one). The taps freeze, the app page (i.e. Contact, Settings, etcetera) works, sometimes, else reboot. And a lot of other issues. Something in this should work without the need for buying equipment to make it work. If it worked for me, it’ would have been fired out the door yesterday afternoon after 5 days of trying and following suggestions. Problem is, I can’t get what most want without dling or sudo’ing their suggestions.

I’m not dragging a keyboard, and will need mouse (tap is overly aggressive) to a meeting and take out my device, while others are sitting their with theirs, and haul out a keyboard and mouse. Would make a funny video tho.

Anyway, I’m pretty PO’ed, and with the device, in a dark place right now so I should shut up before stomp on this -thing- and explain why would get me kicked out.

Off to relax with some Call of Duty.

My understanding, from the other thread, is that you might have a rogue process running in the background eating up the CPU, and making the phone more or less unusable.

If that was happening on my Pinephone, again I’d run htop (my suggestion from the other thread). Among other things you’d need the Terminal for is to install htop (if not already installed), and then to run htop once installed.

If there is a rogue process, then once it is identified and eliminated, the phone might start working correctly. That said, I don’t have my Librem 5 yet, so am not familiar with the hardware. It is possible something is wrong with the device itself, but I hope it is a software issue so that it can be fixed.

“htop” Command not found" I’m not permitted to input my “password” when getting htop via terminal sudo etcetera. terminal won’t accept any keypress at the password enter. Just blink for a awhile then hangs.
That, or the thing is possessed. I cannot continue with your suggestion, because:

  1. Following another suggestion, I opened “Settings” and went to “Power” and am stuck. I think to turn off the device is to push the top right button in. I’ve done that too, but power on takes me right to “Power” again. There is no swiping, no tap the back button, it doesn’t work anywhere. IMO: It’s junk.

Maybe, if I drain the battery, not hard to do, no - that won’t close the darned Power window. Kewl. I didn’t think anything could get worse. The screen just changed. Good! Midnight shading everything. Where’s a gun when ya need one.

The WiKi has misinformation, or the device refuses to agree with the WiKi but a lot of stuff in the pictures isn’t on this phone, like working back buttons, input cell, power button on-screen.

I still don’t know if the device is off enough to insert a ‘optional’ storage card.


sudo won’t visually acknowledge your key presses. This is a security feature in the vast majority of Linux distros, although its usefulness is subject to debate. Linux Mint, for example, disagrees with this practice and will display asterisks.


I figured that, so before I listed this umpteenth bug/glitch/ I tried just entering the whole pass-thing already a few times. Thanks anyway.

You are very clever person indeed.

Finally you are at the point where you might want to take Librem 5 battery out (and insert precisely leveled cards).

Why has everyone ignored the question? "

I’ll unplug the pwr supply, and turn it on and let it run dry, then take out the card. That should be OK - right? I read about the “Press the POWER button until HTC U12 life vibrates”. Have no idea what or who HTC-U12 is/was/or might be.

Thanks very much,

You are not allowed to do this. @dos warned about related already. Librem 5 needs to be treated as home pet and not like some wild animal.

Please use: sudo systemctl poweroff before you start do destroy your Librem 5 microSD card slot.

EDIT: microSD cardreader not working tells us: “please move the tray only when the phone is off, it isn’t really meant to be hotplugged”.

As far as I understand, using sudo is no option.
Entering a password is not possible.

As far as I understand usage of sudo works on every Librem 5 out-of-the-box.

EDIT: @shopping4purism, you are anyway very welcomed to help @Sharon with usage of passwd, if 123456 still counts on this particular Linux smartphone.

You didn’t read it!!! :face_with_symbols_over_mouth: and you point the shame-finger at me!
Recall that help if you can from @shopping…, because you have, unintentionally I’m sure, misled them as to the unread issue.
Could you hear me all the down to California? Good. Cause I still need to get the thing fixed.

BTW sudo worked, right out of the box. Still works as a matter of fact. Never said it didn’t.

1 Like

maybe, treating people as home pet and not like some wild animal; will improve the Forums image.
Stop insulting. Thanks for your past help. Bye.

Don’t follow this advice. HTC U12 is some other phone.

1 Like

Poppycock. I just used sudo’d, and found a way to circumvent the CPU hog long enough I could get all the numbers in without a problem. READ More please ->>> The issue was never with Sudo NEVER. It is/was about sudo, then password - tapping in 123456 and the hog burps, and it might look like 123 and that’s it. Since we are blinded from viewing what we’re tapping what goes, be it counting the asterisks or seeing the cursor move and gather the dev team was short of asterisks so I rightfully assumed nothing was going in, and I looked, and I read, and read all day and into late tonight.

Later. I forget who (sorry who) told me that it’s done on purpose. That makes it hard when one is typing and looks at their screen to see 12 words, and the rest din’t go in while the beats was busing using the resources.

Too, some things simply freeze. I’ve used clever phones (no such thing as smart phones), tablets, laptops, and desktops since 1981 - before Internet, before PC’s were normal in-home demons.

I very much appreciate the help, but multitasking has proven that reading one thing while listening to someone, or watching something unrelated reduces a mans cognitive skills to that of a 8 year old. I am not suggesting anyone is acting like a child. But it cover what I said earlier, some people are not reading it all.

It’s probably difficult for people working here to run between people an their issues and cognitive hammer kicks up a hiccup. I sure wouldn’t want the job.

Now, we are at the stage where insults and innuendos have gone too far. How do I arrange a refund and where do I start? I read it is easier to do than to fix the phone.

This photo looks just fine to me:, as I wasn’t requested to made one and as I recommended fine horizontal aligment of both cards in my post, because those weght almost nothing and replying here if this important point of mine missed.

This actually isn’t true, from what I’ve read. I think your next option at this point is reinstalling the operating system.