CPU usage when compiling on the Librem Mini

I’m compiling with gcc on the Librem Mini v1 (using 6 threads) and I notice they are all running at about 1Ghz and CPU usage on those threads is 100%. What’s going on?

Thermal throttling?

Or just CPU throttling? The Max Turbo Frequency only (necessarily) applies to a single core. Intel reserves the right to apply a lower maximum turbo frequency when more than one core / all cores are active (in order to meet the design goals re power consumption and heat dissipation).

However if it’s gone all the way down to 1 GHz, it sounds more like thermal throttling. Check the system log.

Is the fan spinning fast?

I suspected some kind of throttling too. I’ve never seen the temperature go above 45C. The CPU is running at 100% (while compiling) and below its base frequency. I’ve tried both the powersave and performance governors, the result is the same.

Screenshot from 2021-04-09 11-52-53 !

Check the CPU parameters described here: How to reduce annoying fan noise.

That seems to be for disabling turbo frequencies, no?

Yes. I suggested to check whether something is disabled or underclocked for you.

Nothing as far as I’m aware.

I just noticed the same thing happens when rendering a video. CPU usage at 100% each core/thread running around 1GHz. Is there something in Coreboot that throttles the CPU?

Does the system log show any messages about throttling?

it might be thermally bottle-necked but you still have the harder POWER-draw limit of the PSU-brick so even if you would mod a librem-mini unless you ALSO lifted the power-constraints i doubt you would get much better out of such a compact/mobile system …

want performance and greater-heat-dissipation capabilities ? get a desktop/workstation/server in a sufficiently spacious enclosure with a beefy cooling system …

@kieran I don’t see anything unusual in the log or anything indicating throttling.

@reC I don’t think this can be a thermal issue. The CPU temp never rises very much. Even on a fresh boot I have the CPU limit when compiling but the temp can be 30-35C.

For other things I’ve had the CPU running at 4GHz on all cores so I don’t think there is a power limit issue here either, but then again they weren’t running at 100%.

ah Morgan ! i forgot it was you …

yes in your case the LMini sits in your moded case so it shouldn’t have thermal problems but that PSU-brick on the other hand is not made to handle more than ~40 watts (19V@~2.1A) … the v2 should have more wiggle room but it’s power delivery system still has the drawbacks of a mobile PC. not that i’m complaining, just sayin’

Aha but I’m using this PSU - https://hdplex.com/hdplex-internal-200w-ac-dc-adapter-with-active-pfc-and-19vdc-output.html


1 Like

says it’s ~200W (19V-DC@~10.5A) rated … so you are NOT using the default Purism brick ? i was under the impression that this was only an ADAPTER and not the actual PSU itself ? either way the VRM system inside is mobile class so you still get horrible noise under certain loads …

1 Like

I’m not using the default brick.

1 Like

@MrChromebox Does Coreboot do some kind of power throttling/limiting to the Librem Mini?

I used the Stress tool to apply a load to the CPU then ran powerstat. The power consumption started at 28W then dropped to 15W after a few seconds. Temp was around 35C. At idle the power goes down to 5W.

all firmware does. coreboot sets the PL1 (long term) power to 15W and PL2 (short term / turbo boost) to 28W. Thermal design would allow much higher, but have to stay within the limits of the 40W PSU shipped with these units.

Any way I can adjust this? I’m using a 200W PSU.

sure, recompile coreboot with the PL1/2 values adjusted for the Mini (in src/mainboard/purism/librem_cnl/variants/librem_mini/devicetree.cb)