Crimson Experience

When there will be a completely flashable build without the u-boot procedure … I will flash this also for a test

1 Like

Great, I also have a few new experiences to mention:

  • Extensions can now be installed directly from the same tab, but may require landscape orientation in order to install them.
  • GNOME Calendars requires temporarily using landscape orientation in order to edit details of previously created events.

Question here:

Somebody who can give a short report of using the Build from Jenkins on a daily or regular base?

I only know for now that the Cam is not working. But all the others like BT, GPS, Suspend, the energy consumption?

And all phone specific experiences like Calls and SMS?



1 Like

SMS works fine.

But no sound via microphone. The system settings allow me only to select as imput the

Analog Input - Modem


● pulseaudio.service - Sound Service
     Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; enabled; preset: enabled)
     Active: active (running) since Tue 2024-04-09 17:40:34 UTC; 23s ago
TriggeredBy: ● pulseaudio.socket
   Main PID: 741 (pulseaudio)
      Tasks: 4 (limit: 3067)
     Memory: 22.5M
        CPU: 587ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pulseaudio.service
             └─741 /usr/bin/pulseaudio --daemonize=no --log-target=journal

Apr 09 17:40:32 pureos systemd[717]: Starting pulseaudio.service - Sound Service...
Apr 09 17:40:34 pureos pulseaudio[741]: No such profile: HiFi
Apr 09 17:40:34 pureos pulseaudio[741]: Sink alsa_output.platform-sound.HiFi__hw_L5__sink does not exist.
Apr 09 17:40:34 pureos pulseaudio[741]: Source alsa_input.platform-sound.HiFi__hw_L5__source does not exist.
Apr 09 17:40:34 pureos pulseaudio[741]: No sink found by this name or index.
Apr 09 17:40:34 pureos pulseaudio[741]: No source found by this name or index.
Apr 09 17:40:34 pureos systemd[717]: Started pulseaudio.service - Sound Service.
Apr 09 17:40:41 pureos pulseaudio[741]: module-x11-xsmp may not be loaded twice.
Apr 09 17:40:41 pureos pulseaudio[741]: Failed to load module "module-x11-xsmp" (argument: "display=:0 xauthority= session_manager=local/pureos:@/t>```
1 Like

Confirm your camera/microphone hardware kill switch is disabled, restart your phone with a microphone headset connected, then test your audio configuration against GNOME Sound Recorder.

No way, no sound input and pulseaudio does not run on startup

1 Like

Flashed back my Byzantinum backup and all works as expected.Also the microphone and loudspeaker in calls.

The build from Jenkins maybe was faulty? Perhaps someone using Crimos here cann upload his running build on any filehoster?

1 Like

This was my experience. I had byzantium as my daily driver. A Couple of days ago, I flashed a crimson image (I think it was a Mar 22 stable build). Everything was working well, even suspend, resume from suspend, SMS (didn’t test MMS), docking with hoyoki dock. I didn’t test GPS though. And, I had sound on the phone.

Then yesterday, I got a call, and I heard no sound, and I realized my Input source wasn’t working on the phone. This was a show stopper so I switched back to byzantium last night.

The audio (on phone calls) is the main issue right now. I have audio in regular web browsing, and some system sounds. The alarm didn’t work though, I woke up late monday morning :slight_smile:

I also noticed that the compositer doesn’t quite scale all apps correctly. Some apps would overrun the screen (gnome settings, and a few other apps). Also, like to set my display to 150% and then use gnome-tweaks to increase font size. That wasn’t working on most apps. Some apps fonts would scale.

Also, I often use the right-click and paste into a terminal window so I don’t have to type in long URL’s. that wouldn’t work for some reason.

The mobile friendly tools that user0 developed, worked on librewolf, but not on firefox. But, I think that is due to how FF does the default profile, etc.

So, if it wasn’t for the audio not working on calls, the modem works fine, I could use crimson as a daily driver for my basic needs. Some things would be annoying, but the phone would be functional.

Of course the camera is still in dev, but I don’t rely on the camera much.

Also, I like using vpn, and it has been a pain with the resume from suspend. That always creates headaches, often times i need to hard reboot if I don’t disconnect vpn before it goes into suspend. I was hoping that might be fixed with crimson, but not yet.


The Clocks’ alarm function works fine for me.

That also works fine for me at the moment.

1 Like

Calls work GOOD in Crimson like Byzantium? I know you are the best related to Crimson.

1 Like

Which image did you flash? the date. That shouldn’t matter as the updates should bring it all to the same point, but just curious.

1 Like

I have not called anyone yet on Crimson.

The same as yours, #264.

1 Like

Ok, good to know. I will try reflashing again next week. I need a reliable phone for in the meantime.

1 Like

Alarm not working from suspend was, I think, a known problem in byzantium and maybe it is the same in crimson i.e. not worse or better? Were you using suspend overnight?

pulseaudio not starting may also be a known problem. It can probably be worked around. I suggest searching the forum.


No, I had the phone plugged in so it was not in suspend mode.

Yeah, I will look around. Since the Output mode was working fine in gnome-control-center, It was sort of half working. I just panicked when I missed 2 important calls, and I don’t have time this week to debug, so I will give it a try next week.

The general experience though re-iterated to me the thoughts in the thread about crowdsourcing funds to finish crimson. I remember Guido feeling there wasn’t much work left. There are some things to work out like camera, but otherwise, crimson seems pretty close to being viable?!?


Honestly I am … more or less … very much disappointed with the Crimson build on Jenkins :frowning:

The absolute basic and minimum work of a phone - making and getting phone calls do not work. And nobody seems to have an idea how to fix it. There must be greatly exist a problem with the soundsystem itself. Also system sounds do not work and there is no ringtone on receiving calls.

And there were also some other glitches and I fear ATM nobody has any time or money to fix this.

For the future of Crimson I have no good feeling anymore

I greatly fear that we perhaps must bury all hops receiving a running and working build of Crimson for the future

1 Like

For me also the --no-sound – in calls were the showstopper and I switched back to Byzantinum :frowning:

1 Like

It works fine for me. I just learned that the “Front Left” speaker is near the base of the phone, and the “Front Right” speaker is near the camera.

1 Like

There is NO microphone selectable. There is simply no device I can select in the input section. Just empty.

And if I select something like speakers in the output the system settings will crash.

Therefore the question which build used?

How often are the builds updated? I see that the last builds have all the same size ?

1 Like